Results 1 to 2 of 2

Thread: If you have problems with knetworkmanager in 11.4

  1. #1
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default If you have problems with knetworkmanager in 11.4

    An unknown problem with NetworkManager-KDE, aka knetworkmanager, will sometimes
    disable wireless even when 'rfkill list' shows no block. My "fix" for this is to
    create a small script to stop and re-start knetworkmanager. To date, this has
    worked every time.

    The script has the following content:

    Code:
    #!/bin/sh
    #
    # Restart knetworkmanager to re-enable wireless
    #
    killproc knetworkmanager
    knetworkmanager > /dev/null 2>&1 &
    Put the above information in a file named ~/restart_knetworkmanager, then issue
    the command

    Code:
    chmod a+x ~/restart_knetmanager
    That makes it executable, When you get "Enable wireless" grayed out and it is
    not caused by any rfkill switch, then enter the command '~/restart_knetworkmanager'.
    Last edited by Jonathan_R; 07-May-2011 at 10:51. Reason: fixed typo

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: If you have problems with knetworkmanager in 11.4

    Very nice lwfinger, thanks for the script. By the way, if you place the script into ~/bin, then you can run it as just restart_knetworkmanager. Anyway thanks very much.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •