Results 1 to 9 of 9

Thread: deleteing folders and files

  1. #1

    Default deleteing folders and files

    I am running Open Suse 11.4 using KDE4, and whenever I try to delete a file "move to trash" it gives me a popup saying "The trash has reached its maximum size! Cleanup the trash manually." and when I go to the trash can it is empty.....happens both on trying to delete files from Linux Partition or the Windows Partition, and I do have it set to allow me to have read and write access on Windows...what do I have to change to be able to delete files

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: deleteing folders and files

    You could set YaST to clear your temp folders and reboot to see if that might help.

    Open /etc/sysconfig/cron, search for a line saying

    Code:
    CLEAR_TMP_DIRS_AT_BOOTUP="no"
    ...and edit "no" to "yes". This could also be done via GUI: YaST → "Editor for /etc/sysconfig".

    Code:
    /System/Cron/CLEAR_TMP_DIRS_AT_BOOTUP
    Both examples do exactly the same thing, so you only need to do one of them. Just one thing you could try. Following is a warning from another user

    Be careful with this setting. I had it too, just thought it is good system maintenance. ...then ..
    I was working on a letter (OO) and we had an power blackout. restart....could not recover the file. I changed the setting MAX_DAYS_IN_TMP=2 for 2 (days) and left CLEAR_TMP_DIRS_AT_BOOTUP=no.
    However, you can use this setting as yes, reboot to clear everything and then change it back to no and then use MAX_DAYS_IN_TMP=2 thereafter.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: deleteing folders and files

    Made change to /etc/sysconfig/cron to yes and rebooted.....no change, still getting the error msg......"The trash has reached its maximum size! Cleanup the trash manually."......I do not have the problem if running GNOME only in KDE

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: deleteing folders and files

    Check the directory '~/.local/share/Trash/files.' Do you have any files there?

  5. #5
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: deleteing folders and files

    Quote Originally Posted by nitewalker41 View Post
    I am running Open Suse 11.4 using KDE4, and whenever I try to delete a file "move to trash" it gives me a popup saying "The trash has reached its maximum size! Cleanup the trash manually." and when I go to the trash can it is empty.....happens both on trying to delete files from Linux Partition or the Windows Partition, and I do have it set to allow me to have read and write access on Windows...what do I have to change to be able to delete files
    Use Konqueror or Dolphin to change your Trash settings. In Dolphin, for example, you can find that under the menu Settings > Configure Dolphin ... > Trash. I am not sure what exactly you need to set there, but I think your issue lies with limiting the trash to a maximum size.

  6. #6

    Default Re: deleteing folders and files

    When I ran the below I got following results of 0.....if I did it right anyway
    nitewalker@linux-w71t:~> cd ~/.local/share/Trash/files
    nitewalker@linux-w71t:~/.local/share/Trash/files> ls -l
    total 0

    Did what "Lord Emsworth" suggested and cleared the check mark from "limit to maximum size" in Dolphin and all works as advertised, thanks to all of you for you assistance, really appreciate it, so this is now solved....thanks again

  7. #7

    Default Re: deleteing folders and files

    Hi.
    I'm using OpenSUSE 11,4 and that message pops me up when I was trying to delete a lot of files. My trash can was configurated with LIMIT TO A MAXIMUM SIZE checked... well, I'm unchecked it, clicked OK and it works fine. No problems until now!!

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: deleteing folders and files

    Quote Originally Posted by fonsecafabio View Post
    Hi.
    I'm using OpenSUSE 11,4 and that message pops me up when I was trying to delete a lot of files. My trash can was configurated with LIMIT TO A MAXIMUM SIZE checked... well, I'm unchecked it, clicked OK and it works fine. No problems until now!!
    It sounds like you reached your max. Why don't you raise that, if it's a problem, or leave this unchecked?

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,914

    Default Re: deleteing folders and files

    Quote Originally Posted by nitewalker41 View Post
    I am running Open Suse 11.4 using KDE4, and whenever I try to delete a file "move to trash" it gives me a popup saying "The trash has reached its maximum size! Cleanup the trash manually." and when I go to the trash can it is empty.....happens both on trying to delete files from Linux Partition or the Windows Partition, and I do have it set to allow me to have read and write access on Windows...what do I have to change to be able to delete files
    It happens to me if I don't have enough space on my home partition to store the file in trash. Can you check the output of :
    Code:
    df -h
    to see if that is the case ?
    You can use Shift+Del to permanently delete, which is what I use.
    Best regards,
    Greg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •