Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Dimb YAST> Software Managment >Upddates question.

  1. #1
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Question Dimb YAST> Software Managment >Upddates question.

    OK when I go into Software Management > Repositories > Updates I see some packages that are in red. These are packages that are to be rolled back. When I select the check mark/ tick mark it goes to an X. Is it going to be rolled back or removed when I select like this? I haven't been rolling back because I don't want to screw up and bork my system and I have quite a few of these today.
    Tumbleweed

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Dimb YAST> Software Managment >Upddates question.

    Check the version tab on the bottom right. See where each available version comes from and then you can make the decision to keep or replace.

  3. #3
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Dimb YAST> Software Managment >Upddates question.

    I am not so much worried about where the packages or libaries come from as I am making sure I am just rolling back and not removing the package totally. What action does that "X" represent is what I want to know. Is it a remove or roll back?
    Tumbleweed

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Dimb YAST> Software Managment >Upddates question.

    I think removed but the version info is important since you may have installed something from and one repo and added another that has a newer package.

    You can select the version from the version tab.

  5. #5
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Dimb YAST> Software Managment >Upddates question.

    I am not so concerned with where is comes from since I only have the standard 11.3 repos and Packman installed. I have Packman set to 90 so if it's a pm package I have installed that is what will be rolled back/updated to otherwise just the standard openSUSE updates.

    Removed is not good. Removed breaks things. How do I make it roll back instead?
    Tumbleweed

  6. #6
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Dimb YAST> Software Managment >Upddates question.

    Quote Originally Posted by FlameBait View Post
    I am not so concerned with where is comes from since I only have the standard 11.3 repos and Packman installed. I have Packman set to 90 so if it's a pm package I have installed that is what will be rolled back/updated to otherwise just the standard openSUSE updates.

    Removed is not good. Removed breaks things. How do I make it roll back instead?
    Show a screenshot of such a package including the tab labelled "Versions". However, from your description it sounds as if there were no package to roll-back to.

    ETA: You are not looking at VLC packages perchance?
    http://forums.opensuse.org/english/g...-11-4-a-2.html

  7. #7
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Dimb YAST> Software Managment >Upddates question.

    This is strange. When I went to grab the screen shot I noticed the red packages in YAST> Software> Management> Repositories> Updated for openSUSE 11.3 11.3-1.82 were no longer highlighted in red. I did all the updates that were on blue (packages for which updates were available) the first time through. Now when I go back in to YAST > Software Management the repos are not scanned and the red entries are not present. Did doing the updates satisfy some dependencies or do I need to force it to rescan some how? These were all most all pm multimedia packages and libs that I updated.
    Tumbleweed

  8. #8
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Dimb YAST> Software Managment >Upddates question.

    Quote Originally Posted by FlameBait View Post
    This is strange. When I went to grab the screen shot I noticed the red packages in YAST> Software> Management> Repositories> Updated for openSUSE 11.3 11.3-1.82 were no longer highlighted in red.
    Look at the pseudo-repository "@System" instead.

  9. #9
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Dimb YAST> Software Managment >Upddates question.

    I did a reboot and looking at the @system I picked one package that is red.

    There is no other version available. Pretty much makes it a non issue.


    So it's just YAST being unhappy it seems.
    Tumbleweed

  10. #10
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Dimb YAST> Software Managment >Upddates question.

    Quote Originally Posted by FlameBait View Post
    There is no other version available. Pretty much makes it a non issue.
    Yes, that is it. (And while the package libdvdcss has Packman as vendor, it does not come from the Packman repository. It comes from the libdvdcss repository. So if you wanted to update or re-install it you would need to enable that repo again.)

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •