Results 1 to 6 of 6

Thread: Samba setup help

  1. #1

    Exclamation Samba setup help

    First off, I'm following this HowTo:
    Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x

    I'm running into trouble with the tip "Switching Samba on:". When I open System Services in YaST, the SMB daemon is enabled under "Simple Mode," but not under "Expert Mode." Also, in Simple Mode, the Yes is followed by a *. Like this: Yes*

    What does this star (*) mean? Is Samba enabled or not? Also, in expert mode, runlevels 3 and 5 are checked off. Is this correct? When I choose "Start Now...", while selecting SMB in expert mode, the NO turnes to Yes, however, when I click "OK" (closing System Services) and re open it, SMB is back to No in expert mode.

    Any help or insight would be greatly appreciated!
    Thanks,
    Ben

  2. #2
    Join Date
    Dec 2009
    Location
    Moldova
    Posts
    130

    Default Re: Samba setup help

    An asterisk (*) after a service status means that the service is enabled but not running or is disabled but running now.
    It seems that you have well know problem with AppArmor. You can just disable AppArmor at all from Yast/AppArmor Control Panel.
    Then you can enable just in simple mode the samba server, or just set in Yast/Samba Server/Service Start/During Boot.
    Also you can set all options of Samba server here in Yast/Samba Server.
    the service start/stop/restart can be done also from shell rcsmb start, rcsmb stop, rcsmb restart

  3. #3
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,451

    Default Re: Samba setup help

    In another thread, a solution is listed that is a bit different. In the AppArmor control panel, set smb and nmb to Warning and that will let it run without shutting off AppArmor altogether,
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  4. #4

    Thumbs up Re: [Solved] Samba setup help

    Thanks to both of you. Both solutions worked! For the time being, I've completely shut off appArmor until I'm done configuring Samba. Once I'm done I will place nmb and smb under warning. Thanks Again!

    Here I'm going to diverge from the topic a bit:
    I have also been having problems with my backup cronjobs running. I have set them up in webmin 1.540. Could this also be caused by appArmor?
    Thanks Again!
    Ben

  5. #5
    Join Date
    Dec 2009
    Location
    Moldova
    Posts
    130

    Default Re: Samba setup help

    as far as I know there is no any conflict of crontab with AppArmor. But you can disable it if you have some suspicions. I don't use webmin but, as I understand, at the end of day, it should add in the crontab a line with your command. So you can check if it was added by running "crontab -l" in the shell (with user you've added it).
    If it is there then check parameters, logs...

  6. #6

    Default Re: Samba setup help

    Quote Originally Posted by isemionov View Post
    as far as I know there is no any conflict of crontab with AppArmor. But you can disable it if you have some suspicions. I don't use webmin but, as I understand, at the end of day, it should add in the crontab a line with your command. So you can check if it was added by running "crontab -l" in the shell (with user you've added it).
    If it is there then check parameters, logs...
    You were correct. I disabled AppArmor and my cronjobs still are not running (even after re-setup in webmin). I will open a new thread for this thanks.
    The link to the new thread is below:
    Webmin CronJobs not running

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •