Results 1 to 4 of 4

Thread: upstart changed to systemd = boot problems

  1. #1
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    248

    Default upstart changed to systemd = boot problems

    What is the correct/safe way to move from upstart to systemd?

    I originally installed upstart in 11.3 and have now upgraded to 11.4. Having successfully upgraded to 11.4 I tried to use yast2 to install systemd and systemd-sysvinit onto my running system. Yast correctly identified that upstart should be deinstalled as a prerequisite for installing systemd-sysvinit.

    After the install of systemd the system wouldn't shut down, and on a reset the system reported many systemctl/start service timeouts on things such as mounts and ttys. Eventually the system started an X-windows KDM login, but there were no console ttys and mounts were missing.

    I used X/kdm to login to root - phew! - I restored / from an rsync backup I'd made prior to the changes, so I'm back in business with upstart. I'd like to tidy up and move to systemd - so any info on how to make the move would be appreciated.

    I going to have a nose around myself, perhaps I will try switching back to sysv init and then going to systemd - but I have to wait for the machine to be idle before I experiment, any info in the mean time would be great.

  2. #2

    Default Re: upstart changed to systemd = boot problems

    Maybe this could help: SDB:Systemd - openSUSE ?

    And this: openSUSE:Systemd status - openSUSE

    On the latter you have a link toward "How Do I Convert A SysV Init Script Into A systemd Service File"

    Cheers.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: upstart changed to systemd = boot problems

    Uninstall systemd-sysvinit. I think a dep will be the reinstall of sysvinit. All good. Now after that add "init=/bin/systemd" to the boot options line, or to /boot/grub/menu.lst on the line for your kernel, right after the "vga=..." statement. Works great here. Saves 3 secs from GRUB to login, makes starting LibreOffice much faster.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    248

    Default Re: upstart changed to systemd = boot problems

    Yes that worked (after de-installing upstart as well) - thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •