Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Auto-login & a Blank, Black Desktop

  1. #1
    Join Date
    May 2011
    Location
    Etobicoke, Canada
    Posts
    5

    Unhappy Auto-login & a Blank, Black Desktop

    Hi, guys:

    First off, lemme say sorry if I'm repeating a topic. I'm not entirely sure what keywords to search the forum for.

    Now, to describe my problem:

    I installed openSUSE 11.4 from the DVD and was being fairly liberal with the features I was adding so I could see what was offered. At installation, I installed all the desktop environments (KDE, GNOME, Xfce, LXDE and all the lesser ones that came with them (like IceWM, etc.)).

    So, last night, I was testing out all the desktops one-by-one to see what they looked like to decide which I would keep and which I would get rid of if it ever came to cleaning the partition.
    I tried one, the name of which I've regrettably forgotten, and the desktop was just blank... completely blank. I just had a blank, black screen and because there was no GUI, I didn't know how to interact or log out. Naturally, I restarted the machine, only to be brought back into that same desktop (I had enabled auto-login during installation).
    At first I had thought that the system was broken, but I hit the PrntScr button while going crazy on the keyboard and the screenshot dialog popped up. I clicked "Help" and searched "keyboard shortcuts" in the hope that there'd be a shortcut I could use to log out. As you might have guessed, I had no luck with that.

    I figure my last hope is either:
    A) To find a Terminal command that will turn off auto-login, or
    B) Just re-install everything from scratch.

    So, my question is: Does anyone know any commands that can do this or maybe not that exactly, but still fix my problem?




    PS: When the screenshot dialog came up and, consequently, the help windows, their title bars looked like Xfce's windows' title bars. I also tried some keyboard shortcuts (like Alt+F2) which would usually work, but didn't.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Auto-login & a Blank, Black Desktop

    Get ye to a command line. (hint press 3 at the boot then enter to continue) Log in as root.

    type yast this is the command line version so you need to use arrow keys and tabs to navigate

    find System-/etc/sysconf editor select then go to Desktop-Display Manager-DISPLAYMANAGER_AUTOLOGIN and set it to blank
    This should force a login screen.

    While in the editor you can look at and maybe change the default Window manager it is in Window Manager-DEFAULT_WM

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Auto-login & a Blank, Black Desktop

    On 2011-05-03 23:06, calmblythe wrote:
    > I clicked "Help" and searched "keyboard shortcuts" in
    > the hope that there'd be a shortcut I could use to log out. As you might
    > have guessed, I had no luck with that.


    Right click? :-)
    Perhaps with control.

    > I figure my last hope is either:
    > A) To find a Terminal command that will turn off auto-login, or


    ~> grep -i login /etc/sysconfig/*
    ....
    /etc/sysconfig/displaymanagerISPLAYMANAGER_AUTOLOGIN=""


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Auto-login & a Blank, Black Desktop

    On 2011-05-03 23:06, calmblythe wrote:
    > Naturally, I restarted the machine,


    ctrl-alt-bckspace, twice.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5
    Join Date
    May 2011
    Location
    Etobicoke, Canada
    Posts
    5

    Default Re: Auto-login & a Blank, Black Desktop

    Quote Originally Posted by gogalthorp View Post
    Get ye to a command line. (hint press 3 at the boot then enter to continue) Log in as root.

    type yast this is the command line version so you need to use arrow keys and tabs to navigate

    find System-/etc/sysconf editor select then go to Desktop-Display Manager-DISPLAYMANAGER_AUTOLOGIN and set it to blank
    This should force a login screen.

    While in the editor you can look at and maybe change the default Window manager it is in Window Manager-DEFAULT_WM
    Thanks sooo much!!
    I tried it and rebooted and I had to authorize my login. The name of what I'd logged into last is Metacity.

  6. #6
    Join Date
    May 2011
    Location
    Etobicoke, Canada
    Posts
    5

    Default Re: Auto-login & a Blank, Black Desktop

    Quote Originally Posted by robin_listas View Post
    On 2011-05-03 23:06, calmblythe wrote:
    > Naturally, I restarted the machine,


    ctrl-alt-bckspace, twice.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)
    I tried that and all I got for my trouble was an obnoxiously loud beep. xD

  7. #7
    Join Date
    May 2011
    Location
    Etobicoke, Canada
    Posts
    5

    Default Re: Auto-login & a Blank, Black Desktop

    Quote Originally Posted by robin_listas View Post
    On 2011-05-03 23:06, calmblythe wrote:
    > I clicked "Help" and searched "keyboard shortcuts" in
    > the hope that there'd be a shortcut I could use to log out. As you might
    > have guessed, I had no luck with that.


    Right click? :-)
    Perhaps with control.

    > I figure my last hope is either:
    > A) To find a Terminal command that will turn off auto-login, or


    ~> grep -i login /etc/sysconfig/*
    ....
    /etc/sysconfig/displaymanagerISPLAYMANAGER_AUTOLOGIN=""


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)
    I'd tried right clicking and everything.
    Now that the problem's fixed, I went back to try Ctrl+Right-clicking. Nothing happened.

    As for that command, I actually understand it since I just finished an Introduction to Linux/UNIX this past semester.
    I tried trying it, but failsafe was encountering some trouble and I lost patience since, well, I have a functioning GUI again.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Auto-login & a Blank, Black Desktop

    On 2011-05-04 01:36, calmblythe wrote:

    >> ctrl-alt-bckspace, twice.
    >>

    >
    > I tried that and all I got for my trouble was an obnoxiously loud beep.
    > xD


    I said: twice.


    Alternatively: ctrl-alt-f1.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  9. #9
    Join Date
    May 2011
    Location
    Etobicoke, Canada
    Posts
    5

    Default Re: Auto-login & a Blank, Black Desktop

    Quote Originally Posted by robin_listas View Post
    On 2011-05-04 01:36, calmblythe wrote:

    >> ctrl-alt-bckspace, twice.
    >>

    >
    > I tried that and all I got for my trouble was an obnoxiously loud beep.
    > xD


    I said: twice.


    Alternatively: ctrl-alt-f1.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)
    That's what I did, but I typed (Ctrl+Alt+Backspace)x2 as opposed to Ctrl+Alt+(Backspacex2).
    I'd suspected it might have been the latter but I remembered, one time, when I'd tried stringing shortcuts that have some of the same keys in them together it wouldn't register. i.e. I'd have to lift my fingers and type the entire shortcut as opposed to just moving a single finger to a different key.
    Also, I tried the Ctrl+Alt+F1. It reminds me of the shortcut to go to the consoles that pay tribute to teletype

    In any case, the problem's been fixed and all is right with the world. Thanks for your help, again.

  10. #10

    Default Re: Auto-login & a Blank, Black Desktop

    Editing /etc/sysconfig/displaymanager to ...AUTOLOGIN="" saved hours of work and a possible reinst all which I sure didn't want to since I update openSUSE 11.4 to Factory. Logged in from the command line in "rescue" mode kernel!

    Thanks!!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •