Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Problem upgrading; impossible download 'whatever.foo'

  1. #11
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Problem upgrading; impossible download 'whatever.foo'

    You should not tell/show us situations that are not what you try to do but a sort of tests where nobody exactly knows how it should work. Thus enable the repos that you must have (OSS, nonOSS and Update), disable the others, show us the
    Code:
    LANG=C zypper lr -d
    LANG=C zypper ref
    so we can all see (in english) what your originaly and real problem is.
    Henk van Velden

  2. #12

    Default Re: Problem upgrading; impossible download 'whatever.foo'

    Code:
    ~> LANG=C zypper lr -d
    #  | Alias                                               | Name                                                  | Enabled | Refresh | Priority | Type   | URI                                                                                                          | Service
    ---+-----------------------------------------------------+-------------------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------------------------------+--------
    1  | Packman Repository                                  | Packman Repository                                    | No      | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3                                                     |        
    2  | download.opensuse.org-Extra                         | openSUSE BuildService - KDE:Extra                     | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3/                                          |        
    3  | download.opensuse.org-STABLE                        | openSUSE BuildService - OpenOffice.org                | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.3/                              |        
    4  | download.opensuse.org-UpdatedApps                   | openSUSE BuildService - KDE:UpdatedApps               | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.3/                                    |        
    5  | download.opensuse.org-filesystems                   | openSUSE BuildService - filesystems                   | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_11.3/                                         |        
    6  | download.opensuse.org-mozilla                       | openSUSE BuildService - Mozilla                       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/                                             |        
    7  | download.opensuse.org-openSUSE_11.3_Update_standard | openSUSE BuildService - Virtualizzazione (VirtualBox) | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization:/VirtualBox_backports/openSUSE_11.3_Update_standard |        
    8  | download.opensuse.org-packages                      | openSUSE BuildService - Java:packages                 | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.3/                                      |        
    9  | download.opensuse.org-perl                          | openSUSE BuildService - devel:languages:perl          | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_11.3/                              |        
    10 | download.opensuse.org-python                        | openSUSE BuildService - devel:languages:python        | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_11.3/                            |        
    11 | download.opensuse.org-standard                      | Repository principale (Contrib)                       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.3:/Contrib/standard/                                  |        
    12 | ftp.uni-erlangen.de-suse                            | Packman Repository                                    | No      | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/                                                    |        
    13 | openSUSE-11.3_11.3-1.82_1                           | openSUSE-11.3-Debug                                   | No      | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                                               |        
    14 | openSUSE-11.4-Non-Oss                               | openSUSE-11.4-Non-Oss                                 | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                                                 |        
    15 | openSUSE-11.4-Oss                                   | openSUSE-11.4-Oss                                     | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                                                     |        
    16 | openSUSE-11.4-Update                                | openSUSE-11.4-Update                                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                                                    |        
    17 | openSUSE-11.4_11.3-1.82                             | openSUSE-11.4 11.3-1.82                               | No      | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/                                              |        
    18 | opensuse-guide.org-repo                             | libdvdcss repository                                  | No      | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/
    
    # LANG=C zypper ref
    Retrieving repository 'openSUSE-11.4-Update' metadata [\]
    Failed to download /repodata/repomd.xml from http://download.opensuse.org/update/11.4/
    Abort, retry, ignore? [a/r/i/?] (a):

  3. #13

    Default Re: Problem upgrading; impossible download 'whatever.foo'

    I've already tried with 1 and 15 enabled.

    By the way: I don't see the Edit button anymore, what's happened?

  4. #14
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Problem upgrading; impossible download 'whatever.foo'

    Quote Originally Posted by Buntolo View Post
    I've already tried with 1 and 15 enabled.

    By the way: I don't see the Edit button anymore, what's happened?
    I asked you to enable Oss (15), Non-Oss (14) and Update (16) and to disable all others. Thus why do you show what I did not ask for and do not show what I asked for.

    Which Edit button, where? There is no Edit button in zypper.
    Henk van Velden

  5. #15
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem upgrading; impossible download 'whatever.foo'

    On 2011-05-17 21:06, Buntolo wrote:
    >
    > Code:
    > --------------------
    > ~> LANG=C zypper lr -d
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+-----------------------------------------------------+-------------------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------------------------------+--------

    ....
    > 16 | openSUSE-11.4-Update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.4/ |

    ....
    > # LANG=C zypper ref
    > Retrieving repository 'openSUSE-11.4-Update' metadata [\]
    > Failed to download /repodata/repomd.xml from http://download.opensuse.org/update/11.4/
    > Abort, retry, ignore? [a/r/i/?] (a):
    >
    > --------------------


    Try downloading manually
    http://download.opensuse.org/update/...ata/repomd.xml, with wget,
    for example. Recheck your proxy configuration. If you do not have proxy,
    recheck it again, twice :-) Zypper has its own configuration.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •