Results 1 to 6 of 6

Thread: fglrx broke my KDM

  1. #1
    Join Date
    Apr 2011
    Location
    Staffordshire, UK
    Posts
    13

    Default fglrx broke my KDM

    Hi all, I seem to have disrupted my display manager when I installed fglrx from the Ati repository,
    I was trying to update the graphics drivers as i am getting a screen flicker every 10-15 seconds and its beginning to annoy me, so I add the ATi repository in yast, installed 'fglrx' and rebooted.

    Everything went as it should until the graphical loader showed the bar at about 50% and the screen went black, my monitor reports that its out of range after a minute or so.
    My graphics card is a HD4650 and the max res of my screen is 75Hz,

    Ive managed to get the command line by booting to Failsafe and started KDM manually and i get the same thing.

    Im assuming that the driver is correct but is setting the resolution or refresh rate too high?
    Has anyone else had this problem? and can someone point me in the direction of editing aticonfig?

    Thanks for your time

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: fglrx broke my KDM

    You may need a minimal /etc/X11/xorg.conf to get a working desktop.

    Bott to runlevel 3 (at the grub prompt, type '3', then <Enter>). Login as root, and type this command

    Code:
    aticonfig --initial --input=/etc/X11/xorg.conf
    (You'll need root privileges for this).

    IIRC, you can set desired resolutions with something like this (adjust to suit your circumstances):

    Code:
    sudo aticonfig --resolution=0,1280x1024,1024x768,800x600
    Once done, type

    Code:
    init 5
    to start the desktop.

    See if that helps.
    Last edited by deano_ferrari; 03-May-2011 at 01:48.

  3. #3
    Join Date
    Apr 2011
    Location
    Staffordshire, UK
    Posts
    13

    Default Re: fglrx broke my KDM

    thanks ill try this now

  4. #4
    Join Date
    Apr 2011
    Location
    Staffordshire, UK
    Posts
    13

    Default Re: fglrx broke my KDM

    Hi, i tried the steps above but when i init runlevel 5, i get the blck screen, no hdd activity and nothing happening on the monitor,
    I think im better off trying to revert back to how it was originally set up after installing. can this be done or could the original packages/dependencies have been removed or altered?
    Thanks again for your help

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: fglrx broke my KDM

    This guide may help with returning to using the radeon driver:

    SDB:ATI troubleshooting - openSUSE

    You will need to remove (or rename) any existing xorg.conf file as well

    Code:
    mv /etc/X11/xorg.conf /etc/X11/xorg.old

  6. #6

    Default Re: fglrx broke my KDM

    To uninstall the ATI driver, you just have to exit X or boot in runlevel 3 and do

    Code:
    su -c 'zypper rm x11-video-fglrxG02'
    provided this is the one you installed. If you did install x11-video-fglrxG01 or x11-video-fglrx, that would already explain why it didn't work.

    Rename or remove /etc/X11/xorg.conf and you should be back to the open source driver.

    If you'll like to try the latest ATI driver, you can try atiupgrade: Upgrading ATI driver with atiupgrade

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •