Results 1 to 2 of 2

Thread: D-Link DWA-125 on Opensuse 11.4

  1. #1

    Default D-Link DWA-125 on Opensuse 11.4

    Dear all,

    yesterday I bought a new USB WLAN card from D-Link. The model is DWA-125.
    I have problems to get it to run on opensuse 11.4.

    I have managed to connect to my WLAN and to get an IP from the DHCP server, but it seems to be impossible to make any network connections. e.G pinging the gateway does not work, although firewall etc. are disabled.

    I get the following errors in dmesg

    Code:
    [ 1117.048565] Err;FC.ToDs
    [ 1141.484194] Err;FC.ToDs
    [ 1153.283994] Err;FC.ToDs
    [ 1177.022098] Err;FC.ToDs
    Here is what I did.

    After installing the staging drivers, the module rt2870sta: is loaded

    Code:
    dmesg | grep rt28   
    [..]
    [   8.806770] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
    [    8.829490] usbcore: registered new interface driver rt2870
    Code:
    linux-271d:~ # lsmod |grep rt
    iTCO_vendor_support     2554  1 iTCO_wdt
    parport_pc             33763  0 
    parport                34550  2 ppdev,parport_pc
    rt2870sta             438592  1 
    crc_ccitt               1419  1 rt2870sta
    I can configure the wlan0 using yast (scanning for networks works) and the device can retrieve an IP with DHCP, if I configure it manually with iwconfig

    Code:
      iwconfig wlan0 mode Managed
      iwconfig wlan0 key off
      iwconfig wlan0 essid my-wif
    Code:
    linux-271d:~ # iwconfig wlan0
    wlan0     Ralink STA  ESSID:"my-wifi"  Nickname:"RT2870STA"
              Mode:Managed  Frequency=2.462 GHz  Access Point: 00:17:59:7C:19:B0   
              Bit Rate=54 Mb/s   
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=100/100  Signal level:-61 dBm  Noise level:-83 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    However, rcnetwork restart gives me error messages, but I do not think this is relevant to my problem, as typing the commands manually and starting the network works ok.

    Code:
       wlan0     
        wlan0     warning: using NO encryption
    command 'iwconfig wlan0 mode Managed' returned
     Error for wireless request "Set Mode" (8B06) :
        SET failed on device wlan0 ; Network is down.
    command 'iwconfig wlan0 key off' returned
     Error for wireless request "Set Encode" (8B2A) :
        SET failed on device wlan0 ; Network is down.
    command 'iwconfig wlan0 essid my-wifi' returned
     Error for wireless request "Set ESSID" (8B1A) :
        SET failed on device wlan0 ; Network is down.
        wlan0     Starting DHCP4+DHCP6 client. . . . . . . .  
        wlan0     DHCP4 continues in background
        wlan0     DHCP6 continues in background
    It seems the driver is not working properly.. why can I get an IP via the network but not send or receive anything? (tcpdump -vv -i wlan0 while pinging produces outgoing ARP requests, but no incoming traffic). I suspect this is a driver problem. Can anybody please assist?

    thanks
    Kurt

    P.S I have downloaded the newest driver from the ratech website, but I have trouble installing it.

    Code:
    linux-271d:/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0 # make
    make -C tools
    make[1]: Entering directory `/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools'
    /tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools/bin2h
    cp -f os/linux/Makefile.6 /tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/os/linux/Makefile
    make  -C  /lib/modules/2.6.37.1-1.2-desktop/build SUBDIRS=/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/os/linux modules
    make: *** /lib/modules/2.6.37.1-1.2-desktop/build: No such file or directory.  Stop.
    make: *** [LINUX] Error 2
    any help would be very much appreciated
    thanks
    Kurt

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: D-Link DWA-125 on Opensuse 11.4

    On 05/02/2011 08:36 AM, kurt hectic wrote:
    >
    > Dear all,
    >
    > yesterday I bought a new USB WLAN card from D-Link. The model is
    > DWA-125.
    > I have problems to get it to run on opensuse 11.4.
    >
    > I have managed to connect to my WLAN and to get an IP from the DHCP
    > server, but it seems to be impossible to make any network connections.
    > e.G pinging the gateway does not work, although firewall etc. are
    > disabled.
    >
    > I get the following errors in dmesg
    >
    >
    > Code:
    > --------------------
    > [ 1117.048565] Err;FC.ToDs
    > [ 1141.484194] Err;FC.ToDs
    > [ 1153.283994] Err;FC.ToDs
    > [ 1177.022098] Err;FC.ToDs
    > --------------------
    >
    >
    > Here is what I did.
    >
    > After installing the staging drivers, the module rt2870sta: is loaded
    >
    >
    > Code:
    > --------------------
    >
    > dmesg | grep rt28
    > [..]
    > [ 8.806770] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
    > [ 8.829490] usbcore: registered new interface driver rt2870
    >
    > --------------------
    >
    >
    >
    > Code:
    > --------------------
    > linux-271d:~ # lsmod |grep rt
    > iTCO_vendor_support 2554 1 iTCO_wdt
    > parport_pc 33763 0
    > parport 34550 2 ppdev,parport_pc
    > rt2870sta 438592 1
    > crc_ccitt 1419 1 rt2870sta
    > --------------------
    >
    >
    > I can configure the wlan0 using yast (scanning for networks works) and
    > the device can retrieve an IP with DHCP, if I configure it manually with
    > iwconfig
    >
    >
    > Code:
    > --------------------
    > iwconfig wlan0 mode Managed
    > iwconfig wlan0 key off
    > iwconfig wlan0 essid my-wif
    > --------------------
    >
    >
    >
    > Code:
    > --------------------
    >
    > linux-271d:~ # iwconfig wlan0
    > wlan0 Ralink STA ESSID:"my-wifi" Nickname:"RT2870STA"
    > Mode:Managed Frequency=2.462 GHz Access Point: 00:17:59:7C:19:B0
    > Bit Rate=54 Mb/s
    > RTS thrff Fragment thrff
    > Encryption keyff
    > Link Quality=100/100 Signal level:-61 dBm Noise level:-83 dBm
    > Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    > Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    > --------------------
    >
    >
    > However, rcnetwork restart gives me error messages, but I do not think
    > this is relevant to my problem, as typing the commands manually and
    > starting the network works ok.
    >
    >
    > Code:
    > --------------------
    >
    > wlan0
    > wlan0 warning: using NO encryption
    > command 'iwconfig wlan0 mode Managed' returned
    > Error for wireless request "Set Mode" (8B06) :
    > SET failed on device wlan0 ; Network is down.
    > command 'iwconfig wlan0 key off' returned
    > Error for wireless request "Set Encode" (8B2A) :
    > SET failed on device wlan0 ; Network is down.
    > command 'iwconfig wlan0 essid my-wifi' returned
    > Error for wireless request "Set ESSID" (8B1A) :
    > SET failed on device wlan0 ; Network is down.
    > wlan0 Starting DHCP4+DHCP6 client. . . . . . . .
    > wlan0 DHCP4 continues in background
    > wlan0 DHCP6 continues in background
    > --------------------
    >
    >
    > It seems the driver is not working properly.. why can I get an IP via
    > the network but not send or receive anything? (tcpdump -vv -i wlan0
    > while pinging produces outgoing ARP requests, but no incoming traffic).
    > I suspect this is a driver problem. Can anybody please assist?
    >
    > thanks
    > Kurt
    >
    > P.S I have downloaded the newest driver from the ratech website, but I
    > have trouble installing it.
    >
    >
    > Code:
    > --------------------
    > linux-271d:/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0 # make
    > make -C tools
    > make[1]: Entering directory `/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools'
    > gcc -g bin2h.c -o bin2h
    > make[1]: Leaving directory `/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools'
    > /tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/tools/bin2h
    > cp -f os/linux/Makefile.6 /tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/os/linux/Makefile
    > make -C /lib/modules/2.6.37.1-1.2-desktop/build SUBDIRS=/tmp/wlan/2009_1204_RT3070_Linux_STA_v2.1.2.0/os/linux modules
    > make: *** /lib/modules/2.6.37.1-1.2-desktop/build: No such file or directory. Stop.
    > make: *** [LINUX] Error 2
    > --------------------


    When you have wireless trouble, please post in the wireless forum.

    That staging driver is worthless. The ones from the Ralink site are not much
    better. Please blacklist rt2870sta and install compat-wireless. Driver rt2800usb
    from that source works pretty well.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •