Results 1 to 7 of 7

Thread: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

  1. #1

    Default Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    Just put 11.4, 32 bit on a system with an Intel D865 GLC motherboard and 865G built in graphics controller. While the install went OK it turns out that X is totally hosed.

    After fighting with things for a while and discovering that Sax2 had disappeared I poked at Google and discovered some other poor folks that have had similar issues with Intel video cards. Based on a suggestion for a doc in OpenSuse.org I edited the file:
    /etc/X11/xorg.conf.d/50-device.conf

    and added the line:
    Driver "intel"
    to it - after that things got better. Obviously the install process had not identified the video card correctly. I'm now left with another issue - while the system now identifies the driver and can talk to the monitor correctly, a Samsung S23A350H I can't open a window after X comes up and I login - basically the same issue as the unresolved Bug 673873:
    [Bug 673873] intel [865G] Windows flash rapidly or don't appear if Desktop Effects are on in KDE and GNOME

    The workaround is to turn Desktop Effects off but since X doesn't work I can't figure out how to do that. I can't find the gnome-xgl-switch or a xgl-switch that used to exist to do it on the command line so that's out. Someone said you could drop the empty file "disable-compiz" in the ~/.config/compiz directory and that would do it but in 11.4 that directory doesn't exist. The closest thing is ~/.config/compiz-1 and I put it there but that didn't help.

    So, would some kind soul tell me how to disable "Desktop Effects"/XGL/compiz or whatever it is now called on the command line in OpenSuse 11.4 without a gui if that is still possible? I can use VI just fine so please just tell me how to turn the mess off -

    Thanks!

    Mike

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    What about the following brute force solution:
    Run yast from your console, it will come up in text mode, go to software
    management - search for compiz and uninstall all compiz related packages
    (you can do that of course, your desktop does not depend on having compiz).

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    Quote Originally Posted by martin_helm View Post
    What about the following brute force solution:
    Run yast from your console, it will come up in text mode, go to software
    management - search for compiz and uninstall all compiz related packages
    (you can do that of course, your desktop does not depend on having compiz).
    Thanks - I hadn't thought of that but it will be kind'a stunning if that's what has to be done because it means that there isn't a simple on/off switch reachable via command line text to shut the stuff off. If this is true somebody has forgotten one of the central tenants of Unix land - all configuration files need to be text. Loosing that is a sure sign Linux is headed off to Windoze land. Sad, very sad.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    I do not say that there is no such switch. I just think if nobody until now
    knows the switch or the persons who know it until now have not seen the
    thread, it is at least a way to ensure it cannot start compiz until you
    found out how to disable it.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    Thanks for another idea!

    I buzzed over to Compiz's website at: Compiz Home hoping to find a way to ask a question and frankly it looks kind'a dead. There are/were 3 mailing lists - with no posts since late 2010 and the front page hasn't been updated since about that time so there isn't much hope for help there. I tried a few searches to no avail. The Wiki and Planet sections seem active but I could not find a mechanism to post simple, stupid questions like "how do I turn it off?"?

    Additionally I played around with "compiz --help" and its no help either. Wonder if there is a man page! I'm not betting on it but I'll go and see!

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    So what you are looking for is more or less where compiz stores it settings
    and the answer is: it depends.
    Compiz can use several backends to store its settings (which includes of
    course the setting if effects are enabled at all or not).
    I never looked that up (since I use KDE most of the time) but
    can you look if you have a folder ~/.config/compiz/?

    In that folder I see an empty file disable-config, when I enable compiz I
    see a file enable-compiz.
    So probably it is simply enough if you delete ~/.config/compiz/enable-compiz
    and create an empty file ~/.config/compiz/disable-compiz.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Vido problems with 11.4 32 bit & the Intel 865 Graphics controller

    Quote Originally Posted by mwfolso View Post
    So, would some kind soul tell me how to disable "Desktop Effects"/XGL/compiz or whatever it is now called on the command line in OpenSuse 11.4 without a gui if that is still possible? I can use VI just fine so please just tell me how to turn the mess off -
    Did you try to boot to a more basic (and more compatible) graphic driver than the "Intel" driver as an interim, so that you can turn OFF the "Desktop Effects", and then reboot back to the "intel" driver?

    I recommend you 1st install the program "mc" (midnight commander) as that provides a menu driven easy to follow text editor that you can run in a text mode to edit files such as 50-device.conf.

    Then try either the "intellegacy" video driver (its in essence a packaged version of an old Intel driver version) or try the basic but very compatible "fbdev" driver.

    To try the "intellegacy" driver just replace "intel" with "intellegacy" in the 50-device.conf file.

    To try the "fbdev" driver, you can simply reboot and apply the boot code "x11failsafe" and that should force the fbdev driver. Or if you have the original 50-device.conf (with no "intel" nor "intellegacy" edits and with "radeon" still commented out) you can use the boot code "nomodeset" and that should also cause the fbdev driver to be loaded. Or you can select the FailSafe boot option, and that should also force the "fbdev" driver to load. Or if you like editing, you can even edit the 50-device.conf file adding the "fbdev" in place of the "intel" and that should cause the fbdev to load. So pick your 'poison' ...

    Once you have the "Desktop Effects" disabled, you can restore your "intel" selection in the 50-device.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •