Results 1 to 5 of 5

Thread: Ethernet and Wlan must work Howto SOS

  1. #1
    Join Date
    May 2010
    Location
    Phuket
    Posts
    12

    Default Ethernet and Wlan must work Howto SOS

    I lost due to lightenings and flashes which came througe the telephone line within 5 month 5 mainboards, 4 grafic cards, 3 UPS's and 2 CPU's.(I m living in Thailand).
    Therefore, I must disconnect fron the telephone line and go to wireless.

    Since 2 month`s I try to get the wireless working and red through tons of documents including this thread.

    I have 3 computers in dual boot Opensuse 11.1, 11,3 and 11.4 with 2x Win XP and win98se.

    Windows I got to work, however Opensuse not.

    The windows data are as follows:

    Windows-IP-Konfiguration
    Hostname. . . . . . . . . . . . . : bill80
    Primres DNS-Suffix . . . . . . . :
    Knotentyp . . . . . . . . . . . . : Unbekannt
    IP-Routing aktiviert. . . . . . . : Nein
    WINS-Proxy aktiviert. . . . . . . : Nein

    Ethernetadapter LAN-Verbindung 1:
    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : NVIDIA nForce Networking Controller
    Physikalische Adresse . . . . . . : 00-11-D8-CF-F1-62
    DHCP aktiviert. . . . . . . . . . : Nein
    IP-Adresse. . . . . . . . . . . . : 192.168.1.80
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . :

    DNS-Server. . . . . . . . . . . . : 208.67.220.220
    208.67.222.222

    Ethernetadapter Drahtlose Netzwerkverbindung 3:
    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : TL-WN321G USB Wireless Adapter
    Physikalische Adresse . . . . . . : D8-5D-4C-94-C0-BB
    DHCP aktiviert. . . . . . . . . . : Nein
    IP-Adresse. . . . . . . . . . . . : 192.168.10.101
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . : 192.168.10.1
    DNS-Server. . . . . . . . . . . . : 208.67.220.220
    208.67.222.222
    Lease erhalten. . . . . . . . . . : Mittwoch, 27. April 2011 01:51:20
    Lease expires ab. . . . . . . . . . : Donnerstag, 28. April 2011 01:51:20

    nbtstat -a
    LAN-Verbindung 1:
    Knoten-IP-Adresse: [192.168.1.80] Bereichskennung: []
    Drahtlose Netzwerkverbindung 3:
    Knoten-IP-Adresse: [192.168.10.101] Bereichskennung: []

    Routing
    ===========================================================================
    Schnittstellenliste
    0x1 ............MS TCP Loopback interface
    0x2 ...00 11 d8 cf f1 62 ...... NVIDIA nForce Networking Controller - Paketplaner-Miniport
    0x10004 ...d8 5d 4c 94 c0 bb ...... TL-WN321G USB Wireless Adapter - Paketplaner-Miniport
    ===========================================================================
    ===========================================================================
    Aktive Routen:
    Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
    0.0.0.0 0.0.0.0 192.168.10.1 192.168.10.101 25
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    192.168.1.0 255.255.255.0 192.168.1.80 192.168.1.80 20
    192.168.1.80 255.255.255.255 127.0.0.1 127.0.0.1 20
    192.168.1.255 255.255.255.255 192.168.1.80 192.168.1.80 20
    192.168.10.0 255.255.255.0 192.168.10.101 192.168.10.101 25
    192.168.10.101 255.255.255.255 127.0.0.1 127.0.0.1 25
    192.168.10.255 255.255.255.255 192.168.10.101 192.168.10.101 25
    224.0.0.0 240.0.0.0 192.168.1.80 192.168.1.80 20
    224.0.0.0 240.0.0.0 192.168.10.101 192.168.10.101 25
    255.255.255.255 255.255.255.255 192.168.1.80 192.168.1.80 1
    255.255.255.255 255.255.255.255 192.168.10.101 192.168.10.101 1
    Standardgateway: 192.168.10.1
    ===========================================================================


    With Opensuse I can connect with each of the other linux and windows systems througe ethernet only, but I can not connect to the internet.

    The Linux data are as follows

    ifconfig -a

    eth0 Link encap:Ethernet HWaddr 00:15:F2:16:12:40
    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:31 errors:0 dropped:0 overruns:0 frame:0
    TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:5509 (5.3 Kb) TX bytes:8539 (8.3 Kb)
    Interrupt:21 Base address:0xe000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:156 errors:0 dropped:0 overruns:0 frame:0
    TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:12853 (12.5 Kb) TX bytes:12853 (12.5 Kb)

    wlan0 Link encap:Ethernet HWaddr D8:5D:4C:94:E5:4E
    inet addr:192.168.10.10 Bcast:192.168.10.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:8888 (8.6 Kb)

    iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:"WILHELM"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:04:ED;3:06:45
    Bit Rate=54 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr;ff Fragment thrff
    Encryption keyff
    Power Managementn
    Link Quality=70/70 Signal level=-38 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:518 Missed beacon:0

    netstat -r
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.10.0 * 255.255.255.0 U 0 0 0 wlan0
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.10.1 0.0.0.0 UG 0 0 0 wlan0

    bill50:/usr/sbin = ping 192.168.10.10
    PING 192.168.10.10 (192.168.10.5) 56(84) bytes of data.
    64 bytes from 192.168.10.10: icmp_seq=1 ttl=64 time=0.037 ms
    64

    bill50:/usr/sbin = ping 192.168.10.1
    PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
    From 192.168.10.10: icmp_seq=2 Destination Host Unreachable
    From 192.168.10.10 icmp_seq=2 Destination Host Unreachable


    bill50:/usr/sbin = ping 192.168.1.50
    PING 192.168.1.50 (192.168.1.50) 56(84) bytes of data.
    64 bytes from 192.168.1.50: icmp_seq=1 ttl=64 time=0.039 ms
    64 bytes from 192.168.1.50: icmp_seq=2 ttl=64 time=0.033 ms


    The above was with configuring the devices at boot. I could connect to all hosts, but not to the internet, because it doesnot find the Wlanrouter which has the ip adress 192.168.10.1
    I tried several weeks all variations i could think of, even with addroute, but without success. None of the 3 linux versions connected to the internet.

    Now my last try was to remove all network cards, I deleted all configured devices and started newover using configurationmode if hotplugged for the wlan and if cable connected for the ethenet. Here are the results:

    bill50:/usr/sbin = ifconfig -a
    eth0 Link encap:Ethernet Hardware Adresse 00:118:CF:F1:62
    inet Adresse:192.168.1.50 Bcast:192.168.1.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:360 errors:0 dropped:0 overruns:0 frame:0
    TX packets:499 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:47745 (46.6 Kb) TX bytes:71886 (70.2 Kb)
    Interrupt:20

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1034 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1034 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:0
    RX bytes:150916 (147.3 Kb) TX bytes:150916 (147.3 Kb)

    wlan0 Link encap:Ethernet Hardware Adresse D8:5D:4C:94:C0:BB
    inet Adresse:192.168.10.5 Bcast:192.168.10.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:429 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:52465 (51.2 Kb)


    bill50:/home/bill = netstat -nr
    Kernel IP Routentabelle
    Ziel Router Genmask Flags MSS Fenster irtt Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.10.1 0.0.0.0 UG 0 0 0 wlan0

    bill50:/usr/sbin = iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:"WILHELM"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:04:ED3:06:45
    Bit Rate=36 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementn
    Link Quality=70/70 Signal level=-26 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    bill50:/usr/sbin = ping 192.168.10.5
    PING 192.168.10.5 (192.168.10.5) 56(84) bytes of data.
    64 bytes from 192.168.10.5: icmp_seq=1 ttl=64 time=0.037 ms
    64 bytes from 192.168.10.5: icmp_seq=2 ttl=64 time=0.032 ms

    bill50:/usr/sbin = ping 192.168.10.1
    PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
    From 192.168.10.5: icmp_seq=1 Destination Host Unreachable
    From 192.168.10.5 icmp_seq=1 Destination Host Unreachable
    From 192.168.10.5 icmp_seq=2 Destination Host Unreachable

    bill50:/usr/sbin = ping 192.168.1.60[/COLOR]
    PING 192.168.1.60 (192.168.1.60) 56(84) bytes of data.
    64 bytes from 192.168.1.60: icmp_seq=1 ttl=128 time=0.623 ms
    64 bytes from 192.168.1.60: icmp_seq=2 ttl=128 time=0.149 ms

    bill50:/usr/sbin = ping bill60
    PING bill60.bill (192.168.1.60) 56(84) bytes of data.
    64 bytes from bill60.bill (192.168.1.60): icmp_seq=1 ttl=128 time=0.328 ms

    bill50:/usr/sbin = ping bill10
    PING bill10.bill (192.168.1.10) 56(84) bytes of data.
    64 bytes from bill10.bill (192.168.1.10): icmp_seq=1 ttl=64 time=1.74 ms
    64 bytes from bill10.bill (192.168.1.10): icmp_seq=2 ttl=64 time=0.120 ms

    I tried again to add a route, but I got the message '192.168.10.0' is not a valid network. Idont know what to do anymore.

    I am very glad if someone cold give me some advise or help.

    Thank you.
    Willi

  2. #2

    Default Re: Ethernet and Wlan must work Howto SOS

    Use <CODE></CODE> tags (substituting the <> for []) to post the output of commands in the future. It would be much appreciated.
    You say you're using the telephone line, so I take it there is a modem involved somewhere. Are your computers going to the router (you say they can interconnect so I'm assuming they are) or plugged directly into the modem?
    If they're directly connecting to the modem, take a look at wvdial.
    If not, try and run
    Code:
    sudo dhcpcd eth0
    replace the eth0 with wlan0 if you're trying wireless.
    I'm pretty sure all of your interfaces are up, but running
    Code:
    ifconfig eth0 up
    can't hurt.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  3. #3
    Join Date
    May 2010
    Location
    Phuket
    Posts
    12

    Default Re: Ethernet and Wlan must work Howto SOS

    My 3 computers are connected to a hub which was connected through cable to a Bell router-modem. In this way, they can communicate with each other directy.
    I replaced the Bell by a wireless one, where each unit is connectd via an wireless USB-stick with the modem, and lan cables with the hub.

    Here is the outcome of the commands you suggested:

    bill10:/ Code: dhcpcd eth0
    err, eth0: timed out
    warn, eth0: using IPV4LL address 169.254.108.4

    bill10:/ Code: dhcpcd wlan0
    err, wlan0: timed out
    warn, wlan0: using IPV4LL address 169.254.19.235

    bill10:/ Code: dhcpcd eth0
    err, eth0: dhcpcd already running on pid 6728 (/var/run/dhcpcd-eth0.pid)
    bill10:/ Code: dhcpcd wlan0
    err, wlan0: dhcpcd already running on pid 6730 (/var/run/dhcpcd-wlan0.pid)

    bill10:/ Code: netstat -nr
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

    As i saw the routing table was changed I tried with yast to reconfigure the network cards, but this did not work. it came aways back to the original configuration and when I restarted the computer everything was like before.
    Sure, because neither the wlan nor the network card were in the 192.168 network any more.

    Thanks a lot for your help.

  4. #4
    Join Date
    May 2010
    Location
    Phuket
    Posts
    12

    Default Re: Ethernet and Wlan must work Howto SOS

    I finally got my systems to work. It was just to write manually the right routing tables
    For Opensuse 11.4 it had to be different as for the 11.1 and 11.3

    For 11.4 it is

    bill10:/CODE netstat -nr
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.10.0 192.168.1.10 255.255.255.0 UG 0 0 0 eth0
    192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.10.1 0.0.0.0 UG 0 0 0 wlan0


    For the 11.1 and 11.3 they are:

    bill50:/ CODE netstat -nr
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.10.1 0 0.0.0 UG 0 0 0 wlan0

    I still dont know why they had to be different, but it works.
    So my problem is soved.



    Thank you again for your good hint with the command dhcpcd

    Willi

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Ethernet and Wlan must work Howto SOS

    On 05/08/2011 07:36 PM, 6373394013 wrote:
    >
    > I finally got my systems to work. It was just to write manually the
    > right routing tables
    > For Opensuse 11.4 it had to be different as for the 11.1 and 11.3
    >
    > For 11.4 it is
    >
    > bill10:/CODE netstat -nr
    > Kernel IP routing table
    > Destination Gateway Genmask Flags MSS
    > Window irtt Iface
    > 192.168.10.0 192.168.1.10 255.255.255.0 UG 0 0
    > 0 eth0
    > 192.168.10.0 0.0.0.0 255.255.255.0 U 0 0
    > 0 wlan0
    > 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0
    > 0 eth0
    > 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0
    > 0 eth0
    > 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0
    > 0 lo
    > 0.0.0.0 192.168.10.1 0.0.0.0 UG 0 0
    > 0 wlan0
    >
    >
    > For the 11.1 and 11.3 they are:
    >
    > bill50:/ CODE netstat -nr
    > Kernel IP routing table
    > Destination Gateway Genmask Flags MSS
    > Window irtt Iface
    > 192.168.1.0 0.0.0.0 255.255.255.0 U 0
    > 0 0 eth0
    > 192.168.10.0 0.0.0.0 255.255.255.0 U 0
    > 0 0 wlan0
    > 169.254.0.0 0.0.0.0 255.255.0.0 U
    > 0 0 0 eth0
    > 127.0.0.0 0.0.0.0 255.0.0.0 U
    > 0 0 0 lo
    > 0.0.0.0 192.168.10.1 0 0.0.0 UG
    > 0 0 0 wlan0
    >
    > I still dont know why they had to be different, but it works.
    > So my problem is soved.
    >
    >
    >
    > Thank you again for your good hint with the command dhcpcd


    If your router is at 192.168.10.1, then that first UG rule in the top table is
    just plain wrong. Did you enter one with a typo? The tables for 11.4 should be
    the same as 11.3.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •