Results 1 to 8 of 8

Thread: no sound using amarok

  1. #1

    Default no sound using amarok

    I added the Packman repository and installed ASF modules for Amarok. Since that point Amarok didn't make a noise, although it actually played music.

    - Speakers aren't muted
    - sound works fine using banshee and pretty much everything else
    - so drivers are up to date

    please reply

    thanks very much

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: no sound using amarok

    I added the Packman repository and installed ASF modules for Amarok. Since that point Amarok didn't make a noise, although it actually played music.

    - Speakers aren't muted
    - sound works fine using banshee and pretty much everything else
    - so drivers are up to date

    please reply

    thanks very much
    I might suggest you run a script file I call mmcheck to determine if your multimedia is now setup properly. You can find a copy here:

    MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

    I also have a script useful to check out sound setup you can find here:

    S.T.A.R.T. - SuSE Terminal Audio Reporting Tool

    I would give them a try to see if any of the information might be helpful to you.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: no sound using amarok

    I recommend you go to our forum New User FAQ Forum 'read only' area and take a look at a couple of guides :

    What version of openSUSE are you using ?

    What desktop do you have? LXDE ? Xfce ? Gnome ? KDE ?

    On openSUSE-11.4 I typically install the application 'pavucontrol' and run 'pavucontrol' the first time I run a multimedia application, so as to tune my system to work with that application. But not everyone believes this is necessary, and indeed for many users that is the case (its not necessary). I simply find it easier.

    Edit: Beat to the punch by jdmcdaniel3 - his advice is EXCELLENT by the way !!

  4. #4

    Default Re: no sound using amarok

    Thank you very much, I might try those scrypts out.
    I'm quite happy to hear about the "read only" section, completely forgot about that.

    Great quick reply, thank you

  5. #5

    Default Re: no sound using amarok

    Look, I read through all those instructions on the "read only" section and actually installed all needed packages (exept vlc and libffmpeg0), but it's still not working.
    However, because this is probably the next suggestion you will make, I'll try to run the script to see what's wrong.

    Anyway, do you have any other suggestions?

    Thank you for your time

  6. #6

    Default Re: no sound using amarok

    I am really sorry, that I have bothered you.

    The solution is actually pretty simple, which is unfortunately more than often the case, when you have a problem, driving you mad.

    I build my pc myself and lucky me, I had 3 available sound cards(one onboard and two offboard), so I just put them in. The whole system was set up to one sound card, except Amarok. It preferred, why ever, another one. ;D
    So as simple as it sounds, Amarok just had to be set to the one sound card, I'm currently using as the default one.
    I know, that this forum should be only for "emergencies", but the solution was just so fundamental, I didn’t think of it. Everything else, which had anything to do with sound, was working fine, so I believed, that it couldn't be the sound card being set up wrong, I thought I would need some specific packages.

    By the way, I'm amazed by the support you get very quickly in this community. I hope, that I can help people out in some matters as well.

    Again, thank you for your quick replies and sorry about the so obvious simplicity in this case.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: no sound using amarok

    Quote Originally Posted by 13X View Post
    Look, I read through all those instructions on the "read only" section and actually installed all needed packages (exept vlc and libffmpeg0), but it's still not working.
    Typically amarok will use the audio settings that is configured by default in the desktop. If you are using KDE, then you need to ensure that the order of sound devices (especially the 1st selected device) in KMenu > Configure Desktop > Multimedia > Phonon for your sound matches the order of devices in YaST > Hardware > Sound. One also may have a choice of sound engines in Phonon. I typically prefer the xine sound engine as a KDE user.

    Sometimes, if one has chosen the xine engine in KDE desktop (such that the xine engine will then be used by Amarok) it may be necessary to tune the xine engine. That can be done by installing the application xine-ui and then running xine. Go to the xine > settings > setup > gui in xine (sometimes right clicking on a video opened in xine will give one the menu control for settings) and select 'master of the known universe' and then restart xine. Then go to xine >settings > setup > audio and one can choose the appropriate 'audio driver to use'. I prefer to use 'oss' or 'pulse'. One can test playing the audio files with xine, and if they play ok with xine, thats a good sign it will then be possible to play them with amarok.

    I also in openSUSE-11.4 prefer to install the application 'pavucontrol' and then each time I start a multimedia application for the first time, I will launch 'pavucontrol' and use that to tune the settings of pulse audio for that application. From then on when one starts the application, those pulse audio settings will be applied for that application.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: no sound using amarok

    Quote Originally Posted by 13X View Post
    I had 3 available sound cards(one onboard and two offboard), so I just put them in. The whole system was set up to one sound card, except Amarok. It preferred, why ever, another one. ;D
    So as simple as it sounds, Amarok just had to be set to the one sound card, I'm currently using as the default one.
    Glad to read you sorted this.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •