Results 1 to 10 of 10

Thread: Geany don't work

  1. #1
    Join Date
    Apr 2011
    Location
    Croatia
    Posts
    8

    Default Geany don't work

    Hi!

    I have problem with geany.. on one pc geany works fine but on my lap I get segmentation fault message and nothing happens. Does anybody knows how to solve this? :/

    both machines are running 11.4...

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Geany don't work

    r2csx wrote:

    >
    > Hi!
    >
    > I have problem with geany.. on one pc geany works fine but on my lap I
    > get segmentation fault message and nothing happens. Does anybody knows
    > how to solve this? :/
    >
    > both machines are running 11.4...
    >

    Works fine here so pleasec an you give the following infos:
    32bit or 64bit?
    which version of geany and from which repository?
    for the first simply type
    Code:
    rpm -q geany
    Do you also have geany plugins installed (it may as well be a plugin which
    crashes)?
    Run geany in a terminal till it crashes and post the terminal output.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3
    Join Date
    Apr 2011
    Location
    Croatia
    Posts
    8

    Default Re: Geany don't work

    it is 32-bit OS and I install it from standard repo. Version is geany-0.20-20.3 (without any plugins)

    Just to be clear, when I try to start geany nothing happens, but when i try to start geany from console i get "Segmentation fault"

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Geany don't work

    r2csx wrote:

    >
    > it is 32-bit OS and I install it from standard repo. Version is
    > geany-0.20-20.3 (without any plugins)
    >
    > Just to be clear, when I try to start geany nothing happens, but when i
    > try to start geany from console i get "Segmentation fault"
    >

    This is for sure not the geany from the standard repo but from Gnome Apps
    repo or similar. The standar geany has version 0.20-5.3 (which runs without
    problems here but on 64bit including the plugins).

    I would try the following:
    Open yast -> software management
    search for geany
    select it and at the bottom you can view and see the different versions from
    the different repos - change it to the standard repository (oss) and see if
    that runs more stable. It may be that you introduced inconsistencies by
    using a mixture of software from different repositories.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5
    Join Date
    Apr 2011
    Location
    Croatia
    Posts
    8

    Default Re: Geany don't work

    my bad.. it's from gnome apps repo but even when i use standard repo, error is the same..

    thnx for helping me but i think i will install fresh copy of opensuse (64? )

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Geany don't work

    r2csx wrote:

    >
    > my bad.. it's from gnome apps repo but even when i use standard repo,
    > error is the same..
    >
    > thnx for helping me but i think i will install fresh copy of opensuse
    > (64? )
    >

    That is a bit heavy, before you do that you can disable the extra
    repositories (maybe except packman), so that you have only oss, non-oss and
    updates and then do a "zypper dup". I think you have nothing to loose by
    doing that if you consider reinstallation as solution.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7
    Join Date
    Apr 2011
    Location
    Croatia
    Posts
    8

    Default Re: Geany don't work

    I already do that

    now all works just fine

    thnx anywy

  8. #8

    Default Re: Geany don't work

    I think I know the problem. This is bug in GTK or oxygen-gtk. When I tried to use oxygen-gtk theme fo GTK applications in KDE 4.6 and started geany I also saw segmentation fault. But when I switched to qt-curve geany worked fine. The similar problem was with nm-applet. It crashed because of missing icons in oxygen-gtk.

  9. #9
    Join Date
    Apr 2011
    Location
    Croatia
    Posts
    8

    Default Re: Geany don't work

    maybe... after I was reinstalled my system, problem has appeared again after KDE update to 4.6.2

  10. #10

    Default Re: Geany don't work

    Also have this problem after upgrading Gnome to v3. Definitely related to some of the gnome packages / configs.

    Currently installed:
    geany-lang-0.20-20.2.noarch
    geany-0.20-20.2.x86_64

    but used this one when Geany (from OSS repo) stopped working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •