Results 1 to 2 of 2

Thread: HowTo Upgrade Gnome 2 in Tumbleweed to Gnome 3

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default HowTo Upgrade Gnome 2 in Tumbleweed to Gnome 3

    (Edit 14 may: warning: this method will be obsolete as soon as the Gnome 3 RPMs are merged into the main Tumbleweed repo, so you should check whether that's happened).

    There is a Tumbleweed repo containing Gnome 3 RPMs, located at this address:
    HTML Code:
    http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/GNOME/openSUSE_Tumbleweed
    The package manager (@gregkh of these forums) intends soon to fold all the RPMs into the Tumbleweed repo so that a special repo for Gnome packages will no longer be required. But until this happens, that is the repo that you can attach if you want to upgrade your Tumbleweed with Gnome 2 to Tumbleweed with Gnome 3.

    Here's the process I used, written as a HowTo:

    First, before you attach the Gnome 3 repo, prepare your Tumbleweed for Gnome 3 by making it fully up to date in two steps. Step one is to get the existing security fixes and so on for the underlying 11.4 up to scratch by running Yast Online Update (go to Yast --> Software --> Online Updates). Step two is to upgrade the RPMs from the Tumbleweed repo with this command
    Code:
    zypper dup --from Tumbleweed
    After making Tumbleweed up to date, attach and enable the Tumbleweed:Gnome repo (see address above). You can use Yast --> Software --> Software Reops to add it. I named the repo TumbleweedGnome (for example). So now you should have the original 11.4 repo enabled along with your primary Tumbleweed repos and the new Gnome repo, like this:

    Code:
    john@tumbleweed114:~> zypper lr -u
    #  | Alias                | Name                   | Enabled | Refresh | URI                                                                                                
    ---+----------------------+------------------------+---------+---------+------------------------------------------------------------------------------------------
     1 | Tumbleweed           | Tumbleweed             | Yes     | Yes     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
     2 | TumbleweedPackman    | TumbleweedPackman      | Yes     | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed
     3 | repo-non-oss         | openSUSE-11.4-Non-Oss  | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/non-oss/
     4 | repo-oss             | openSUSE-11.4-Oss      | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/oss/
     5 | TumbleweedGnome      | TumbleweedGnome        | Yes     | Yes     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/GNOME/openSUSE_Tumbleweed

    Then you simply run the update command with focus on the new Gnome repo,:
    Code:
    zypper dup --from TumbleweedGnome
    When I ran the "zypper dup --from TumbleweedGnome" I got one dependency issue (not an error -- an issue that was easy to solve). You might not get the issue, depending on what you had installed beforehand. Here's the message I got:
    Code:
    Problem: libgdata7-0.6.6-2.1.i586 requires libgdata-lang = 0.6.6, but this requirement cannot be provided
    and here's the resolution suggested by zypper
    Code:
     Solution 22: install libgdata-lang-0.6.6-2.1.noarch from excluded repository
    I accepted this and all proceeded smoothly. When the process finishes, the final step is to install three extra packages, shown below:

    Code:
    zypper in gnome-shell metatheme-adwaita-common gnome-shell-lang
    Then reboot and it's done.
    Last edited by swerdna; 13-May-2011 at 14:15.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: HowTo Upgrade Gnome 2 in Tumbleweed to Gnome 3

    Caveat: as at todays date 3rd May, this is a quote from Greg k-h
    It will be a few weeks for GNOME 3 to work in Tumbleweed in a stable way, please be patient.
    So even though it works nicely for me, your mileage may vary.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •