Results 1 to 7 of 7

Thread: eclipse cdt helios crashes

  1. #1
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Question eclipse cdt helios crashes

    Hi all,

    I've just installed openSUSE 11.4 64bit Gnome and after that I downloaded
    eclipse-cpp-helios-SR2-linux-gtk-x86_64.tar.gz (CDT version for eclipse).
    I downloaded the linuxtools and tried to write some lines and I got a crash.
    I have the Oracle Java installed on the system.

    I restarted eclipse but seems that I cannot get rid of this crash.

    Did you experince something like this?


    This is the output from cli:
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0x00007f48a3a2a89b, pid=16354, tid=139949755737856
    #
    # JRE version: 6.0_24-b07
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (19.1-b02 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # j org.eclipse.cdt.internal.core.dom.parser.cpp.semantics.CPPSemantics.declaredBefore(Ljava/lang/Object;Lorg/eclipse/cdt/core/dom/ast/IASTNode;Z)Z+15
    #
    # An error report file with more information is saved as:
    # /home/nuca/Downloads/eclipse/hs_err_pid16354.log
    #
    # If you would like to submit a bug report, please visit:
    # HotSpot Virtual Machine Error Reporting Page
    #



    Thanks,
    Nuca

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: eclipse cdt helios crashes

    You can try if that helps
    http://dev-loki.blogspot.com/2011/04...elios-kvm.html

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #3
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Default Re: eclipse cdt helios crashes

    It doesn't work. I tried also with eclipse for java and got the same crash. I think that the first time crashes after a Save or a Ctrl + S. But after the first crash it reproduces forever just after opening the eclipse application.

    Quote Originally Posted by martin_helm View Post
    You can try if that helps
    /dev/loki: Workaround for Eclipse Helios JVM crashes

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: eclipse cdt helios crashes

    ionpetrache wrote:
    > It doesn't work.

    Can you post the /home/nuca/Downloads/eclipse/hs_err_pid16354.log to
    past.opensuse.org and post the link to it here.
    To a limited degree I can read it.
    But I cannot promise anything.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: eclipse cdt helios crashes

    martin_helm wrote:
    > past.opensuse.org and post the link to it here.

    This shall be paste.opensuse.org

    In the meantime I found that there is a bug report that indicates it is not an eclipse problem but a 64bit java problem.
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=333227

    One solution it mentions as workaround is the following (comment #8)
    Code:
    This could be another JIT compiler bug similar to
    http://bugs.sun.com/view_bug.do?bug_id=6614100.
    To disable the JIT compiler add -Xint to the vmargs in eclipse.ini.
    To exclude only the problematic method from JIT compilation, use
    -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/CPPASTFunctionDeclarator,postAccept
    -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPSemantics,declaredBefore
    Another idea is if you try the openjdk to run eclipse and see if that works.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce 9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia ION | 3GB Ram

  6. #6
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Default Re: eclipse cdt helios crashes

    The -Xint argument seem to work for me!

    Thank you very much for your help. It was very annoing the fact that I cannot use eclipse.

    Quote Originally Posted by martin_helm View Post
    martin_helm wrote:
    > past.opensuse.org and post the link to it here.

    This shall be paste.opensuse.org

    In the meantime I found that there is a bug report that indicates it is not an eclipse problem but a 64bit java problem.
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=333227

    One solution it mentions as workaround is the following (comment #8)
    Code:
    This could be another JIT compiler bug similar to
    http://bugs.sun.com/view_bug.do?bug_id=6614100.
    To disable the JIT compiler add -Xint to the vmargs in eclipse.ini.
    To exclude only the problematic method from JIT compilation, use
    -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/CPPASTFunctionDeclarator,postAccept
    -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPSemantics,declaredBefore
    Another idea is if you try the openjdk to run eclipse and see if that works.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce 9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia ION | 3GB Ram

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: eclipse cdt helios crashes

    ionpetrache wrote:
    >
    > The -Xint argument seem to work for me!

    Glad to hear that, have much fun.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •