Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: "/home is a folder, but a file was expected"

  1. #1
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default "/home is a folder, but a file was expected"

    I use openSUSE 11.4, KDE Desktop.

    Each time I open my /home folder via Konqueror, I'm prompted with this message at the bottom of the Konqueror window. Since I'm a noob, I'm wondering if this is "normal". I did a google search and didn't find anything of interest.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: "/home is a folder, but a file was expected"

    Is the the default kde for 11.4 or have you added repos?

    Try a new user account and see if you get the same behaviour
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: "/home is a folder, but a file was expected"

    Have a look in Settings>General and what you have as your Home Page; possibly a / is missing; my entry is /home/john

  4. #4
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: "/home is a folder, but a file was expected"

    My Konqueror version is 4.6.0-6.6.2 (the same version as the terminal). I haven't added any repos.

    I will try with a new user account.

  5. #5

    Default Re: "/home is a folder, but a file was expected"

    actually there was this thread Sabayon Forums • View topic - I am not able to make dolphin as my default file manager but I don't think it's a bit misleading.
    So you might try this:
    alt-f2 --> systemsettings --> File Associations --> inode --> directory
    select Dolphin in the right list (it must be the first of the list) --> Edit
    select Application and check that "Command" voice is:
    Code:
    dolphin %i -caption "%c" %u
    with %u at the end
    being there... you may just do the same for next voice in the list, which should be "Konqueor" and check that Application tab --> Command is:
    Code:
    kfmclient openURL %u inode/directory
    hope it helps

  6. #6
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: "/home is a folder, but a file was expected"

    Quote Originally Posted by john_hudson View Post
    Have a look in Settings>General and what you have as your Home Page; possibly a / is missing; my entry is /home/john
    I have changed it and closed Konqueror. Same message though. Anyway, I can access my files, I just don't know why it keeps displaying this message.

  7. #7
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: "/home is a folder, but a file was expected"

    Quote Originally Posted by caf4926 View Post
    Is the the default kde for 11.4 or have you added repos?

    Try a new user account and see if you get the same behaviour
    I've added a new user, logged in...same message. I really don't know. I've upgraded my openSUSE 11.3 to 11.4 some time ago, but I didn't notice it until yesterday.

  8. #8
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: "/home is a folder, but a file was expected"

    Quote Originally Posted by fabio_s View Post
    actually there was this thread Sabayon Forums • View topic - I am not able to make dolphin as my default file manager but I don't think it's a bit misleading.
    So you might try this:
    alt-f2 --> systemsettings --> File Associations --> inode --> directory
    select Dolphin in the right list (it must be the first of the list) --> Edit
    select Application and check that "Command" voice is:
    Code:
    dolphin %i -caption "%c" %u
    with %u at the end
    being there... you may just do the same for next voice in the list, which should be "Konqueor" and check that Application tab --> Command is:
    Code:
    kfmclient openURL %u inode/directory
    hope it helps
    Thanks. I've done that, too. No change...

  9. #9
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: "/home is a folder, but a file was expected"

    Ok, I think I've got it. Thank you for the replies.

    I've checked this thread: Unable to mount/view partitions through Konqueror

    and Henk van Velden's post in particular:

    "Default Re: Unable to mount/view partitions through Konqueror

    It seems that in 11.3 the sysinfo of Konqureror (on this subject) points to the block device special file of the partition (like /dev/sdc1). When you click on it, as usual, Konqueror tries to find an applic thatis associated to the type of file (like gwenvie for a JPEG, or konqueror for an HTML, amarok for an MP3, etc), but non is defined (not strange because only root can access these files, so why configure something for the end-user). And it says so in the error message.

    And of course the normal way of using mounted file systems in a Unix/Linux OS is forgetting that it is a different partition, but simply walking to it through the directory tree. This starting from mountpoints seems to be a leftover from those who used MD Windows for a considarable tiime. "


    So Konqueror points to the block device file of the partition! That's why when I write the path to /home it doesn't display any error message. Maybe it's not a very clever thing to access your partition from Konqueror's sysinfo.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: "/home is a folder, but a file was expected"

    Maybe it's not a very clever thing to access your partition from Konqueror's sysinfo.
    No
    I never do
    But it should work.
    Let me check
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •