Results 1 to 5 of 5

Thread: How get screen to stop turning off after some time on desktop?

  1. #1

    Default How get screen to stop turning off after some time on desktop?

    I've tried everything: turn off screen saver, turn off power management, set it to be performance, nothing works!

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : How get screen to stop turning off after some time on desktop?

    Hi,

    Wich desktop you are using : KDE or GNOME ?

    In KDE, you have to set it through the system config->Kpowersaving and edit the profile you want (performance in your case) and set it to not turn off the monitor.

  3. #3

    Default Re: Re : How get screen to stop turning off after some time on desktop?

    Assuming you have already done what the 1st answer to your question suggests try adding line

    option "DPMS" "FALSE"

    to the file /etc/X11/xorg.conf in both the screen and monitor sections. This disable standard vesa power management. Some no doubt will say that only one entry needs to be made but it seems that the 2 are needed these days.

    If you do not have an xorg.conf file look in the /ect/X11/xorg.conf.d directory. There will be a screen file and a monitor file. Adding this line to both should have the same effect.

    I have my machine set up like this with an xorg.conf file and the monitor no longer turns off no matter how long I leave it. I have also disabled acpi during installation but do not think this has any effect on display management. It does prevent the system from running down the cpu frequency and spinning discs down though. If it still does turn off you will need to achieve this some how as well. You may have the opportunity to add this when you boot up.

    Like you just changing kde settings didn't work for me.
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  4. #4

    Default Re: Re : How get screen to stop turning off after some time on desktop?

    Quote Originally Posted by ajohnw View Post
    Assuming you have already done what the 1st answer to your question suggests try adding line

    option "DPMS" "FALSE"

    to the file /etc/X11/xorg.conf in both the screen and monitor sections. This disable standard vesa power management. Some no doubt will say that only one entry needs to be made but it seems that the 2 are needed these days.

    If you do not have an xorg.conf file look in the /ect/X11/xorg.conf.d directory. There will be a screen file and a monitor file. Adding this line to both should have the same effect.

    I have my machine set up like this with an xorg.conf file and the monitor no longer turns off no matter how long I leave it. I have also disabled acpi during installation but do not think this has any effect on display management. It does prevent the system from running down the cpu frequency and spinning discs down though. If it still does turn off you will need to achieve this some how as well. You may have the opportunity to add this when you boot up.

    Like you just changing kde settings didn't work for me.
    Thanks, I'll try that. Any idea why that's needed? Sounds like a bug.

  5. #5

    Default Re: How get screen to stop turning off after some time on desktop?

    I think it's a case of X working to some default values that will turn a monitor of if left for rather a long time. It seems the only way to stop it is with DPMS option and that is only read when the X system boots and at no other time. As it does that I can't really see that it's a bug. It's just being officious.

    I haven't tried the kde powersave modes with this setting but screen savers annoy me and I just turn of my monitor when it's not in use. The whole idea of screen savers was to prevent things being burnt into VDU type terminals anyway really.

    I should point out that the no acpi boot/install option will interfere with kde's power management. Personally I wish there was a button on the desktop to reduce power when not in use but unfortunately there doesn't seem to be any way of getting the kernel to do that. You will find plenty on the net about installing acpi into a built kernel but as far as I'm aware zero on removing it without rebooting. Modprobe is the function that is most likely to do it. There is also a command that will cause the kernel to reload it's modules. Unfortunately I mostly just use the desktop and can't remember it. Wish I could actually. It might be useful.

    If playing with system files I always copy them to make restoration easy from the prompt.
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •