Results 1 to 5 of 5

Thread: IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

  1. #1
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

    Hi guys I am running my wifi using YAST and IFUP. The card is a zd1211, and works just fine. However lately I have have to "start" it manually after booting. The only way I have found to do this is to open YAST >network settings> and "edit" the card, but NOT change anything, just click through the next buttons and it connects. I have tried using the settings "on boot" and "on hotpug" but always when I reboot, I have to go through the YAST rigmarole. This is a PITA. Can anyone guide me please? I am trying to avoid NM as I want to sort this out, not cover it up with more software.

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

    I'm not familiar with that card, but since you posted in Wireless, I assume it is a WiFi card.

    Try changing the DHCP client to "dhclient" instead of "dhcpd". I found that WiFi was not reliable with "ifup" unless I made that change.

    It seems that "dhcpd" is caching too much information about the connection, and reusing that cached information instead of making a new dhcp query.

    You change in Yast --> system --> /etc/sysconfig
    (you can probably find you own way from there).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

    Thank-you Nrickert, but your advice did not work, in fact I lost connection altogether, so I put it back how it was. I seem to have sorted it by accident ( ) rather unscientifically and I was tweaking other settings at the time so I am afraid i can't detail the exact settings changed, but I think it was in >menu>system settings>network & conn > network settings. I think NM was trying to take over when KDE was loading (???? this just an idiot guess blush).....

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  4. #4
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

    D'oh I thought it was solved, but a second reboot, and I am back to square 1......
    As a workaround while I am trying to solve, what command is YAST sending when I do YAST> Network settings > select device > edit > next > OK and I dont change anything, it takes a while and when it gets to activate network settings and my net monitor says 'connected'. What 'command' is YAST actually sending at this point?

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: IFUP Woes and grief (set up looks fine and works, but won't auto-connect)

    On 04/28/2011 12:06 PM, wakou wrote:
    >
    > D'oh I thought it was solved, but a second reboot, and I am back to
    > square 1......
    > As a workaround while I am trying to solve, what command is YAST
    > sending when I do YAST> Network settings> select device> edit> next>
    > OK and I dont change anything, it takes a while and when it gets to
    > activate network settings and my net monitor says 'connected'. What
    > 'command' is YAST actually sending at this point?


    The only thing I know is that it effectively does the following:

    Code:
    sudo /sbin/ifdown <ifname>
    sudo /sbin/ifup <ifname>
    where <ifname> is wlan1, or whatever interface you are using.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •