Results 1 to 3 of 3

Thread: Obsolete thread: Tumbleweed and Gnome 3

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Obsolete thread: Tumbleweed and Gnome 3

    Greg k-h stated on the mailing list at end last week that it would be a few weeks before the Gnome 3 repo for Tumbleweed was ready for us to do an upgrade from Gnome 2 to 3.

    But he did suggest that I might be able to follow a path of upgrade from 11.4 standard Gnome 2 to Gnome 3 before upgrading the openSUSE 11.4 distro to Tumbleweed -- suggested it might be worth a try. So I gave it a whirl and it works.

    Here are my experiences, starting with openSUSE 11.4 plus Gnome 2 standard, no KDE.

    I added the Factory Gnome (3) repo at priority 98 as per the wiki page for Gnome 3 and ran the "text upgrade". There were no Tubleweed repos atached for this phase. Upgrade to Gnome 3 went perfectly. Then I disabled the openSUSE 11.3 repos and added Tumbleweed plus Tumbleweed/Packman and ran "zypper dup --from Tumbleweed." I received only one dependency error:

    Code:
    Problem: hdjmod-kmp-desktop-1.28_k2.6.37.1_1.2-1.2.x86_64 requires ksym(desktop:current_task) = 8299a889, but this requirement cannot be provided
      deleted providers: kernel-desktop-2.6.37.1-1.2.2.x86_64
     Solution 1: deinstallation of hdjmod-kmp-desktop-1.28_k2.6.37.1_1.2-1.2.x86_64
     Solution 2: keep obsolete kernel-desktop-2.6.37.1-1.2.2.x86_64
     Solution 3: break hdjmod-kmp-desktop by ignoring some of its dependencies
    I chose (1) deinstall hdjmod-kmp-xx because I have no Hercules that I'm aware of. The distro upgrade then went fine.

    I also like Packman RPMs so I ran "zypper up --repo TumbleweedPackman" and that all went smoothly.

    All works well now, Gnome 3 and fully Tumbleweed.

    N.B. change of status: this method is now unnecessary. It is now possible to attach the Tumbleweed:Gnome repo to a standard Tumbleweed distro and upgrade Gnome 2 --> Gnome 3.
    Last edited by swerdna; 30-Apr-2011 at 00:15.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default re: Obsolete thread: Tumbleweed and Gnome 3

    @swerdna, all of kernel related module packages having a version number "2.6.37" must be removed when using Tumbleweed, for sure!

    That is the critical point for any user thinking about turning to Tumbleweed, for example:
    If Tumbleweed relates to linux-2.6.39 in the future and the user feels dependend on ati proprietary fglrx module, Tumbleweed is a NOGO if amd-ati is behind actual developement (as usual, but my proprietary beta nvidia runs with 2.6.39-rc5 now!).

    @swerdna, try playing around with priorities! That way you only will have to use:

    zypper dup

    The additional advantage of using "dup" is to automatically get appearing brand new versions in Tumbleweed!

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default re: Obsolete thread: Tumbleweed and Gnome 3

    Thanks ulenrich. I have just now found that the Tumbleweed:Gnome repo at this address
    HTML Code:
    http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/GNOME/openSUSE_Tumbleweed
    now works very smoothly for upgrading 11.4 Gnome 2 to Gnome 3, so what I said about upgrading with Factory:Gnome is now obsolete and users can attach Tumbleweed:Gnome for a straightforward experience

    More on that here: http://forums.opensuse.org/english/g...gnome-3-a.html
    Last edited by swerdna; 30-Apr-2011 at 12:58.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •