Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Problem adding nvidia repository

  1. #1

    Default Problem adding nvidia repository

    Hi,
    I'm trying to add the NVidia repository
    ftp://download.nvidia.com/opensuse/11.4/
    in order to install the proprietary driver, so I can get desktop effects etc.

    Basically I'm following the instructions in SDB:NVIDIA drivers

    The following error occurs when Yast tries to refresh:

    Download (curl) error for 'ftp://download.nvidia.com/opensuse/11.4/repodata/repomd.xml':
    Error code: HTTP response: 500
    Error message: The requested URL returned error: 500

    The file repomd.xml is there and can be read using a web browser.

    The same errors occurs for ftp://download.nvidia.com/opensuse/11.4/content

    All these errors also occurs with Zypper.

    What's the deal?

    Thanks in advance for the answers.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Problem adding nvidia repository

    Try
    Code:
    # zypper refresh
    And send the output here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Problem adding nvidia repository

    Quote Originally Posted by itayshom View Post
    Hi,
    I'm trying to add the NVidia repository
    ftp://download.nvidia.com/opensuse/11.4/
    in order to install the proprietary driver, so I can get desktop effects etc.

    Basically I'm following the instructions in SDB:NVIDIA drivers


    The following error occurs when Yast tries to refresh:

    Download (curl) error for 'ftp://download.nvidia.com/opensuse/11.4/repodata/repomd.xml':
    Error code: HTTP response: 500
    Error message: The requested URL returned error: 500

    The file repomd.xml is there and can be read using a web browser.

    The same errors occurs for ftp://download.nvidia.com/opensuse/11.4/content

    All these errors also occurs with Zypper.

    What's the deal?

    Thanks in advance for the answers.

    Just a 'zypper refresh' is not going to help. From what you describe the repo is not added at all.
    Open a terminal window and do:
    Code:
    su -c 'zypper ar ftp://download.nvidia.com/opensuse/11.4/ NVIDIA'
    Then do
    Code:
    zypper lr -d
    and post output here. If all is well you should be able to start Softwaremanagement, the driver packages should be autoselected for install.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Problem adding nvidia repository

    It would better to check if repos are refreshed and then go step by step about installation.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Problem adding nvidia repository

    Quote Originally Posted by Knurpht
    Code:
    su -c 'zypper ar ftp://download.nvidia.com/opensuse/11.4/ NVIDIA'
    ...should be

    Code:
    su -c 'zypper ar -f ftp://download.nvidia.com/opensuse/11.4/ NVIDIA'
    ...otherwise the repo won't be refreshed at all.

  6. #6

    Default Re: Απ: Re: Problem adding nvidia repository

    This is the output of

    su -c 'zypper ar ftp://download.nvidia.com/opensuse/11.4/ NVIDIA'
    zypper lr -d


    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+----------------------+-----------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | Contrib | Contrib | No | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.3:/Contrib/standard |
    2 | KR46 | KR46 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Release:/46/openSUSE_11.4 |
    3 | KR46-extra | KR46-extra | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4 |
    4 | Libdvdcss repository | Libdvdcss repository | No | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.3/ |
    5 | NVIDIA | NVIDIA | Yes | Yes | 99 | NONE | ftp://download.nvidia.com/opensuse/11.4/ |
    6 | nvidia | nvidia | Yes | Yes | 99 | NONE | ftp://download.nvidia.com/opensuse/11.4/ |
    7 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    8 | repo-11.4-oss | openSUSE-11.4 OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    9 | repo-11.4-update | openSUSE-11.4 Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |

    as you can see the nvidia repository already existed (line 6).
    Doing a 'zypper refresh' gives the same error.
    Also Yast cannot refresh and the repo does not appear in software management.

    Thanks for the help.

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Re: Problem adding nvidia repository

    Could you tell us the installation process of nvidia drivers. And please read and translate this Εγκατάσταση Drivers Καρτών γραφικών NVIDIA-AMD ATI RADEON

    This driver was written when I had openSUSE 11.3 so the nvidia repo has changed.

    The repo who you need is this
    ftp://download.nvidia.com/opensuse/11.4/

    And you need this
    x11-video-nvidiaG02
    this x11-video-nvidiaG01
    and this x11-video-nvidia(if you have GF4 or older)
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  8. #8

    Default Re: Απ: Re: Απ: Re: Problem adding nvidia repository

    You can use the ftp repo from yast - or could 2 days ago, Add it as a url ftp:// ......................../11.4
    You can also check it exists and that the rpms are in it by putting the url in a browser. Before using one that is probably the best thing to check 1st. This will also tell you what kind of repo it is. The rpm only ones should be picked up as yum.

    John

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Απ: Re: Απ: Re: Problem adding nvidia repository

    @gropiuskalle: thanks for the correction, my mistake
    @itayshom: your repos look OK. One thing I can think of, is corruption of the rpm database. To solve that:
    Code:
    su -c 'rpm --rebuilddb'
    Check the software installer after running and finishing this command

    If the problem persist, please open a terminal window and try to run:
    Code:
    su -c yast
    This will show you Yast in it's ncurses interface. See if it's working and let us know.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Απ: Re: Problem adding nvidia repository

    Quote Originally Posted by itayshom View Post
    This is the output of

    su -c 'zypper ar ftp://download.nvidia.com/opensuse/11.4/ NVIDIA'
    zypper lr -d


    Code:
    # | Alias                | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                                | Service
    --+----------------------+-----------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | Contrib              | Contrib               | No      | Yes     |   99     | rpm-md | Index of /repositories/openSUSE:/11.3:/Contrib/standard    |        
    2 | KR46                 | KR46                  | Yes     | Yes     |   99     | rpm-md | Index of /repositories/KDE:/Release:/46/openSUSE_11.4          |        
    3 | KR46-extra           | KR46-extra            | Yes     | Yes     |   99     | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4 |        
    4 | Libdvdcss repository | Libdvdcss repository  | No      | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                                               |        
    5 | NVIDIA               | NVIDIA                | Yes     | Yes     |   99     | NONE   | ftp://download.nvidia.com/opensuse/11.4/                                           |        
    6 | nvidia               | nvidia                | Yes     | Yes     |   99     | NONE   | ftp://download.nvidia.com/opensuse/11.4/                                           |        
    7 | repo-11.4-non-oss    | openSUSE-11.4 Non-OSS | Yes     | Yes     |   99     | yast2  | Index of /distribution/11.4/repo/non-oss                       |        
    8 | repo-11.4-oss        | openSUSE-11.4 OSS     | Yes     | Yes     |   99     | yast2  | Index of /distribution/11.4/repo/oss                           |        
    9 | repo-11.4-update     | openSUSE-11.4 Updates | Yes     | Yes     |   99     | rpm-md | Index of /update/11.4                                          |
    as you can see the nvidia repository already existed (line 6).
    Doing a 'zypper refresh' gives the same error.
    Also Yast cannot refresh and the repo does not appear in software management.
    You should not have the same repo twice. Just delete one of them and do a zypper refresh.

    Code:
    su -l
    zypper rr NVIDIA
    zypper refresh

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •