Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Problem in updating opensuse 11.4

  1. #1

    Default Problem in updating opensuse 11.4

    Hi

    I have a problem in updating opensuse 11.4, when I try to update the system the progress stops in the update window, and no updates appear


  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Problem in updating opensuse 11.4

    Open your terminal
    And make a
    Code:
    # zypper refresh
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,841
    Blog Entries
    14

    Default Re: Απ: Problem in updating opensuse 11.4

    Quote Originally Posted by stamostolias View Post
    Open your terminal
    And make a
    Code:
    # zypper refresh
    @Stamos: Are you assuming everyone is running openSUSE with root permissions? The command should be:
    Code:
    su -c 'zypper ref'
    Without root permissions, it would throw an error about permissions.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Problem in updating opensuse 11.4

    You are right maybe it would better with a
    Code:
    su
    Sorry for confusing and thanks for adding.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Problem in updating opensuse 11.4

    Actually a '#' in front of a command indicates that it should be run as root. :-)

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problem in updating opensuse 11.4

    I am not too familiar with the intrinsics of packagekit (that is what seems
    to get stuck here).
    Can you try an update from the command line and tell us what happens?
    Open a terminal and type
    Code:
    su -
    zypper up
    before you do that you have to stop the updater applet. I hope under Gnome
    this works: Right click on its symbol at the bottom of your screen an choose
    "exit" or "close" or whatever it is called there.
    If you run into a problem report back.
    What output do do you get from the zypper command?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Problem in updating opensuse 11.4

    Quote Originally Posted by gropiuskalle View Post
    Actually a '#' in front of a command indicates that it should be run as root. :-)
    Yeahh. But it would better to write as Knurpht said with a su, because many new users do not know it.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Re: Απ: Problem in updating opensuse 11.4

    True. Back to topic. :-)

  9. #9

    Default Re: Απ: Re: Απ: Re: Απ: Problem in updating opensuse 11.4

    Thank you all

    zypper refresh

    zypper refresh
    **
    GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
    Repository 'openSUSE-11.4-Non-Oss' is up to date.
    **
    GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
    Repository 'openSUSE-11.4-Oss' is up to date.
    **
    GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
    Repository 'openSUSE-11.4-Update' is up to date.
    All repositories have been refreshed.
    zypper up

    zypper up
    Loading repository data...
    Reading installed packages...

    The following NEW packages are going to be installed:
    bundle-lang-kde-en flash-player libgpod4 libgpod-tools nspluginwrapper
    tar-lang

    The following packages are going to be upgraded:
    aaa_base aaa_base-extras alsa banshee-1 banshee-1-backend-engine-gstreamer
    banshee-1-backend-io-gio banshee-1-backend-platform-gnome
    banshee-1-backend-platform-unix banshee-1-client-classic banshee-1-core
    banshee-1-dmp banshee-1-dmp-apple-devices banshee-1-dmp-mtp
    banshee-1-extensions-default bootsplash bootsplash-branding-openSUSE
    btrfsprogs dhcp dhcpcd dhcp-client dosfstools espeak evolution-data-server
    gdm gio-sharp gnome-applets-gdm gnome-nettool gnome-screensaver
    gstreamer-0_10-plugins-good gtk2-data gtk2-immodule-amharic
    gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese
    gtk2-tools insserv krb5 krb5-client libasound2 libcairo2 libcairo-gobject2
    libcamel-1_2-19 libebackend-1_2-0 libebook-1_2-10 libecal-1_2-8
    libedata-book-1_2-8 libedata-cal-1_2-10 libedataserver-1_2-14
    libedataserverui-1_2-11 libegroupwise-1_2-13 libgpod-sharp libgtk-2_0-0
    libmodplug0 libpcsclite1 libpulse0 libpulse-browse0 libpulse-mainloop-glib0
    libtiff3 libusbmuxd1 mingetty MozillaFirefox
    MozillaFirefox-translations-common mozilla-js20 mozilla-xulrunner20
    mozilla-xulrunner20-gnome mozilla-xulrunner20-translations-common mtools
    ndesk-dbus-glib openSUSE-release openvpn permissions postfix
    pullin-flash-player pulseaudio pulseaudio-esound-compat
    pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-lirc
    pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils rsyslog
    sane-backends sane-backends-autoconfig smolt SuSEfirewall2 sysvinit
    sysvinit-tools tar timezone translation-update translation-update-de
    translation-update-ru usbmuxd virtualbox-guest-kmp-default
    virtualbox-guest-tools virtualbox-guest-x11 xorg-x11 xorg-x11-driver-video
    xorg-x11-xauth yast2-bootloader yast2-control-center yast2-gtk
    yast2-ldap-client yast2-trans-de yast2-trans-en_US yast2-trans-ru

    The following product is going to be reinstalled:
    openSUSE 11.4

    107 packages to upgrade, 6 new.
    Overall download size: 63.9 MiB. After the operation, additional 31.6 MiB will
    be used.
    Continue? [y/n/?] (y):
    I wrote "n" because I want to solve the problem firstly
    thank you

  10. #10
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Απ: Re: Απ: Re: Απ: Problem in updating opensuse 11.4

    https://bugzilla.novell.com/show_bug.cgi?id=672793#c

    Try to run the updates, it's a known bug which is marked as "resolved", so it should work after updating and restarting your GNOME-session.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •