Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

  1. #1

    Default yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    hey guys,

    i came to you with my problem, as I can't manage to solve it on my own...
    so.. I have an old HP laptop nx6325, with a broadcom wireless card, and I use OpenSUSE 11.3...
    up until some time ago I managed to make my wlan0 to work but for a couple of weeks now, I'm not able to connect to my wireless router anymore

    so iwlist shows me this:
    wlan0 Scan completed :
    Cell 01 - Address: 00:21:91:69:CC:E4
    Channel:6
    Frequency:2.437 GHz (Channel 6)
    Quality=55/70 Signal level=-55 dBm
    Encryption keyff
    ESSID:"Fratii"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
    36 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=0000005209b4721f
    Extra: Last beacon: 60ms ago
    IE: Unknown: 0006467261746969
    IE: Unknown: 010482848B96
    IE: Unknown: 030106
    IE: Unknown: 2A0100
    IE: Unknown: 32080C1218243048606C
    Cell 02 - Address: 00:17:3F:A7:9D:57
    Channel:13
    Frequency:2.472 GHz (Channel 13)
    Quality=28/70 Signal level=-82 dBm
    Encryption keyff
    ESSID:"qwerty"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    12 Mb/s; 24 Mb/s; 36 Mb/s
    Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
    Mode:Master
    Extra:tsf=0000001e6070c181
    Extra: Last beacon: 554ms ago
    IE: Unknown: 0006717765727479
    IE: Unknown: 010882848B960C183048
    IE: Unknown: 03010D
    IE: Unknown: 050400010000
    IE: Unknown: 07064E4C20010D14
    IE: Unknown: 2A0100
    IE: Unknown: 32041224606C
    I don't know why there are 2 cells...???? I only have one wireless card..
    yast2 let's me configure (it sees my wireless router, it sets up the connection) but when I star firefox and try to browse something it doesn't load

    networkmanager doesn't even allow me to click on the wireless tab...

    so..after a couple of hours searching the forums and reading everything I still can't make me wlan0 work...
    hope you'll be able to help me...
    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    Post the result of

    Code:
    /sbin/lspci -nnk
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    hey man,
    thanks for the quick reply..
    here's the result...the wireless card is the last...

    00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
    00:04.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a36]
    Kernel driver in use: pcieport
    00:05.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a37]
    Kernel driver in use: pcieport
    00:06.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a38]
    Kernel driver in use: pcieport
    00:12.0 IDE interface [0101]: ATI Technologies Inc IXP SB400 Serial ATA Controller [1002:4379] (rev 80)
    Kernel driver in use: sata_sil
    00:13.0 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4374] (rev 80)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: ohci_hcd
    00:13.1 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4375] (rev 80)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: ohci_hcd
    00:13.2 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB2 Host Controller [1002:4373] (rev 80)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: ehci_hcd
    00:14.0 SMBus [0c05]: ATI Technologies Inc IXP SB400 SMBus Controller [1002:4372] (rev 82)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: piix4_smbus
    00:14.1 IDE interface [0101]: ATI Technologies Inc IXP SB400 IDE Controller [1002:4376] (rev 80)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: pata_atiixp
    00:14.2 Audio device [0403]: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller [1002:437b] (rev 01)
    Subsystem: Device [30b0:103c]
    Kernel driver in use: HDA Intel
    00:14.3 ISA bridge [0601]: ATI Technologies Inc IXP SB400 PCI-ISA Bridge [1002:4377] (rev 80)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    00:14.4 PCI bridge [0604]: ATI Technologies Inc IXP SB400 PCI-PCI Bridge [1002:4371] (rev 80)
    00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
    00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
    00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
    00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
    Kernel driver in use: k8temp
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS482 [Radeon Xpress 200M] [1002:5975]
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: radeon
    02:01.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet [14e4:169c] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: tg3
    02:04.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: yenta_cardbus
    02:04.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: ohci1394
    02:04.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: tifm_7xx1
    02:04.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]
    Subsystem: Hewlett-Packard Company Device [103c:30b0]
    Kernel driver in use: sdhci-pci
    30:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
    Subsystem: Hewlett-Packard Company Broadcom 802.11a/b/g WLAN [103c:1361]
    Kernel driver in use: b43-pci-bridge

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    This is you device

    30:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
    Subsystem: Hewlett-Packard Company Broadcom 802.11a/b/g WLAN [103c:1361]
    Kernel driver in use: b43-pci-bridge
    Try following this:
    Install Broadcom Drivers from Packman
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    hey...
    thanks ..i've done that...it installed some other drivers...
    unfortunatly it still doesn't work... and now..iwlist doesn't see wlan0 anymore...

    what next???

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    Post result of the following

    Code:
    uname -a
    Code:
    rpm -qa | grep broadcom
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    hey..
    uname-a
    Linux linux-h5ks 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

    rpm -qa | grep broadcom
    broadcom-wl-5.100.82.38-7.pm.9.1.x86_64
    broadcom-wl-kmp-desktop-5.100.82.38_k2.6.34.7_0.7-7.pm.9.1.x86_64


    thanks for your incredibli fast replys..
    i might add..that the notebook has a extra button, that is a on/off for bluetooth and wireless devices, and in windows work perfectly..in linux it isn't set up...and the blue led (which states it's ON function) is always light up..maybe this helps..

    thanks again

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    I need you to install something:
    In the terminal become su -

    Code:
    zypper in rfkill
    Now report the result of

    Code:
    /usr/sbin/rfkill list
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    oh.. thank you... I read about rfkill here...after I did the research...but didn't knew I had to install it...
    so the result is:

    0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    2: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: yast2 configs my wlan0, same does iwlist, but I can't connect to my router

    Now post again the wireless part of

    Code:
    /sbin/lspci -nnk
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 5 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •