Results 1 to 10 of 10

Thread: Update error with zypper

  1. #1
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Post Update error with zypper

    I am experiencing update error when I try to update Suse 11.4 KDE with zypper
    babloo@linux-3npg:~> su
    Password:
    linux-3npg:/home/babloo # zypper up
    Loading repository data...
    Reading installed packages...

    The following package updates will NOT be installed:
    gstreamer-0_10-plugins-good k3b libvpx0 libwavpack1 linphone taglib

    Nothing to do.
    linux-3npg:/home/babloo #

    Can you please suggest a remedy.
    Thanks.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Update error with zypper

    Hello try a
    Code:
    # zypper refresh
    Post the output here.

    Maybe these packages have already installed.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Re: Απ: Update error with zypper

    Here is the output

    linux-3npg:/home/babloo # zypper refresh
    Repository 'contrib' is up to date.
    Repository 'libdvdcss' is up to date.
    Repository 'nvidia' is up to date.
    Repository 'packman' is up to date.
    Repository 'openSUSE-11.4-Non-Oss' is up to date.
    Repository 'openSUSE-11.4-Oss' is up to date.
    Repository 'openSUSE-11.4-Update' is up to date.
    All repositories have been refreshed.

    Is the update related to multimedia? I remember recently I had various problems playing media files with various players. I installed smplayer, banshee, kaffeine, vlc etc etc... These players just refused to play various files. Atlast I have installed Dragonplayer.. So far it doesn't show subtitles options, but otherwise its running fine.

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Update error with zypper

    Quote Originally Posted by babloo75 View Post
    Here is the output

    linux-3npg:/home/babloo # zypper refresh
    Repository 'contrib' is up to date.
    Repository 'libdvdcss' is up to date.
    Repository 'nvidia' is up to date.
    Repository 'packman' is up to date.
    Repository 'openSUSE-11.4-Non-Oss' is up to date.
    Repository 'openSUSE-11.4-Oss' is up to date.
    Repository 'openSUSE-11.4-Update' is up to date.
    All repositories have been refreshed.

    Is the update related to multimedia? I remember recently I had various problems playing media files with various players. I installed smplayer, banshee, kaffeine, vlc etc etc... These players just refused to play various files. Atlast I have installed Dragonplayer.. So far it doesn't show subtitles options, but otherwise its running fine.
    I want to check of repos update.
    Anyway try with Vlc and set subtitles here. If you have problems to play media files, so you need some codecs.
    Could I see your repos?
    Code:
    su
    Code:
    # zypper lr -d
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Re: Απ: Re: Απ: Update error with zypper

    linux-3npg:/home/babloo # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------+----------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------+--------
    1 | contrib | contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.4:/Contrib/standard |
    2 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.4/ |
    3 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.4/ |
    4 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/openSUSE_11.4 |
    5 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
    6 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
    7 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    8 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    9 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |
    10 | repo-update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    linux-3npg:/home/babloo #

  6. #6
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Update error with zypper

    What do you mean to play various files??

    You have tried to play a media file with no success?

    As I can see you have the correct repos to play multimedia files. Maybe you missed some codecs.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  7. #7
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Re: Απ: Re: Απ: Re: Απ: Update error with zypper

    Yes I am talking about movie files. Earlier smplayer used to run fine. One fine day, it stopped functioning. Then I uninstalled it, replaced it with kaffeine, it too didn't function. Installed vlc, even vlc didn't load. Uninstalled it too.
    Then came banshee... same problem.
    Finally I am having Dragonplayer. It can open movie files, songs; but the option of 'subtitles' is dimmed out and cannot be selected.

  8. #8
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Re: Απ: Update error with zypper

    I do not thing that your packman has problems but try to install VLC.

    Check if you have installed these codecs and libraries
    amarok-packman (if kde or you want this media player) + amarok-xine
    libavcodec52
    libdvdnav4
    libdvdplay0
    libdvdread4
    libavdevice52
    ffmpeg
    libquicktime0
    libxine1
    libxine1-codecs
    libxvidcore4
    smplayer
    vlc
    w32codec-all
    xine-ui
    xvidcore
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,393
    Blog Entries
    1

    Default Re: Απ: Re: Απ: Re: Απ: Re: Απ: Update error with zypper

    @babloo75. Did you read the stickies in the Multimedia forum?

    Multimedia

    The required codecs can be found in the Packman repo, along with the fully-working version of kaffeine. It is not necessary to install vlc. Read the post by caf4926 in the first sticky.

  10. #10
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: Απ: Re: Απ: Update error with zypper

    Check if you have these libraries
    amarok-packman (if kde or you want this media player) + amarok-xine
    libavcodec52
    libdvdnav4
    libdvdplay0
    libdvdread4
    libavdevice52
    ffmpeg
    libquicktime0
    libxine1
    libxine1-codecs
    libxvidcore4
    smplayer
    vlc
    w32codec-all
    xine-ui
    xvidcore
    I have written a guide about multimedia in Greek subforum and check the multimedia guide of caf4926 as deano_ferrari said, because mine guide is in Greek.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •