I need to install java jre 1.6.0_07 or higher. I did an install of java which was jre 1.6.0 but when running wine it errored out stating I needed jre 1.6.0_07 or higher in order to run this diabetes program which is a windows file.

linux-f9ak:/home/larry # yast2 --update all
linux-f9ak:/home/larry # yast2 -i java jre 1.6.0_20
linux-f9ak:/home/larry #
I tried the above in a terminal got an error.
can someone assist me.
Larry