Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

  1. #1

    Default Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    I just upgraded my machine from 32 bit SuSE 11.2 to 64 bit SuSE 11.4.
    I need the Nvidia proprietary driver for 3D hardware support ( I do 3D work so I really need this )
    I got the driver from here:
    NVIDIA DRIVERS 270.41.06 Certified
    (it says Linux x64 (AMD64/EM64T) Display Driver)
    My processor is Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz

    Anyway, I'm used to installing the driver like this:

    1) Kernel sources must be installed and configured. Usually this means
    installing the 'kernel-source', 'make' and 'gcc' packages with YaST2.
    Now download the latest Nvidia driver:

    Place the file in your /home/username

    Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
    At the login
    Login with your username and password

    Now switch to super user with su
    and root password

    *Now remember you can use the {TAB} key to auto complete

    so type:
    sh NVIDIA{TAB}
    and the whole file name should auto complete

    eg: sh NVIDIA-Linux-x86-185.18.36-pkg1.run

    Follow the installer and let it compile the kernel module for you.
    Say Yes to everything
    Use TAB to move around
    reboot
    --------------------
    When I viewed the installation instructions for the 64 bit version, it had this extra step:
    Code:
    2) Run the following commands
    
     echo "blacklist nouveau" > /etc/modprobe.d/nvidia.conf
     # recreate initrd without KMS, if the use of KMS is enabled in initrd
     if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
       sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel
       mkinitrd
     fi
    Do I really have to do this? I have no idea about KMS nor initd. I've never had to do that step before.
    BTW, SuSE 11.4 was not on the instructions list. It only went up to 11.3.

    I'm just confused.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Quote Originally Posted by gymnart View Post
    Do I really have to do this? I have no idea about KMS nor initd. I've never had to do that step before.
    BTW, SuSE 11.4 was not on the instructions list. It only went up to 11.3.

    I'm just confused.
    The big difference for nVidia hardware is in 11.2 the opensource nouveau graphic driver was not so popular, and not installed by default in 11.2. Starting with openSUSE-11.3 the nouveau graphic driver was installed and loaded by default. However there are extra steps when installing the proprietary nvidia driver after having the nouveau driver. Dependent on one's hardware one or more steps are needed. The steps can consist of:
    1. disable KMS per the openSUSE-11.4 release notes (that you read ? right ?? ) ie navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to "yes". This takes a minute or two to save once changed is submitted, and/or
    2. boot with the boot code 'nomodeset' when building the proprietary graphic driver like you just attempted, and/or
    3. blacklist the nouveau driver via
      Code:
      echo "blacklist nouveau" > /etc/modprobe.d/50-blacklist.conf

    Again, typically not all are needed and it depends on one's exact hardware. I typically implement #1 and #2 but not #3.

  3. #3

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Thanks.
    What if something goes wrong (or I so something wrong or forget a step) and I have to go back to the Nouveau driver?
    How would I do that? Or would SuSE be able to just fall back to that?

    P.S.
    boot with the boot code 'nomodeset' when building the proprietary graphic driver like you just attempted
    what exactly is that? do you mean booting into run level 3?
    Last edited by gymnart; 23-Apr-2011 at 13:05. Reason: another question

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Quote Originally Posted by gymnart View Post
    What if something goes wrong (or I so something wrong or forget a step) and I have to go back to the Nouveau driver?
    How would I do that?
    To go back to the nouveau graphic driver just 'undo' everything you have done.

    ie remove any blacklist in 50-blacklist.conf. Remove the 'no' setting in the "NO_KMS_IN_INITRD". And do not boot with the 'nomodeset' boto code, and finally remove the proprietary NVIDIA driver with root permissions with :
    Code:
    sh NVIDIA{TAB} -uninstall
    I'm going by memory so you may need to play with the syntax a bit.

    Quote Originally Posted by gymnart View Post
    what exactly is that? do you mean booting into run level 3?
    I don't understand what you are asking. do you mean how to boot with the 'nomodeset' boot code? Simply enter it in the options line of the grub menu.

    [click on image for larger version of image]

    I recommend you install (if not already installed) the program 'midnight commander' (mc) which is a text editor that can be run in text mode by typing 'mc' . It is menu driven by function keys and its pretty intuitively obvious. Very handy if you are stuck in text mode and have to edit some system files.

  5. #5

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    So, instead of
    Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
    I would type in "nomodeset" (without quotes of course) in the boot arguments place rather than just typing 3 when I want to install the driver?

    I now have mc installed. Does this run in run level 3 too?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Quote Originally Posted by gymnart View Post
    So, instead of
    I would type in "nomodeset" (without quotes of course) in the boot arguments place rather than just typing 3 when I want to install the driver?
    No.

    Since you need to go to run level 3 to build the proprietary driver, you need BOTH the "nomodeset" followed by the "3" separated by a space.

    Quote Originally Posted by gymnart View Post
    I now have mc installed. Does this run in run level 3 too?
    Yes. Just try it. Explore.

  7. #7

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    So, just so that I'm sure, this is what I should do (I hope I got this right):

    1) Disable KMS ie navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to "yes".

    2) Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then type: "nomodeset 3" (without the quotes of course)

    4) At the login
    Login with your username and password

    5) Now switch to super user with su
    and root password

    6) *Now remember you can use the {TAB} key to auto complete

    so type:
    sh NVIDIA{TAB}
    and the whole file name should auto complete

    eg: sh NVIDIA-Linux-x86_64-270.41.06.run

    Follow the installer and let it compile the kernel module for you.
    Say Yes to everything
    Use TAB to move around

    7) reboot

    And I don't have to blacklist the nouveau driver, right? This might not cause any trouble, right?

    Then I won't have to worry about using nomodeset ever again, even when I have to re-install the NVidia driver (after xorg updates and kernel updates) right?

  8. #8

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Here's a bit of a screenshot of how the nouveau driver handles the theme I'm using (Oxygen)
    http://i64.photobucket.com/albums/h1...sontaskbar.png
    Notice the stripes!
    I remember with 11.2, it would do that after an xorg update and it would look right once I re-installed the NVidia proprietary driver.
    Last edited by gymnart; 24-Apr-2011 at 08:37. Reason: fixed screenshot

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Quote Originally Posted by gymnart View Post
    So, just so that I'm sure, this is what I should do (I hope I got this right):

    2) Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then type: "nomodeset 3" (without the quotes of course)
    No need to delete the "VGA... " entry.

    Quote Originally Posted by gymnart View Post
    eg: sh NVIDIA-Linux-x86_64-270.41.06.run
    If it were me, I would type:

    sh NVIDIA-Linux-x86_64-270.41.06.run -q


    Quote Originally Posted by gymnart View Post
    And I don't have to blacklist the nouveau driver, right? This might not cause any trouble, right?
    Only black list in a 2nd attempt if 1st fails.

    Quote Originally Posted by gymnart View Post
    Then I won't have to worry about using nomodeset ever again, even when I have to re-install the NVidia driver (after xorg updates and kernel updates) right?
    Thats the way it works for me.

    Note you can reboot from terminal with (root permissions):
    Code:
    shutdown -r now
    and you can halt from terminal with (root permissions):
    Code:
    shutdown -h now

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Nvidia 8600 GTS 64 bit driver for SuSE 11.4?

    Quote Originally Posted by gymnart View Post
    Here's a bit of a screenshot of how the nouveau driver handles the theme I'm using (Oxygen)
    http://i64.photobucket.com/albums/h1...sontaskbar.png
    Notice the stripes!
    I remember with 11.2, it would do that after an xorg update and it would look right once I re-installed the NVidia proprietary driver.
    Are not the stripes part of the theme ? Is that what you want to get or get rid of ? Because the stripes are supposed to be there.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •