Results 1 to 10 of 10

Thread: zypper dup - my solution - but unsure about some repos

  1. #1
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default zypper dup - my solution - but unsure about some repos

    To enable "zypper dup" to have the vendor change when there are new tumble packages arriving, this is my output of "zypper lr -anrupP"
    Code:
    #  | Alias        | Name           | Enabled | Refresh | Priority | URI                                                                                       
    ---+--------------+----------------+---------+---------+----------+-------------------------------------------------------------------------------------------
     3 | games        | games          | Yes     | Yes     |   22     | http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/                      
     4 | gnome        | gnome          | Yes     | Yes     |   22     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/GNOME/openSUSE_Tumbleweed/
     7 | kde          | kde            | Yes     | Yes     |   22     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/KDE/openSUSE_Tumbleweed/  
    13 | packman      | packman        | Yes     | Yes     |   22     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/            
    14 | tumble       | tumble         | Yes     | Yes     |   22     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                  
    15 | vbox         | vbox           | Yes     | Yes     |   22     | http://download.opensuse.org/repositories/Virtualization/openSUSE_Tumbleweed/             
     1 | contrib      | contrib        | Yes     | Yes     |   44     | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/       
     2 | contribgnome | contribGnomeF  | Yes     | Yes     |   44     | http://download.opensuse.org/repositories/GNOME:/Contrib/openSUSE_Factory+GNOME_Factory/  
     5 | gnomer       | gnomeRelease   | Yes     | Yes     |   44     | http://download.opensuse.org/repositories/GNOME:/STABLE:/3.0/openSUSE_11.4/               
     8 | kder         | kdeRelease     | Yes     | Yes     |   44     | http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/                 
     9 | kdextra      | kdextraRelease | Yes     | Yes     |   44     | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4/        
    12 | ossupdate    | ossUpdate      | Yes     | Yes     |   44     | http://download.opensuse.org/update/11.4/                                                 
    10 | oss          | openSUSE       | Yes     | No      |   66     | http://download.opensuse.org/distribution/11.4/repo/oss/                                  
    11 | ossnon       | nonOpen        | Yes     | No      |   66     | http://download.opensuse.org/distribution/11.4/repo/non-oss/                              
     6 | google       | google         | Yes     | Yes     |   88     | http://dl.google.com/linux/chrome/rpm/stable/x86_64/
    /etc/zypp/repos.d/myreps.repo
    Code:
    [contrib]
    name=contrib
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=44
    gpgcheck=1
    keeppackages=1
    
    [contribgnome]
    name=contribGnomeF
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/GNOME:/Contrib/openSUSE_Factory+GNOME_Factory/
    path=/
    type=rpm-md
    priority=44
    gpgcheck=1
    keeppackages=1
    
    [games]
    name=games
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    
    [gnome]
    name=gnome
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/GNOME/openSUSE_Tumbleweed/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    
    [gnomer]
    name=gnomeRelease
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/GNOME:/STABLE:/3.0/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=44
    gpgcheck=1
    keeppackages=1
    
    [google]
    name=google
    enabled=1
    autorefresh=1
    baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64/
    type=rpm-md
    priority=88
    keeppackages=1
    
    [kde]
    name=kde
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/Tumbleweed:/KDE/openSUSE_Tumbleweed/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    
    [kder]
    name=kdeRelease
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=44
    gpgcheck=1
    keeppackages=1
    
    [kdextra]
    name=kdextraRelease
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4/
    path=/
    type=rpm-md
    priority=44
    gpgcheck=1
    keeppackages=1
    
    [oss]
    name=openSUSE
    enabled=1
    autorefresh=0
    baseurl=http://download.opensuse.org/distribution/11.4/repo/oss/
    type=yast2
    priority=66
    keeppackages=1
    
    [ossnon]
    name=nonOpen
    enabled=1
    autorefresh=0
    baseurl=http://download.opensuse.org/distribution/11.4/repo/non-oss/
    type=yast2
    priority=66
    keeppackages=1
    
    [ossupdate]
    name=ossUpdate
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/update/11.4/
    path=/
    type=rpm-md
    priority=44
    keeppackages=1
    
    [packman]
    name=packman
    enabled=1
    autorefresh=1
    baseurl=http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    
    [tumble]
    name=tumble
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    
    [vbox]
    name=vbox
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/Virtualization/openSUSE_Tumbleweed/
    path=/
    type=rpm-md
    priority=22
    gpgcheck=1
    keeppackages=1
    The only minor problems are:

    - some packman gstreamer not in sync but newer in Gregs "tumble" repository
    - some yast2-controlcenter-qt newer in openSUSE-update than in kde_Release_46
    - a bunch of packages existing in kde-46-Release but not in kde of tumbleWeed, which is why I enabled this kde_Release_46 repository

    I am quiet unsure about all repos having priority 44, but:

    This repository list enables me to run tumbleWeed Gnome3 and also tumbleWeed Kde-4.6 starting from the same gdm3 displaymanager! All updates coming in using just:

    zypper dup

  2. #2
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Arriving Gnome-3.0.1 is complete but Kde-4.6.2 not so

    With arriving Gnome-3.0.1 in Tumbleweeds testing gnome repo I can remove my priority 44 GnomeRelease repo from above list. But when I remove my priority 44 kdeRelease repo this happens, when "zypper -v dup"
    Code:
    Verbosity: 1
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Initializing Target
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    Force resolution: No
    Computing upgrade...
    
    The following packages are going to be upgraded:
    amarok                       
      2.4.0-2.3 -> 2.4.0-8.11.3
    amarok-lang                  
      2.4.0-2.3 -> 2.4.0-8.11.3
    gpgme                        
      1.3.0-4.1 -> 1.3.0-12.1  
    libarchive2                  
      2.8.4-3.1 -> 2.8.4-8.1   
    libassuan0                   
      2.0.0-5.1 -> 2.0.1-4.1   
    libgpgme11                   
      1.3.0-4.1 -> 1.3.0-12.1  
    libphonon4                   
      4.4.4-2.1 -> 4.4.4-3.1   
    phonon                       
      4.4.4-2.1 -> 4.4.4-3.1   
    phonon-backend-gstreamer-0_10
      4.4.4-2.1 -> 4.4.4-3.1   
    
    
    The following packages are going to be downgraded:
    akonadi-runtime             
      1.5.2-89.1 -> 1.5.0-3.3.1                  
    choqok                      
      1.1-25.1 -> 1.0-3.2                        
    cln                         
      1.3.1-66.1 -> 1.3.1-2.1                    
    clucene-core                
      0.9.21-81.1 -> 0.9.21-74.1                 
    ggz                         
      0.0.14.1-54.1 -> 0.0.14.1-49.1             
    kaffeine                    
      1.2.2-51.1 -> 1.1-7.10.1                   
    kcm_gtk                     
      1.1-25.7 -> 1.1-13.2                       
    kio_iso                     
      2.0.0-51.17 -> 2.0.0-15.3                  
    kiosktool                   
      1.99.svn1122153-19.6 -> 1.99.svn1122153-4.1
    kipi-plugins                
      1.9.0-121.6 -> 1.8.0-5.2                   
    kipi-plugins-acquireimage   
      1.9.0-121.6 -> 1.8.0-5.2                   
    kipi-plugins-lang           
      1.9.0-121.6 -> 1.8.0-5.2                   
    konversation                
      1.3.1-42.9 -> 1.3.1-7.10.1                 
    konversation-lang           
      1.3.1-42.9 -> 1.3.1-7.10.1                 
    krusader                    
      2.0.0-51.17 -> 2.0.0-15.3                  
    krusader-doc                
      2.0.0-51.17 -> 2.0.0-15.3                  
    ksshaskpass                 
      0.5.3-11.6 -> 0.5.3-2.1                    
    ktorrent                    
      4.1.0-98.6 -> 4.1.0-1.3.1                  
    ktorrent-lang               
      4.1.0-98.6 -> 4.1.0-1.3.1                  
    kvkbd                       
      0.6-19.6 -> 0.6-9.1                        
    kwebkitpart                 
      1.1.0-16.7 -> 1.1.0-3.2                    
    kwebkitpart-lang            
      1.1.0-16.7 -> 1.1.0-3.2                    
    lensfun                     
      0.2.5-28.2 -> 0.2.5-7.3                    
    libakonadiprotocolinternals1
      1.5.2-89.1 -> 1.5.0-3.3.1                  
    libattica0                  
      0.2.0-27.2 -> 0.2.0-5.1                    
    libggz2                     
      0.0.14.1-54.1 -> 0.0.14.1-49.1             
    libiodbc3                   
      3.52.7-14.1 -> 3.52.6-9.1                  
    libktorrent3                
      1.1.0-15.2 -> 1.1.0-1.3.1                  
    libktorrent3-lang           
      1.1.0-15.2 -> 1.1.0-1.3.1                  
    liblastfm0                  
      0.3.0-13.12 -> 0.3.0-7.2                   
    liblensfun0                 
      0.2.5-28.2 -> 0.2.5-7.3                    
    liblqr-1-0                  
      0.4.1-12.1 -> 0.4.1-6.1                    
    libmsn0_3                   
      4.1-24.1 -> 4.1-5.1                        
    libpolkit-qt-1-1            
      0.99.1-32.1 -> 0.99.1-5.1                  
    libqalculate5               
      0.9.7-9.1 -> 0.9.7-2.1                     
    libqimageblitz4             
      0.0.4-207.2 -> 0.0.4-106.1                 
    libqoauth1                  
      1.0.1-15.1 -> 1.0.1-3.1                    
    libsoprano4                 
      2.5.63-95.2 -> 2.5.63-5.1                  
    libssh4                     
      0.4.8-20.1 -> 0.4.8-7.1                    
    libstrigi0                  
      0.7.3.99-61.15 -> 0.7.3.99-9.2             
    oxygen-gtk                  
      1.0.3-11.1 -> 1.0.1-2.2                    
    phonon-backend-xine         
      4.4.4-17.2 -> 4.4.4-3.1                    
    plasmoid-quickaccess        
      0.8.1-20.4 -> 0.8.1-9.2                    
    polkit-kde-agent-1          
      0.99.0-13.3 -> 0.99.0-3.1                  
    polkit-kde-kcmmodules-1     
      0.98.1-13.7 -> 0.98.1-3.2                  
    qalculate                   
      0.9.7-9.1 -> 0.9.7-2.1                     
    shared-desktop-ontologies   
      0.5-17.1 -> 0.5-2.1                        
    skanlite                    
      0.7.kde4.5.0-46.6 -> 0.7.kde4.5.0-3.1      
    soprano                     
      2.5.63-95.2 -> 2.5.63-5.1                  
    soprano-backend-redland     
      2.5.63-95.2 -> 2.5.63-5.1                  
    soprano-backend-virtuoso    
      2.5.63-98.3 -> 2.5.63-5.1                  
    speedcrunch                 
      0.10.1-102.2 -> 0.10.1-53.1                
    strigi                      
      0.7.3.99-61.15 -> 0.7.3.99-9.2             
    synaptiks                   
      0.4.0-21.6 -> 0.4.0-9.2                    
    virtuoso-drivers            
      6.1.2-20.1 -> 6.1.2-4.3                    
    virtuoso-server             
      6.1.2-20.1 -> 6.1.2-4.3                    
    yakuake                     
      2.9.8-19.6 -> 2.9.8-3.1                    
    
    
    The following packages are going to change vendor:
    akonadi-runtime              
      1.5.2-89.1 -> 1.5.0-3.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    amarok                       
      2.4.0-2.3 -> 2.4.0-8.11.3                  
      obs://build.opensuse.org/KDE -> openSUSE
    amarok-lang                  
      2.4.0-2.3 -> 2.4.0-8.11.3                  
      obs://build.opensuse.org/KDE -> openSUSE
    choqok                       
      1.1-25.1 -> 1.0-3.2                        
      obs://build.opensuse.org/KDE -> openSUSE
    cln                          
      1.3.1-66.1 -> 1.3.1-2.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    clucene-core                 
      0.9.21-81.1 -> 0.9.21-74.1                 
      obs://build.opensuse.org/KDE -> openSUSE
    ggz                          
      0.0.14.1-54.1 -> 0.0.14.1-49.1             
      obs://build.opensuse.org/KDE -> openSUSE
    gpgme                        
      1.3.0-4.1 -> 1.3.0-12.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    kaffeine                     
      1.2.2-51.1 -> 1.1-7.10.1                   
      obs://build.opensuse.org/KDE -> openSUSE
    kcm_gtk                      
      1.1-25.7 -> 1.1-13.2                       
      obs://build.opensuse.org/KDE -> openSUSE
    kio_iso                      
      2.0.0-51.17 -> 2.0.0-15.3                  
      obs://build.opensuse.org/KDE -> openSUSE
    kiosktool                    
      1.99.svn1122153-19.6 -> 1.99.svn1122153-4.1
      obs://build.opensuse.org/KDE -> openSUSE
    kipi-plugins                 
      1.9.0-121.6 -> 1.8.0-5.2                   
      obs://build.opensuse.org/KDE -> openSUSE
    kipi-plugins-acquireimage    
      1.9.0-121.6 -> 1.8.0-5.2                   
      obs://build.opensuse.org/KDE -> openSUSE
    kipi-plugins-lang            
      1.9.0-121.6 -> 1.8.0-5.2                   
      obs://build.opensuse.org/KDE -> openSUSE
    konversation                 
      1.3.1-42.9 -> 1.3.1-7.10.1                 
      obs://build.opensuse.org/KDE -> openSUSE
    konversation-lang            
      1.3.1-42.9 -> 1.3.1-7.10.1                 
      obs://build.opensuse.org/KDE -> openSUSE
    krusader                     
      2.0.0-51.17 -> 2.0.0-15.3                  
      obs://build.opensuse.org/KDE -> openSUSE
    krusader-doc                 
      2.0.0-51.17 -> 2.0.0-15.3                  
      obs://build.opensuse.org/KDE -> openSUSE
    ksshaskpass                  
      0.5.3-11.6 -> 0.5.3-2.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    ktorrent                     
      4.1.0-98.6 -> 4.1.0-1.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    ktorrent-lang                
      4.1.0-98.6 -> 4.1.0-1.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    kvkbd                        
      0.6-19.6 -> 0.6-9.1                        
      obs://build.opensuse.org/KDE -> openSUSE
    kwebkitpart                  
      1.1.0-16.7 -> 1.1.0-3.2                    
      obs://build.opensuse.org/KDE -> openSUSE
    kwebkitpart-lang             
      1.1.0-16.7 -> 1.1.0-3.2                    
      obs://build.opensuse.org/KDE -> openSUSE
    lensfun                      
      0.2.5-28.2 -> 0.2.5-7.3                    
      obs://build.opensuse.org/KDE -> openSUSE
    libakonadiprotocolinternals1 
      1.5.2-89.1 -> 1.5.0-3.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    libarchive2                  
      2.8.4-3.1 -> 2.8.4-8.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    libassuan0                   
      2.0.0-5.1 -> 2.0.1-4.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    libattica0                   
      0.2.0-27.2 -> 0.2.0-5.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    libggz2                      
      0.0.14.1-54.1 -> 0.0.14.1-49.1             
      obs://build.opensuse.org/KDE -> openSUSE
    libgpgme11                   
      1.3.0-4.1 -> 1.3.0-12.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    libiodbc3                    
      3.52.7-14.1 -> 3.52.6-9.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    libktorrent3                 
      1.1.0-15.2 -> 1.1.0-1.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    libktorrent3-lang            
      1.1.0-15.2 -> 1.1.0-1.3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    liblastfm0                   
      0.3.0-13.12 -> 0.3.0-7.2                   
      obs://build.opensuse.org/KDE -> openSUSE
    liblensfun0                  
      0.2.5-28.2 -> 0.2.5-7.3                    
      obs://build.opensuse.org/KDE -> openSUSE
    liblqr-1-0                   
      0.4.1-12.1 -> 0.4.1-6.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    libmsn0_3                    
      4.1-24.1 -> 4.1-5.1                        
      obs://build.opensuse.org/KDE -> openSUSE
    libphonon4                   
      4.4.4-2.1 -> 4.4.4-3.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    libpolkit-qt-1-1             
      0.99.1-32.1 -> 0.99.1-5.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    libqalculate5                
      0.9.7-9.1 -> 0.9.7-2.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    libqimageblitz4              
      0.0.4-207.2 -> 0.0.4-106.1                 
      obs://build.opensuse.org/KDE -> openSUSE
    libqoauth1                   
      1.0.1-15.1 -> 1.0.1-3.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    libsoprano4                  
      2.5.63-95.2 -> 2.5.63-5.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    libssh4                      
      0.4.8-20.1 -> 0.4.8-7.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    libstrigi0                   
      0.7.3.99-61.15 -> 0.7.3.99-9.2             
      obs://build.opensuse.org/KDE -> openSUSE
    phonon                       
      4.4.4-2.1 -> 4.4.4-3.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    phonon-backend-gstreamer-0_10
      4.4.4-2.1 -> 4.4.4-3.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    phonon-backend-xine          
      4.4.4-17.2 -> 4.4.4-3.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    plasmoid-quickaccess         
      0.8.1-20.4 -> 0.8.1-9.2                    
      obs://build.opensuse.org/KDE -> openSUSE
    polkit-kde-agent-1           
      0.99.0-13.3 -> 0.99.0-3.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    polkit-kde-kcmmodules-1      
      0.98.1-13.7 -> 0.98.1-3.2                  
      obs://build.opensuse.org/KDE -> openSUSE
    qalculate                    
      0.9.7-9.1 -> 0.9.7-2.1                     
      obs://build.opensuse.org/KDE -> openSUSE
    shared-desktop-ontologies    
      0.5-17.1 -> 0.5-2.1                        
      obs://build.opensuse.org/KDE -> openSUSE
    skanlite                     
      0.7.kde4.5.0-46.6 -> 0.7.kde4.5.0-3.1      
      obs://build.opensuse.org/KDE -> openSUSE
    soprano                      
      2.5.63-95.2 -> 2.5.63-5.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    soprano-backend-redland      
      2.5.63-95.2 -> 2.5.63-5.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    soprano-backend-virtuoso     
      2.5.63-98.3 -> 2.5.63-5.1                  
      obs://build.opensuse.org/KDE -> openSUSE
    speedcrunch                  
      0.10.1-102.2 -> 0.10.1-53.1                
      obs://build.opensuse.org/KDE -> openSUSE
    strigi                       
      0.7.3.99-61.15 -> 0.7.3.99-9.2             
      obs://build.opensuse.org/KDE -> openSUSE
    synaptiks                    
      0.4.0-21.6 -> 0.4.0-9.2                    
      obs://build.opensuse.org/KDE -> openSUSE
    virtuoso-drivers             
      6.1.2-20.1 -> 6.1.2-4.3                    
      obs://build.opensuse.org/KDE -> openSUSE
    virtuoso-server              
      6.1.2-20.1 -> 6.1.2-4.3                    
      obs://build.opensuse.org/KDE -> openSUSE
    yakuake                      
      2.9.8-19.6 -> 2.9.8-3.1                    
      obs://build.opensuse.org/KDE -> openSUSE
    
    
    9 packages to upgrade, 57 to downgrade, 65  to change vendor.
    Overall download size: 38.2 MiB. After the operation, 3.7 MiB will be freed.
    Continue? [y/n/?] (y):
    Most of them keeping the same upstream release, but I like to get those better from repo Kde46, which is kde-4.6.2, so I will keep kdeRelease repo.

    Also you can see above that akonadi-runtime would be downgraded with kdeRelease repo disabled!

  3. #3
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Gnome-3 extensions

    Gnome-3.0.1 rocks using extensions from Malcolm:

    http://download.opensuse.org/reposit...openSUSE_11.4/

    Now I have a symetrical dock on the other side where I can minimize and start applications with one click as used to. Before I told people they have to dance walz to easily use Gnome-3

  4. #4
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: Gnome-3 extensions

    Quote Originally Posted by ulenrich View Post
    Gnome-3.0.1 rocks using extensions from Malcolm:
    Malcolms repo disappeared. I hope these extensions will be included though into Gnome-3 repo ...

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: zypper dup - my solution - but unsure about some repos

    Quote Originally Posted by ulenrich
    ulenrich;2331788 Wrote:
    > Gnome-3.0.1 rocks using extensions from Malcolm:Malcolms repo
    > disappeared. I hope these extensions will be included

    though into Gnome-3 repo ...
    Hi
    They are in Factory and Gnome 3.0 so maybe they can be moved into
    Tumbleweed now?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.1-1.2-desktop
    up 5 days 17:00, 4 users, load average: 0.09, 0.04, 0.05
    GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06


  6. #6
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: zypper dup - my solution - but unsure about some repos

    Although they are "noarch" and therefore probably can pulled also by having the Gnome3-Release Repo with less significant higher number priority, for simplicity sake ! I can't live without your packets any more ...

    The more critical is the higher upstream version of akonadi-runtime for kde4.6.2 (see above description). Akonadi might be more heavy binary dependent !

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: zypper dup - my solution - but unsure about some repos

    @ulenrich: are you running both KDE4 from the Release repo and GNOME 3 ? No dependency errors?? Does the networkmanager work on KDE?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: zypper dup - my solution - but unsure about some repos

    I surely would never use Networkmanager :/

    I have removed kdm, but I am able to start Gnome3-session as also Kde4.6.2-session from gdm. Because I know, kdm didn't experience gnome3 when it grew up, I think gdm is better able to handle both desktops!

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: zypper dup - my solution - but unsure about some repos

    Quote Originally Posted by ulenrich View Post
    I surely would never use Networkmanager :/

    I have removed kdm, but I am able to start Gnome3-session as also Kde4.6.2-session from gdm. Because I know, kdm didn't experience gnome3 when it grew up, I think gdm is better able to handle both desktops!
    Maybe I should be more clear: I don't "experiment" on my main machine, the laptop is used for sandboxing. I'm running KDE as a main desktop, though I use LXDE and GNOME as well (depends on my mood). I tried to move to GNOME 3, messed around with a lot of deps, no networking, downgraded the packages to get back a fully functional KDE, which worked out fine. Since Networkmanager always gets installed by default, I was wondering how you handled the dep. conflicts in that area.
    I had no issues with kdm btw, the GNOME entry in the session listing was replaced by a GNOME 3 entry.

    Do you think that switching to the Tumbleweed repos might make a difference?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: zypper dup - my solution - but unsure about some repos

    Thank you for the info regarding kdm to be capable of starting up a Gnome3 session.

    Yes Tumbleweed has the faster 2.6.38 Linux kernel. That Linux Release was very smoth, because not much happened, but there were optimizations of "RCU" subsystem. Some memory functions (I don't know for sure) running considerable faster than Linux kernel 2.6.37.

    Krurpht, If you are a Gnome3 guy, you should wait, but kde4.6.2 runs without hassles on top of Tumbleweed. If you need proprietary graphics, fetch the beta nvidia 270.41.06 (ati I don't know), make it executable when in runlevel 1, and run the "N*.run" That is the "hard way". I don't know what is hard about? I forgott, you have to install some kernel-devel, etc before!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •