Results 1 to 5 of 5

Thread: Missing a library to run SeaMonkey

Hybrid View

  1. #1

    Default Missing a library to run SeaMonkey

    I've just updated my system from SuSE 11.2 to 11.4 (I'm using KDE desktop environment)

    I like to install SeaMonkey myself. I use the installer from the Mozilla site. When I try to run SeaMonkey, this is what happens:
    Code:
    ./seamonkey-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
    Where do I get the missing library? I've tried searching for it on the rpmpbone site RPM Search and even they couldn't find it.

  2. #2
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Missing a library to run SeaMonkey

    Quote Originally Posted by gymnart View Post
    I've just updated my system from SuSE 11.2 to 11.4 (I'm using KDE desktop environment)

    I like to install SeaMonkey myself. I use the installer from the Mozilla site. When I try to run SeaMonkey, this is what happens:
    Code:
    ./seamonkey-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
    Where do I get the missing library? I've tried searching for it on the rpmpbone site RPM Search and even they couldn't find it.
    Did you try in YaST?

    Search for dbus-1-glib, or dbus-1-glib-32 if you need the 32 bit version.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  3. #3

    Default Re: Missing a library to run SeaMonkey

    Problem solved. I'm now happily running SeaMonkey. ^_^
    YaST showed that I had the library but not the development one. So, I installed that one too and that did the job!

  4. #4
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Missing a library to run SeaMonkey

    Quote Originally Posted by gymnart View Post
    Problem solved. I'm now happily running SeaMonkey. ^_^
    YaST showed that I had the library but not the development one. So, I installed that one too and that did the job!
    Interesting. I don't have the development one installed and my SeaMonkey 2.1b3 installed from the tarball works fine.

    Maybe it is needed for openSUSE 11.4 or KDE.

    Glad it works for you. Happy surfing!
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  5. #5

    Default Re: Missing a library to run SeaMonkey

    I'm confused too. Maybe it was a KDE thing or a SuSE 11.4 thing. If you do upgrade to 11.4, be expecting this then. Maybe it won't happen with Gnome, who knows?
    I'm using SeaMonkey 2.0.13.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •