Results 1 to 8 of 8

Thread: How to disable CDROM-Device blocking?

  1. #1

    Default How to disable CDROM-Device blocking?

    If I insert a CD/DVD into my Device, the device is blocked, and I can't put the CD/DVD out without to do Eject in the Device Notifier.

    This is annoying. How to disable that??
    I want to disable that!!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to disable CDROM-Device blocking?

    If I insert a CD/DVD into my Device, the device is blocked, and I can't put the CD/DVD out without to do Eject in the Device Notifier.

    This is annoying. How to disable that??
    I want to disable that!!
    This behavior is normal and prevents ejecting a DVD while it is mounted into the file system. I don't feel it is all that much trouble to go to the Device Notifier and eject the media when you are done using it. I am not aware of any method to change this operation, but perhaps we will see some other suggestions here. It is frustrating at first, trying to eject a CD/DVD and thinking there is something wrong, but once you understand the motive and know the way to eject the media, it is really no big deal, in my opinion.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: How to disable CDROM-Device blocking?

    but this is annoying if i can't eject the disk, without unmount it before

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: How to disable CDROM-Device blocking?

    On 04/23/2011 08:06 PM, SoftHacker wrote:
    >
    > but this is annoying if i can't eject the disk, without unmount it
    > before


    did the box your openSUSE came in have "Not annoying, just free and
    easy." printed on it?

    if not, take it back and exchange it for the Free and Easy version...or
    get a refund and use to buy something more easy..

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8 via NNTP]
    A Penguin Being Tickled - http://www.youtube.com/watch?v=0GILA0rrR6w

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: How to disable CDROM-Device blocking?

    DenverD wrote:

    > did the box your openSUSE came in have "Not annoying, just free and
    > easy." printed on it?
    >




    But honestly I would say that the behaviour that the cd is not simply
    ejected when it is mounted is the less annoying feature compared to the
    behaviour that you can eject the cd by accident while it is in use.
    In this way the linux behaviour and its KDE equivalent is foolproof.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  6. #6

    Default Re: How to disable CDROM-Device blocking?

    I haven't had this problem other than when I used the cd drive in a particular way. You may have a similar problem.

    When I burn a cd or dvd I usually open the app 1st and put the disc in later. The auto mount stuff has kicked in even when k3b is running. Where this proved a problem was when I verified the disc after burning. It locked up k3b and the burner. K3b for some reason ejects then shuts before verifying. The shut fired up the auto mount and so on.

    If you are having the auto mount popping up when you aren't using it clicking do nothing may help.

    Having sympathy for the devs I can see that closing all of the what if's can take some time. Testing tends to be done in the way they expect the kit to be used.

    John

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to disable CDROM-Device blocking?

    On 2011-04-24 15:36, ajohnw wrote:
    > K3b for some reason ejects then shuts
    > before verifying.


    Yes, intentional. It is needed to make the kernel reread it, as a new
    burned media, not unburned.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8

    Default Re: How to disable CDROM-Device blocking?

    That's amazing. When the kernel was updated some time ago concerning cd/dvd bruning the man behind ks3b at the time had a lot of trouble using it. I'm surprised the kernel doesn't offer another method of doing that. On the other hand maybe the auto mount should check what is going on at the kde level. Maybe k3b would have to signal that it was doing that and currently doesn't. Closing these sorts of holes can be very time consuming.

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •