Results 1 to 10 of 10

Thread: printing all mixed up after the first page

  1. #1
    Petronov NNTP User

    Default printing all mixed up after the first page

    Hello guys,

    Both my printers can't print more that one page on the row whatever the application I use.

    I used to have a all-in-one printer HP PSC 1510 that I installed without any trouble.

    A few days ago, I've got another scanner-printer HP 1050 that I tried to install on the same laptop in order to use it in another place. I had to take the new version of HP-lip, since 11.3 did not provide the right driver. I just printed the test page and it seemed okay.

    Then, I upgraded from 11.3 to 11.4. And I had to print a long document. Only the first page was displayed correctly. All the following pages are more and more mixed up. It prints allways the same paragraph with big dark lines...

    Following to cup, the drivers in use are :
    Deskjet_1050_J410 : HP Deskjet 1050 j410 Series, hpcups 3.11.3a
    PSC-1500-series : HP PSC 1500 Series, hpcups 3.10.2rc1.9

    But the trouble is the same for both printers.

    I can't guess if it comes from HP-lip or from my upgrade.

    Could you help me getting out of this? Thank you.

  2. #2
    Petronov NNTP User

    Default Re : printing all mixed up after the first page

    Here are scans of my printings.

    The 5th page of a normal document gives this :



    Then, I made a text I only wrote in :
    "1rst line
    2nd line
    3rd line
    etc"
    Here is the second page:

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Re : printing all mixed up after the first page

    1. Did you set up your printers using hp-setup, or via the CUPS web interface?

    2. Did you try the hplip and hpijs drivers?

  4. #4
    Petronov NNTP User

    Default Re : Re: Re : printing all mixed up after the first page

    Thank you, deano, for your answer.

    1. I did not use the CUPS web interface. I went first into Yast and chose the "Printers" menu. It found a driver for 1050 when clicking and "search more drivers" but it did not work. That's why I downloaded a new version of hplip on their website and it worked. It seems it uninstalled the previous version by itself. My printers are referenced both in Hp-lip and in Yast. Maybe they shouldn't... I don't know.

    2. I believe that I'm using hp-lip drivers. HP-toolbox works only when PSC-1500 is connected.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Re : Re: Re : printing all mixed up after the first page

    I think I'd be inclined to delete the printer configs from yast (or via the CUPS web config interface) and start over.

    Open a console and become root with

    Code:
    su -
    then with one printer connected

    Code:
    hp-setup
    When finished, repeat with the other printer.

    If you need to tweak print options for either printer, then use the CUPS web interface:

    http://localhost:631/admin

    HP printer users: Please chime in here if there is a better approach or additional info...

  6. #6
    Petronov NNTP User

    Default Re : Re: Re : Re: Re : printing all mixed up after the first page

    Well,

    hp-setup find an error and replies this:

    Code:
    Bernard:~ # hp-setup
    Traceback (most recent call last):
      File "/usr/bin/hp-setup", line 45, in <module>
        from base import device, utils, tui, models, module
      File "/usr/share/hplip/base/device.py", line 39, in <module>
        import status
      File "/usr/share/hplip/base/status.py", line 45, in <module>
        import hpmudext
    ImportError: /usr/lib64/python2.7/site-packages/hpmudext.so: undefined symbol: hpmud_make_par_uri
    Do you know what I should do to fix this? Thank you.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Re : Re: Re : Re: Re : printing all mixed up after the first page

    Run 'hp-check' and make sure that Python and PyQt versions check out ok, as well as potential dependency errors....

  8. #8
    Petronov NNTP User

    Default Re : printing all mixed up after the first page

    hp-check found some errors, that I do not know how to fix:

    Code:
    | INSTALLED CUPS PRINTER QUEUES |
    ---------------------------------
    
     
    lpstat
    ------
    Type: Unknown
    Device URI: No destinations added.
    
    
    ---------------------
    | PYTHON EXTENSIONS |
    ---------------------
    
    Checking 'cupsext' CUPS extension...
    OK, found.
    
    Checking 'pcardext' Photocard extension...
    OK, found.
    
    Checking 'hpmudext' I/O extension...
    Erreur de segmentation
    "Erreur de segmentation" is "segmentation fault".

    How could I correct hpmudext?

  9. #9
    Petronov NNTP User

    Default Re : printing all mixed up after the first page

    HP-lip errors seem to be fixed now.

    I'm trying to reinstall my printers now. I hope it will work.

  10. #10
    Petronov NNTP User

    Default Re : printing all mixed up after the first page

    The HP 1050 is reinstalled with success. I'll try to add the 1510 tonight. I hope, it will work.

    Thanks a lot for your help, deano-ferrari.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •