Results 1 to 10 of 10

Thread: XFCE documentation

  1. #1
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default XFCE documentation

    When I click on "HELP" in some of the XFCE settings applets, I get an error.

    It looks as if the software is looking for the help under "/usr/share/doc/xfce-utils/" whereas the documentation is really stored under "/usr/share/doc/packages/xfce-utils/".

    I can add a symlink as a workaround. But before I do that, I thought I should ask whether there is a configuration file somewhere that allows setting the documentation path.

    Thanks.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,114

    Default Re: XFCE documentation

    Looks like a bug IMHO. Somewhere this setting (to use the /packages in the path) is taken (by the openSUSE distributors?) but it is not adhered to by all XFCE applications.

    You could start filing a bug at openSUSE:Submitting bug reports - openSUSE. But when my idea about some XFCE apps do and some don't is correct, going to the XFCE site might also b usefull.
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: XFCE documentation

    Thanks for the suggestion.

    It turns out that this has already been reported as bug 688095. It is listed as fixed upstream.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,114

    Default Re: XFCE documentation

    You are welcome. Again something that will be solved in the near future
    Henk van Velden

  5. #5

    Default Re: XFCE documentation

    Set the variable HELP_DIR in /usr/bin/xfhelp4 to /usr/share/doc/packages instead of /usr/share/doc.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: XFCE documentation

    Thanks. Much appreciated.

    So, to test the change, I went into XFCE settings manager, clicked on "Calendar" and then clicked "Help".

    I got: "Firefox can't find the file at /usr/share/orage/doc/C/orage.html#orage-preferences-window"

    LOL.

    However, your suggested change does fix most of the help in XFCE.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: XFCE documentation

    Quote Originally Posted by nrickert View Post
    So, to test the change, I went into XFCE settings manager, clicked on "Calendar" and then clicked "Help".

    I got: "Firefox can't find the file at /usr/share/orage/doc/C/orage.html#orage-preferences-window"
    Did that work before you changed the path?

    * Just checked. It works fine for me. But it opens the file /usr/share/orage/doc/C/orage.html in the browser. If I add '#orage-preferences-window' manually, it loads that page.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: XFCE documentation

    Quote Originally Posted by please_try_again View Post
    Did that work before you changed the path?
    I didn't try it before, and I doubt that it worked.

    It might be something funky in firefox causing that problem. As far as I know, the "#orage-preferences-window" is supposed to identify a location within the file, rather than be part of the file name.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: XFCE documentation

    Quote Originally Posted by nrickert View Post
    I didn't try it before, and I doubt that it worked.

    It might be something funky in firefox causing that problem. As far as I know, the "#orage-preferences-window" is supposed to identify a location within the file, rather than be part of the file name.
    Yes that's what it is too. The command behind the help button in calendar preferences is replacing "#" by its ASCII value (0x23) and send that to the default browser. I don't believe it should encode the URL like this. As a consequence the browser looks for this URL "/usr/share/orage/doc/C/orage.html%23orage-preferences-window" and doesn't find it, but it does succesfully jump to the anchor. It's not a firefox problem.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: XFCE documentation

    Yes, I agree that the "%23" looks wrong. My understanding is that the percent encoding overrides the special meaning of "#" and treats it instead as an ordinary character.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •