Results 1 to 7 of 7

Thread: OMG, Please someone help me with smb.

  1. #1

    Default OMG, Please someone help me with smb.

    All I want to do is share a single Dir, from my linux box to the workgroup.
    thats it,

    I have extencive experience with linux and windows,

    wich only makes me feel more like an idiot, for not being able to do this.

    I have gone threw tut after tut.

    I have gotten it to a point where my linux box can see the workgroup.

    But can't get any further...

    Someone please help.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,734

    Default Re: OMG, Please someone help me with smb.

    When you have extencive experience with linux and windows (or with any other computer software), I guess you are now waiting for anybody to ask:
    . which openSUSE level?
    . what did you configure so far (showing the relevant configuration files)?
    Thus, my question is, why didn't youy tell that in your first post?
    Henk van Velden

  3. #3
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: OMG, Please someone help me with smb.

    On Thu April 21 2011 03:36 am, ghostcyber wrote:

    >
    > All I want to do is share a single Dir, from my linux box to the
    > workgroup.
    > thats it,
    >
    > I have extencive experience with linux and windows,
    >
    > wich only makes me feel more like an idiot, for not being able to do
    > this.
    >
    > I have gone threw tut after tut.
    >
    > I have gotten it to a point where my linux box can see the workgroup.
    >
    > But can't get any further...
    >
    > Someone please help.
    >
    >

    ghostcyber;

    Have a look at this HowTo:
    http://opensuse.swerdna.org/suselanprimer.html
    and also
    http://opensuse.swerdna.org/susesambaserver.html

    Keep the following ideas in mind:

    1. Make sure nmb and smb are set to start at boot.
    2. These three services must be allowed through the firewall: Samba Server,
    Netbios Server and Samba Client.
    3. Create Samba users with:
    Code:
    smbpasswd -a <username>

    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  4. #4

    Default Re: OMG, Please someone help me with smb.

    So, it is a base install .. I guess I am not that high of level with opensuse, since I can't even get smb running..

    NMB is not running, and returns that as an error when I try to enable it.

    I will try to look on how to enable that now..

    thank you both for your responces..

  5. #5

    Default Re: OMG, Please someone help me with smb.

    hurray, that worked, all i need was that service running, and then i messed with the settings a little, everything works perfect now, thanks guys.

  6. #6
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: OMG, Please someone help me with smb.

    On Mon May 2 2011 12:06 am, ghostcyber wrote:

    >
    > So, it is a base install .. I guess I am not that high of level with
    > opensuse, since I can't even get smb running..
    >
    > NMB is not running, and returns that as an error when I try to enable
    > it.
    >
    > I will try to look on how to enable that now..
    >
    > thank you both for your responces..
    >
    >

    ghostcyber;

    There is a bug in AppArmor on OpenSuse 1.4 that prevents smb and nmb from
    running. Go to YaST>Novell AppArmor>AppArmor Control Panel>Configure Profile
    Modes. Set usr.sbin.smbd and usr.sbin.nmbd to Complain and not Enforce. Now
    try to start both smb and nmb.

    Code:
    su -
    rcsmb start
    rcnmb start
    exit
    Go to YaST>System>System Services (Runlevel) and enable both smb and nmb to
    run at boot.


    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  7. #7
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: OMG, Please someone help me with smb.

    On Mon May 2 2011 12:46 am, PV wrote:

    > On Mon May 2 2011 12:06 am, ghostcyber wrote:
    >


    >>

    > ghostcyber;
    >
    > OpenSuse 1.4
    >
    >

    That should read: OpenSuse 11.4
    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •