Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Amarok will not start.

  1. #1
    Join Date
    Jul 2008
    Location
    UK
    Posts
    13

    Default Amarok will not start.

    Well Amarok used to work OK but, suddenly I just could not get it to run. The coloured startup came up but nothing else. So I ran it as su from a terminal and this was the result:

    <unknown program name>(6552)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

    <unknown program name>(6551)/: KUniqueApplication: Pipe closed unexpectedly.


    I just do not understand it. Any help would be appreciated.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Amarok will not start.

    Quote Originally Posted by divali View Post
    Well Amarok used to work OK but, suddenly I just could not get it to run. The coloured startup came up but nothing else. So I ran it as su from a terminal and this was the result:

    <unknown program name>(6552)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

    <unknown program name>(6551)/: KUniqueApplication: Pipe closed unexpectedly.


    I just do not understand it. Any help would be appreciated.
    First try to re-install Amarok through here software.opensuse.org: Search Results

    And i want to see your repos
    Code:
    su
    Code:
    # zypper lr -d
    post the output here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Amarok will not start.

    This is weird, because KuniqueApplication, if I am correct, ensure that there is only one instance of an application open. So, maybe there is an instance of Amarok running in the background that has not been killed. I am not sure if I am correct in my assumption though...

    I suggest you close your session and get back in to see if the problem persists.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Amarok will not start.

    Quote Originally Posted by divali View Post

    <unknown program name>(6552)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

    <unknown program name>(6551)/: KUniqueApplication: Pipe closed unexpectedly.


    I just do not understand it. Any help would be appreciated.
    Please, when you copy/paste computer in/outp[ut here, do so between CODE tags to keep it readable (Posting in Code Tags - A Guide).
    Henk van Velden

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re : Amarok will not start.

    Quote Originally Posted by DaaX View Post
    This is weird, because KuniqueApplication, if I am correct, ensure that there is only one instance of an application open. So, maybe there is an instance of Amarok running in the background that has not been killed. I am not sure if I am correct in my assumption though...

    I suggest you close your session and get back in to see if the problem persists.
    Of course you are correct, I am thinking that maybe firstly he must go to his system monitor to kill the process if runs in background. Although runs background and now tries to run it again graphically, the application must run.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Jul 2008
    Location
    UK
    Posts
    13

    Default Re: Απ: Re : Amarok will not start.

    Ok, here's the result. By the way I have already killed all instances of the Amarok but, still won't load.
    localhost:/home/divali # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+----------------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.2/ |
    2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/11.2/ |
    3 | Pacman | Pacman | Yes | Yes | 99 | rpm-md | Index of /suse/11.2 |
    4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    8 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Amarok will not start.

    On Thu, 21 Apr 2011 01:06:02 +0530, divali
    <divali@no-mx.forums.opensuse.org> wrote:

    >
    > Well Amarok used to work OK but, suddenly I just could not get it to
    > run. The coloured startup came up but nothing else. So I ran it as su
    > from a terminal and this was the result:



    my amarok runs fine, but when i run amarok as "su", i get the same error.
    if you really do want to run amarok as root, you have to do "su -", not
    "su". but i wouldn't recommend that either.


    > -<unknown program name>(6552)/: KUniqueApplication: Cannot find the
    > D-Bus session server: "Did not receive a reply. Possible causes
    > include: the remote application did not send a reply, the message bus
    > security policy blocked the reply, the reply timeout expired, or the
    > network connection was broken."
    >
    > <unknown program name>(6551)/: KUniqueApplication: Pipe closed
    > unexpectedly.
    > -
    >
    > I just do not understand it. Any help would be appreciated.
    >
    >



    --
    phani.

  8. #8
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Re : Amarok will not start.

    I do not know if there is support for 11.2. Anyway try to re-install amarok. software.opensuse.org: Search Results

    And try to remove one of these two repos
    Code:
    2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/11.2/ |
    3 | Pacman | Pacman | Yes | Yes | 99 | rpm-md | Index of /suse/11.2 |
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  9. #9
    Join Date
    Jul 2008
    Location
    UK
    Posts
    13

    Default Re: Απ: Re: Απ: Re : Amarok will not start.

    That must be about the fourth time I have re-installed Amorak and still no luck. By the way guys thanks for such a quick response. Amazing.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Απ: Re: Απ: Re : Amarok will not start.

    PLEASE use CODE tags, not QUOTE tags for computer text.

    And there seems to be a suggestion of someone running Amarok as root. That is one of the more stupid things to do. I hope it was only a suggestion, or a misunderstanding and not done in real.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •