Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: NVIDIA driver slows X and KDE start

  1. #1
    Alberto García Baladía NNTP User

    Default NVIDIA driver slows X and KDE start

    Hello. I have recently installed openSUSE 11.4 x86_64 on my laptop, with
    NVIDIA driver (260.19.44,Geforce 9300M GS).Performance is good, but it slows
    the boot process: The NVidia logo appears and stays on the screen for 10
    seconds aproximately.KDE start is very slow also. I have tried to fix it by
    adding nomodeset to menu.lst and settting sysconfig variable
    NO_KMS_IN_INITRD to yes,with no success.
    Thank you in advance.
    --
    Alberto García Baladía

  2. #2

    Default Re: NVIDIA driver slows X and KDE start

    In the "Devices" section of either your xorg.conf or the file in xorg.conf.d that contains the "Devices" section add the line
    Code:
    "Option"      "NoLogo"   "true"
    That will prevent the logo from showing, but I'm not sure if it will improve performance. I believe it is worth a shot though.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  3. #3
    Alberto García Baladía NNTP User

    Default Re: NVIDIA driver slows X and KDE start

    Thank you for the suggestion, but the problem is still here.With the NoLogo
    option I have 10 seconds of blank screen, an KDE is still starting very
    slow...

    --
    Alberto García Baladía

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: NVIDIA driver slows X and KDE start

    Once started does it run OK? How much memory on the lappy?

  5. #5
    Alberto García Baladía NNTP User

    Default Re: NVIDIA driver slows X and KDE start

    Once started it runs perfectly;system RAM is 4 GB and GPU's 256 MB.



    --
    Alberto García Baladía

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: NVIDIA driver slows X and KDE start

    Alberto Garca Balada wrote:

    > Once started it runs perfectly;system RAM is 4 GB and GPU's 256 MB.
    >

    Can you check if /var/log/Xorg.0.log contains some errors (of course it can
    be anything else and not only the xserver, but let's look at that first).

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7
    Alberto García Baladía NNTP User

    Default Re: NVIDIA driver slows X and KDE start

    Only one error:

    26.084] (EE) Logitech USB Receiver: failed to initialize for relative
    axes.
    [ 26.084] (II) Logitech USB Receiver: initialized for absolute axes.

    But the mouse is OK.

    --
    Alberto García Baladía

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: NVIDIA driver slows X and KDE start

    Alberto Garca Balada wrote:

    > Only one error:
    >
    > 26.084] (EE) Logitech USB Receiver: failed to initialize for relative
    > axes.
    > [ 26.084] (II) Logitech USB Receiver: initialized for absolute axes.
    >
    > But the mouse is OK.
    >

    Sorry for the late follow up. No this is not really related it just tells
    you that it checked your Logitech device and the first setting it ries fails
    and so it uses the second one which works.

    Before we trvael through all the log files. I should have asked that
    earlier: What happens if you simply boot from grub into the failsafe mode,
    is that also slow or is that faster?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: NVIDIA driver slows X and KDE start

    I'd be surprised if loading the video driver is the actual culprit.
    If you've installed the latest nVidia package, it also includes the nVidia Configuration Tool which IMO is more likely to require resources and can of course only be loaded when the display driver is already fully loaded.

    Take a look at it, in KDE (prob similar in Gnome)
    KDE App button > system > configuration > Configure nVidia X Server Settings

    (You should also see an optional Dock applet which places an icon in the Tray)

    From within this application, you'll see that it touches <many> subsystems gathering plenty of hardware information, it doesn't just edit the X Server config file.

    I suppose you could disable loading the app on bootup but I wouldn't... The benefit of the app far out-weighs the bootup penalty.

    IMO,
    Tony

  10. #10
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Re: NVIDIA driver slows X and KDE start

    Quote Originally Posted by Alberto García Baladía View Post
    Hello. I have recently installed openSUSE 11.4 x86_64 on my laptop, with
    NVIDIA driver (260.19.44,Geforce 9300M GS).Performance is good, but it slows
    the boot process: The NVidia logo appears and stays on the screen for 10
    seconds aproximately.KDE start is very slow also. I have tried to fix it by
    adding nomodeset to menu.lst and settting sysconfig variable
    NO_KMS_IN_INITRD to yes,with no success.
    Thank you in advance.
    --
    Alberto García Baladía
    Post the result of
    Code:
    cat /proc/cpuinfo
    cat /proc/meminfo
    openSUSE 11.3 + LXDE
    uname -r = 2.6.34.7-0.4-default

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •