Hi,

When I try to enter http://software.opensuse.org/ a screen is displayed:

Ruby on Rails application could not be started
These are the possible causes:

There may be a syntax error in the application's code. Please check for such errors and fix them.
A required library may not installed. Please install all libraries that this application requires.
The application may not be properly configured. Please check whether all configuration files are written correctly, fix any incorrect configurations, and restart this application.
A service that the application relies on (such as the database server or the Ferret search engine server) may not have been started. Please start that service.

Further information about the error may have been written to the application's log file. Please check it in order to analyse the problem.

Error message:
Permission denied - /srv/www/vhosts/opensuse.org/software/releases/20110412125434/log/production.log
Exception class:
Errno::EACCES
Application root:
/srv/www/vhosts/opensuse.org/software/current
Backtrace:
# File Line Location
0 /usr/lib64/ruby/1.8/logger.rb 518 in `initialize'
1 /usr/lib64/ruby/1.8/logger.rb 518 in `open'
2 /usr/lib64/ruby/1.8/logger.rb 518 in `open_logfile'
3 /usr/lib64/ruby/1.8/logger.rb 487 in `initialize'
4 /usr/lib64/ruby/1.8/logger.rb 263 in `new'
5 /usr/lib64/ruby/1.8/logger.rb 263 in `initialize'
6 /srv/www/vhosts/opensuse.org/software/releases/20110412125434/config/environment.rb 51 in `new'
7 /srv/www/vhosts/opensuse.org/software/releases/20110412125434/config/environment.rb 51
8 /usr/lib64/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb 111 in `run'
9 /srv/www/vhosts/opensuse.org/software/releases/20110412125434/config/environment.rb 16
10 /usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb 29 in `gem_original_require'
11 /usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb 29 in `require'
12 /usr/lib64/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb 156 in `require'
13 /usr/lib64/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb 521 in `new_constants_in'
14 /usr/lib64/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb 156 in `require'
15 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/application_spawner.rb 222 in `preload_application'
16 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/application_spawner.rb 181 in `initialize_server'
17 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/utils.rb 572 in `report_app_init_status'
18 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/application_spawner.rb 174 in `initialize_server'
19 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 204 in `start_synchronously'
20 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 180 in `start'
21 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/application_spawner.rb 149 in `start'
22 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/framework_spawner.rb 268 in `handle_spawn_application'
23 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 132 in `lookup_or_add'
24 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/framework_spawner.rb 263 in `handle_spawn_application'
25 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 82 in `synchronize'
26 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 79 in `synchronize'
27 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/framework_spawner.rb 261 in `handle_spawn_application'
28 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 357 in `__send__'
29 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 357 in `server_main_loop'
30 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 206 in `start_synchronously'
31 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 180 in `start'
32 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/classic_rails/framework_spawner.rb 93 in `start'
33 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/spawn_manager.rb 219 in `spawn_rails_application'
34 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 132 in `lookup_or_add'
35 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/spawn_manager.rb 214 in `spawn_rails_application'
36 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 82 in `synchronize'
37 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server_collection.rb 79 in `synchronize'
38 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/spawn_manager.rb 213 in `spawn_rails_application'
39 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/spawn_manager.rb 132 in `spawn_application'
40 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/spawn_manager.rb 275 in `handle_spawn_application'
41 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 357 in `__send__'
42 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 357 in `server_main_loop'
43 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/lib/phusion_passenger/abstract_server.rb 206 in `start_synchronously'
44 /usr/lib64/ruby/gems/1.8/gems/passenger-3.0.5/helper-scripts/passenger-spawn-server 99


Any idea what this is about ? Would it be a virus ?

thanks for any feedback,

Agunet74