Results 1 to 10 of 10

Thread: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

  1. #1

    Default Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    Hi
    Whenever I type anything on the keyboard, the touchpad is disabled. Is there a fix?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    There's probably a setting for that.

    In KDE, it is Configure Desktop (personal settings) --> Input Devices --> Touchpad

    That's for 11.4 with KDE 4.6. I think the names have changed since 11.3. I recall seeing a similar setting in gnome, but I don't remember the details.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    I tried that but couldn't find the option I was looking for. I don't think its my touchpad as it worked fine in mandriva.

  4. #4

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    It must have something to do with the synaptiks daemon as when I stopped it running at startup it fixed my problem

  5. #5

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    I went back into the settings and found the right option. Can't believe I missed it.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    I'm glad you found it.

    Some folk (I'm one of them) find it very distracting when we accidentally touch the touchpad while typing, and the cursor wanders all over the place. So we find that a useful option.

    I use "mouse follows cursor" and if the cursor moves too far, the window I thought I was typing into will lose focus.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    I can see why its useful. If the default time wasn't as long I might have kept it, but I though it would be easier to switch it off that adjust the time to suit me.

  8. #8
    Join Date
    Jan 2011
    Location
    Riverside, Ca.
    Posts
    220

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

    Quote Originally Posted by RabbidRabbit View Post
    Hi
    Whenever I type anything on the keyboard, the touchpad is disabled. Is there a fix?
    Wish I had your problem.

  9. #9

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboardis pressed.

    You can just do the opposite of what was mentioned above in the
    synaptiks config ...

  10. #10
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Touchpad is disabled for a few secnds when a button on the keyboardis pressed.

    Hello, the daemon is calle syndaemon and it has several options, but couldnt find it practical since you cant set it less than (I think) 1 second of pause.

    I found that its better (for me) to reconfigure the touchpad area, i.e. I have a DV7 notebook and the touchpad is reaaaaaaly big, so when typing I accidentally tap it lossing focus.

    This is the config file to shrink the touchpad area (for my touchpad, others may be slight different...)

    Code:
    sebadamus@itsalive:/etc/X11/xorg.conf.d> cat 50-synaptics.conf
    Section "InputClass"
            Identifier "touchpad catchall"
            Driver "synaptics"
            MatchIsTouchpad "on"
            MatchDevicePath "/dev/input/event*"
            Option  "HorizScrollDelta"      "0"
            Option  "AreaLeftEdge"          "1600"
            Option  "AreaRightEdge"         "5400" 
            Option  "AreaTopEdge"           "1600"
            Option  "AreaBottomEdge"        "0"
            Option  "FingerLow"             "20"
            Option  "FingerHigh"            "40"
    EndSection
    Lap #1: openSUSE 11.4 Kernel 2.6.37.6-0.7-desktop | 64bits | i7-720QM 1.60GHz | KDE 4.6 (ex Gnome 2.32.1 user) | ATI HD 5650 1GB | HP Pavilion dv7-4190us | 6GB RAM

Similar Threads

  1. sax and X11 disabled keyboard and mouse
    By WillyFoobar in forum Install/Boot/Login
    Replies: 4
    Last Post: 08-Mar-2010, 14:32
  2. touchpad disabled on boot and resume after suspend
    By tsuki_kodomo in forum Install/Boot/Login
    Replies: 0
    Last Post: 14-Apr-2009, 23:26
  3. Touchpad disabled on T61p (opensuse 11)
    By chancekang in forum Hardware
    Replies: 3
    Last Post: 16-Aug-2008, 07:35
  4. Mouse Touchpad disabled on boot
    By fuzzymonkey10 in forum Hardware
    Replies: 0
    Last Post: 21-Jul-2008, 16:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •