Results 1 to 2 of 2

Thread: openSuse 11.4 64bit and Skype 2.2.0.25: Cannot mix incompatible Qt library

  1. #1

    Default openSuse 11.4 64bit and Skype 2.2.0.25: Cannot mix incompatible Qt library

    On Opensuse 11.4 64bit, on a Dell E6410 notebook.

    Installed the 32bit dependencies from SDB: Skype (SDB:Skype - openSUSE )

    i.e. su -c 'zypper install libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-x11-32bit libpng12-0-32bit'

    Then installed the latest version (2.2.0.25 from Skype website for openSuse 11+

    And when launching skype in a terminal window I get
    "Fatal: Cannot mix incompatible Qt library (version 0x40702) with this library (version 0x40701) Aborted"

    And this corresponds tot requireing an older QT library for Skype than is the current version from openSuse 11.4

    How do I fix this?? I've already pursued all other solutions I could find.

    thanks

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: openSuse 11.4 64bit and Skype 2.2.0.25: Cannot mix incompatibleQt library

    On Sun, 17 Apr 2011 21:36:01 +0530, frenchrh
    <frenchrh@no-mx.forums.opensuse.org> wrote:

    >
    > On Opensuse 11.4 64bit, on a Dell E6410 notebook.
    >
    > Installed the 32bit dependencies from SDB: Skype ('SDB:Skype -
    > openSUSE' (http://en.opensuse.org/SDB:Skype) )
    >
    > i.e. su -c 'zypper install libasound2-32bit xorg-x11-libXv-32bit
    > xorg-x11-libs-32bit libqt4-x11-32bit libpng12-0-32bit'
    >
    > Then installed the latest version (2.2.0.25 from Skype website for
    > openSuse 11+
    >
    > And when launching skype in a terminal window I get
    > "Fatal: Cannot mix incompatible Qt library (version 0x40702) with this
    > library (version 0x40701) Aborted"
    >
    > And this corresponds tot requireing an older QT library for Skype than
    > is the current version from openSuse 11.4
    >
    > How do I fix this?? I've already pursued all other solutions I could
    > find.
    >


    i'm using 11.4 with KDE 4.6.2 (from
    http://download.opensuse.org/reposit...stro:/Factory/) and got
    qt4 ver. 1.7.2 from that repo. OSS comes with 1.7.1.

    but there isn't much difference between this latest version of skype and
    the previous one -- in my experience. perhaps with faster broadband (most
    are) and better video equipment (ditto) there would be better video &
    audio, as skype claims. haven't heard or read anything about that.

    i'm pretty sure the previous version of skype did not demand that qt4
    version.


    --
    phani.

Similar Threads

  1. Running Skype on 64bit openSUSE
    By dch53 in forum Applications
    Replies: 7
    Last Post: 02-Jul-2011, 12:25

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •