Results 1 to 3 of 3

Thread: Can't compile ndiswrapper

  1. #1
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    37

    Angry Can't compile ndiswrapper

    I use a Netgear WNA3100 Network Adapter that needs a patched version of ndiswrapper to work. So far I successfully compiled ndiswrapper in both Ubuntu and Fedora, but it wont work on openSUSE 11.4. I installed all necessary software I need, at least I think so. I have installed the following before trying to build ndiswrapper

    Code:
    make gcc kernel-syms kernel-dev kernel-source ndiswrapper-kmp-desktop
    Also tried installing linux-headers-`uname -r` as I did in Fedora, but in openSUSE it was not necessary.

    Here is the errors I get. Google could not help me this time so hopefully someone at this forum can.

    Code:
    wahlgren@linux-ubyv:~/Downloads/ndiswrapper-1.56> make
    make -C driver
    make[1]: Entering directory `/home/wahlgren/Downloads/ndiswrapper-1.56/driver'
    make -C /usr/src/linux-2.6.37.1-1.2-obj/i386/desktop M=/home/wahlgren/Downloads/ndiswrapper-1.56/driver
    make[2]: Entering directory `/usr/src/linux-2.6.37.1-1.2-obj/i386/desktop'
    make -C ../../../linux-2.6.37.1-1.2 O=/usr/src/linux-2.6.37.1-1.2-obj/i386/desktop/. 
      CC [M]  /home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.o
    /home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.c:834:2: error: unknown field ‘ioctl’ specified in initializer
    /home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.c:834:2: warning: initialization from incompatible pointer type
    make[5]: *** [/home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.o] Error 1
    make[4]: *** [_module_/home/wahlgren/Downloads/ndiswrapper-1.56/driver] Error 2
    make[3]: *** [sub-make] Error 2
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/usr/src/linux-2.6.37.1-1.2-obj/i386/desktop'
    make[1]: *** [modules] Error 2
    make[1]: Leaving directory `/home/wahlgren/Downloads/ndiswrapper-1.56/driver'
    make: *** [all] Error 2

  2. #2
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    37

    Default Re: Can't compile ndiswrapper

    Found out it had to do with patches, but those patches I needed didn't work with openSUSE. So guess I have to get another wireless adapter/card or go for another distro.

  3. #3
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    37

    Default Re: Can't compile ndiswrapper


Similar Threads

  1. Cannot Compile!
    By ThePerfectPunk in forum Install/Boot/Login
    Replies: 4
    Last Post: 13-Mar-2010, 09:51
  2. ndiswrapper 1.55 won't compile
    By D1234LHOMME in forum Wireless
    Replies: 11
    Last Post: 25-Jan-2010, 12:31
  3. can't compile
    By rkonrad in forum Programming/Scripting
    Replies: 2
    Last Post: 16-Jan-2009, 08:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •