Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Missing integration between Firefox 4 and php5

  1. #1

    Default Missing integration between Firefox 4 and php5

    I've got apache2, ver 2.2 running on openSuse 11.4 and just installed php5. My php web pages are still only displaying the text files and are not parsing or executing as expected. I've rebooted to clear any hidden gotchas. Help please...

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Missing integration between Firefox 4 and php5

    It's nothing to do with Firefox or any web browser. There's no such thing as browser/server integration.

    What you probably forgot to do is enable php5 in the list of Apache modules after installing. Then restart the server.

  3. #3
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Missing integration between Firefox 4 and php5

    On Sun, 17 Apr 2011 09:36:02 +0530, ken yap
    <ken_yap@no-mx.forums.opensuse.org> wrote:

    >
    > It's nothing to do with Firefox or any web browser. There's no such
    > thing as browser/server integration.
    >
    > What you probably forgot to do is enable php5 in the list of Apache
    > modules after installing. Then restart the server.
    >


    ....wich you do in the file /etc/sysconfig/apache2. the module "php5" has
    be be mentioned in the line that starts with "APACHE_MODULES="


    --
    phani.

  4. #4

    Default Re: Missing integration between Firefox 4 and php5

    Thank you Phani, but I've added the line "APACHE_MODULES=php5" and restarted the httpd daemons with no change in results. Firefox still displays the text of the .php pages.

  5. #5
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Missing integration between Firefox 4 and php5

    On Mon, 18 Apr 2011 01:06:03 +0530, j2carte
    <j2carte@no-mx.forums.opensuse.org> wrote:

    >
    > Thank you Phani, but I've added the line "APACHE_MODULES=php5" and
    > restarted the httpd daemons with no change in results. Firefox still
    > displays the text of the .php pages.
    >


    you shouldn't have to add that line; there's already a line starting with
    "APACHE_MODULES=", containing all enabled modules. if you add your line
    before that, the later line will take precedence; if you add it
    afterwards, the other modules won't work.

    i remember there's several of these lines, all but one commented out. you
    have to find the one w/o "#" in the beginning; that's the one to which you
    have to add "php5", if it isn't already included in the string (between
    the quotation marks). if it is already there, your problem lies somewhere
    else.


    --
    phani.

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Missing integration between Firefox 4 and php5

    And in case it isn't that, another couple of reasons are: filename must end in .php, and the file contents must be of the form: <?php php code here ?>

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Missing integration between Firefox 4 and php5

    On Mon, 18 Apr 2011 03:36:03 +0530, ken yap
    <ken_yap@no-mx.forums.opensuse.org> wrote:

    >
    > And in case it isn't that, another couple of reasons are: filename must
    > end in .php, and the file contents must be of the form: <?php php code
    > here ?>
    >


    another possibility: do you have apache2_mod_php5 installed? that's
    required.


    --
    phani.

  8. #8
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Missing integration between Firefox 4 and php5

    On Mon, 18 Apr 2011 03:51:53 +0530, phanisvara <listmail@phanisvara.com>
    wrote:

    >
    > another possibility: do you have apache2_mod_php5 installed? that's
    > required.
    >


    sorry, it's "apache2-mod_php5", not "apache2_mod~~~".


    --
    phani.

  9. #9

    Default Re: Missing integration between Firefox 4 and php5

    I have made sure the apache2-mod_pho5 has been installed and I just finished running another make and make install to verify it was included in the code. I restarted the httpd daemon but the .php pages still all display as text. I'll be happy to upload any config file or output you might like to see.

  10. #10

    Default Re: Missing integration between Firefox 4 and php5

    Here's the appropriate section from my /etc/sysconfig/apache2 file:

    ## Type: string
    ## Default: "actions alias auth_basic authz_host authn_file authz_groupfile authz_default authz_user autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir php5"
    ## ServiceRestart: apache2
    APACHE_MODULES=""

    ...so php5 is included as the default. This is the only APACHE_MODULES line in the file so it is not being superseded.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 14-Mar-2011, 13:27
  2. Replies: 3
    Last Post: 03-Apr-2010, 13:24
  3. Lost Firefox KDE Integration
    By david_b_0 in forum Applications
    Replies: 2
    Last Post: 27-Jan-2010, 02:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •