Results 1 to 4 of 4

Thread: Opensuse 11.4 fresh install: ata2: SRST failed (errno=-16) on brand new hard drive

  1. #1
    Join Date
    Oct 2008
    Posts
    27

    Question Opensuse 11.4 fresh install: ata2: SRST failed (errno=-16) on brand new hard drive

    Hi,

    I have a problem with a fresh install of Opensuse 11.4.
    I have two hard drives (both IDE connected, no sata on my mother board anyways), a Maxtor 80GB (about seven years old) and a brand new (not even formatted) Western Digital Caviar 500 GB.

    The former is connected as master (with the pins set as master) and the other one is connected as slave (with the pins as "cable select"). The BIOS detects both hard drives and marks them accordingly to what I just described: Maxtor as master and WD as slave.

    However, only the master (Maxtor) is recognized in OpenSuSE 11.4 (I haven't tried with other variants of GNU/Linux and I don't have any MS Windows licenses nor CDs). The second one isn't recognized at all: there isn't even a /dev/sdb. I checked in the hardware configuration module of Yast, and it doesn't show up there either.

    What could be the problem? Is there a default kernel module which should be disabled?

    Note that both hard drives are connected with the same IDE cable.

    Any help or idea is appreciated! Thanks in advance.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 11.4 fresh install: ata2: SRST failed (errno=-16) onbrand new hard drive

    On 2011-04-16 13:36, n0x wrote:

    > The former is connected as master (with the pins set as master) and the
    > other one is connected as slave (with the pins as "cable select").


    Try as slave, not cable select. You need a special cable for that.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Oct 2008
    Posts
    27

    Default Re: Opensuse 11.4 fresh install: ata2: SRST failed (errno=-16) on brand new hard drive

    Ok, problem solved! I am not sure what the problem was due to exactly, but I suspect it to originate from a faulty IDE cable.

    I started by connecting another hard drive (we'll call it HD3) with the same cable configuration. I knew that other hard drive worked properly because it was the one used before the upgrade. That lead to the same error. So I knew it wasn't a hard drive problem.

    Then I connected HD3 to the IDE cable of the optical drive (a DVD burn set as master). That worked properly! No error message and the disk showed up in Yast.

    So finally, I plugged in the brand new hard drive (HD2) to the IDE cable of the optical drive and made sure to set HD2 as slave (instead of cable select as it was earlier). That did the trick!

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: Opensuse 11.4 fresh install: ata2: SRST failed (errno=-16) on brand new hard drive

    Hmm. In principle it's not a good idea to hook an optical drive and a hard disk in the same IDE cable, as the slower of the two will limit the transfer speed.
    Long ago, when I had IDE devices, a CDROM (and older 40GB-80GB HDs) would go as far as UDMA 66, while the newer HDs would top UDMA100 or 133. This may not apply to a DVD-RW, but I don't have any of these anymore to check.

    I'd suggest that you check the UDMA settings of your drives (don't remember the command now, someone here will tell you) and hook the drives accordingly, if necessary.

Similar Threads

  1. Replies: 6
    Last Post: 16-Nov-2013, 04:32
  2. Failed hard drive superblock
    By rgrandin in forum Hardware
    Replies: 13
    Last Post: 07-Aug-2010, 21:31
  3. Install OpenSUSE 11.1 on an USB Hard Drive
    By Ignatius881 in forum Install/Boot/Login
    Replies: 2
    Last Post: 18-Jun-2009, 10:37
  4. Fresh install on brand new laptop... no ethernet?
    By fsdhy in forum Network/Internet
    Replies: 1
    Last Post: 23-Sep-2008, 01:05

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •