Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Problems with installing packages with zypper

  1. #1

    Default Problems with installing packages with zypper

    Hi, I'm using openSUSE 11.4 KDE , once I used GNOME, now I'm a little bored with it ... It's a great release and interesting environment .. I am having this problem now:


    Code:
    linux-k6mm:/home/david # zypper in decibel
    Refreshing service 'Packman'.
    Unexpected exception.
    Parse error: repoindex.xml[1] Document is empty
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper/Troubleshooting for instructions
    Code:
    linux-k6mm:/home/david# zypper se decibel
    Refreshing service 'Packman'.
    Unexpected exception.
    Parse error: repoindex.xml[1] Document is empty
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper/Troubleshooting for instructions
    So.. I removed old Packman repo and even installed new one. I can Install programs through Yast, but can't do almost anything with zypper. PLease help!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Problems with installing packages with zypper

    Show me what you get from

    zypper ref
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Problems with installing packages with zypper

    Code:
    linux-k6mm:/home/david # zypper ref 
    Repository 'Packman' is up to date.
    Repository 'openSUSE-11.4-Non-Oss' is up to date.
    Repository 'openSUSE-11.4-Oss' is up to date.
    Repository 'openSUSE-11.4-Update' is up to date.
    All repositories have been refreshed.

    That is new - working Packman.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Problems with installing packages with zypper

    try

    zypper in decibel-audio-player
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Problems with installing packages with zypper

    Same problem again. There is no matter what I type in.. it's always the same output.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Problems with installing packages with zypper

    Switch to this packman url
    Index of /suse/openSUSE_11.4
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Problems with installing packages with zypper

    Try
    zypper clean
    zypper ref
    zypper in "name of the package"

  8. #8

    Default Re: Problems with installing packages with zypper

    Jacob-University is my new packman repo, and no matter if there is or there is not some packman repo, error output is same. Clean command doesn't help either.

  9. #9

    Default Re: Problems with installing packages with zypper

    could you please give me output of:
    zypper ls -d

  10. #10

    Default Re: Problems with installing packages with zypper

    Code:
    linux-k6mm:/home/david # zypper ls -d 
    # | Alias             | Name                       | Enabled | Refresh | Priority | Type   | URI                                                            
    --+-------------------+----------------------------+---------+---------+----------+--------+----------------------------------------------------------------
    1 | service           | Packman                    | Yes     | Yes     |          | ris    | http://packman.inode.at/suse/11.4/packman.repo                 
    2 | Packman           | Packman                    | Yes     | Yes     |   99     | rpm-md | http://packman.jacobs-university.de/suse/11.4/                 
    3 | repo-debug        | openSUSE-11.4-Debug        | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/ 
    4 | repo-debug-update | openSUSE-11.4-Update-Debug | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                
    5 | repo-non-oss      | openSUSE-11.4-Non-Oss      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/   
    6 | repo-oss          | openSUSE-11.4-Oss          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/       
    7 | repo-source       | openSUSE-11.4-Source       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/
    8 | repo-update       | openSUSE-11.4-Update       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/


    Yes... the first one gives me trouble...

    1 | service | Packman | Yes | Yes | | ris | http://packman.inode.at/suse/11.4/packman.repo
    but it's listed only here .. hm. When I type zypper rr service it says:

    Code:
    linux-k6mm:/home/david # zypper rr service
    Repository 'service' not found by alias, number or URI.
    We are close to solution

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •