Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: NetworkManager will not start automatically.

  1. #1
    Join Date
    Jun 2008
    Location
    Tacoma WA USA
    Posts
    28

    Default NetworkManager will not start automatically.

    Installed opensuse 11.4 and wireless network started automatically.

    Then I changed the name of the computer in YAST, and restarted. Now I cannot get NM to start automatically at boot. The red X shows up on the panel app Network Management and settings buttons do not activate the wireless device.
    I have to start NetworkManager from the command line. After about 30 seconds the wireless hardware symbol turns on and then I can connect to the network.

    HP Pavilion Dv7
    opensuse 11.4 64bit AMD
    RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    KDE desktop
    /etc/sysconfig shows NetworkManager=yes
    Service is configured to start on level 3 and level 5.

    This message appears in /var/log/messages

    Apr 15 09:57:24 Dv7 dbus-daemon: [system] Rejected send message, 7 matched rules; type="method_call", sender=":1.11" (uid=1000 pid=1673 comm="kdeinit4: plasma-desktop [kdeinit]) interface="org.freedesktop.NetworkManager" member="Sleep" error name="(unset)" requested_reply=0 destination="org.freedesktop.NetworkManager" (uid=0 pid=6283 comm="NetworkManager))

  2. #2

    Default Re: NetworkManager will not start automatically.

    I'm not openSusing at the moment, so bear with me. In /etc/ there should be some rc files or an rc.d, search around in them and try to figure out which services (Daemons) are starting up on boot. I'm wondering if your network is trying to start before dbus.
    Then, also in /etc/, look for a host or hosts file. I'm wondering if there is a bug in Yast that doesn't properly reset the hostname in the network host file since after changing it you had network problems.
    The 30 seconds you are suffering is your network timeout setting I bet.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  3. #3
    Join Date
    Jun 2008
    Location
    Tacoma WA USA
    Posts
    28

    Default Re: NetworkManager will not start automatically.

    Good ideas. However in looking at /etc/rc.d/rc5.d/
    lrwxrwxrwx 1 root root 8 Mar 2 03:52 S01acpid -> ../acpid
    lrwxrwxrwx 1 root root 10 Mar 2 03:54 S01cpufreq -> ../cpufreq
    lrwxrwxrwx 1 root root 7 Mar 2 03:52 S01dbus -> ../dbus
    lrwxrwxrwx 1 root root 14 Mar 2 03:53 S01earlysyslog -> ../earlysyslog
    lrwxrwxrwx 1 root root 8 Mar 2 03:52 S01fbset -> ../fbset
    lrwxrwxrwx 1 root root 16 Mar 2 03:52 S01microcode.ctl -> ../microcode.ctl
    lrwxrwxrwx 1 root root 9 Mar 2 03:52 S01random -> ../random
    lrwxrwxrwx 1 root root 10 Mar 2 03:53 S02network -> ../network
    lrwxrwxrwx 1 root root 9 Mar 2 03:53 S03syslog -> ../syslog
    lrwxrwxrwx 1 root root 9 Mar 2 03:53 S04auditd -> ../auditd
    lrwxrwxrwx 1 root root 10 Mar 2 03:53 S04rpcbind -> ../rpcbind
    lrwxrwxrwx 1 root root 15 Mar 2 03:53 S04splash_early -> ../splash_early
    Also /etc/HOST and /etc/hosts seem to be set okay. I think my problem is with invoking NetworkManager at startup.

    Thanks.

  4. #4
    Join Date
    Jan 2011
    Location
    Riverside, Ca.
    Posts
    220

    Default Re: NetworkManager will not start automatically.

    If you installed from DVD you have the wrong Network manager anyway. Add plasmoid-networkmanagement in YaST. It will warn you of a conflict. Remove the conflicting packages. Install, reboot and enjoy.

    If this works click me some rep

  5. #5
    Join Date
    Jun 2008
    Location
    Tacoma WA USA
    Posts
    28

    Default Re: NetworkManager will not start automatically.

    Good idea, but I installed from the KDE live CD.
    I tried switching to the other NetworkManager and no joy.
    I switched back to plasmoid-networkmanager (resolved dependency) and still the same problem.
    The workaround is to start NetworkManger from the command line as root and the network comes up immediately.
    It seems lame to have to start my wifi from the command line every time.
    Thanks.

  6. #6

    Default Re: NetworkManager will not start automatically.

    Just write a little startup script
    How To Run Custom Script At Startup?
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  7. #7
    Join Date
    Oct 2010
    Posts
    43

    Default Re: NetworkManager will not start automatically.

    waerola1 wrote:

    >
    > Good idea, but I installed from the KDE live CD.
    > I tried switching to the other NetworkManager and no joy.
    > I switched back to plasmoid-networkmanager (resolved dependency) and
    > still the same problem.
    > The workaround is to start NetworkManger from the command line as root
    > and the network comes up immediately.
    > It seems lame to have to start my wifi from the command line every
    > time.
    > Thanks.


    I had a similar problem.

    When set to tradiotional Network Setup Method in YasT, have a look under

    Network Settings -> Overview Tab

    and chose edit the Network controller for you wireless card and look under
    the "General" tab.

    In my case this was not set to start the device at boot but rather at "On
    NFSroot" for some reason.

    Changed that to on boot, switched over to networkmanager control and it has
    worked ever since.

    Hope this helps in some way.

    --
    Don

  8. #8
    Join Date
    Jun 2008
    Location
    Tacoma WA USA
    Posts
    28

    Default Re: NetworkManager will not start automatically.

    End of Thread
    I found a blog that suggested installing the Gnome networkmanager called nm-applet. That gives me a working network management application. My wifi seems to have improved too.
    HTML Code:
    http://susestarter.blogspot.com/2011/03/step-2-need-mobile-broadband-use-gnome.html
    Thanks for all you suggestions.

  9. #9

    Default Re: NetworkManager will not start automatically.

    Well, the "OnNFSroot" change fixed my issue. I am guessing they really need to fix that.

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: NetworkManager will not start automatically.

    Quote Originally Posted by dekernel View Post
    Well, the "OnNFSroot" change fixed my issue. I am guessing they really need to fix that.
    According to documentation the solution sounds reasonable so I'm guessing this works as expected
    Chapter

    Best regards,
    Greg
    Best regards,
    Greg

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •