Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Delay during boot process on 11.4

  1. #1

    Default Delay during boot process on 11.4

    Hi all,

    I have recently installed Suse 1.4_64 on my system. During the boot process I experience two delays of about 30 seconds, every time I boot up.

    Any suggestions?

    The system has is dual boot, multiple disks:

    Disk /dev/sda: 80.0 GB
    /dev/sda1 HPFS/NTFS/exFAT
    /dev/sda2 HPFS/NTFS/exFAT
    /dev/sda3 Linux
    /dev/sda4 Linux swap / Solaris

    Disk /dev/sdc: 1000.2 GB
    /dev/sdc1 HPFS/NTFS/exFAT

    Disk /dev/sdd: 750.2 GB
    /dev/sdd1 HPFS/NTFS/exFAT
    /dev/sdd2 Linux

    Disk /dev/sde: 500.1 GB
    /dev/sde1 Linux

    Here is a snippet from dmesg:

    [ 5.248419] nvidia 0000:04:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
    [ 5.248426] nvidia 0000:04:00.0: setting latency timer to 64
    [ 5.248431] vgaarb: device changed decodes: PCI:0000:04:00.0,olddecodes=io+mem,decodes=nonewns=io+mem
    [ 5.248566] NVRM: loading NVIDIA UNIX x86 Kernel Module 260.19.44 Sun Feb 27 21:30:31 PST 2011
    [ 35.744134] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
    [ 35.744357] ata2.00: failed command: IDENTIFY PACKET DEVICE
    [ 35.744465] ata2.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 0 pio 512 in
    [ 35.744466] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
    [ 35.744729] ata2.00: status: { DRDY }
    [ 35.744797] ata2: hard resetting link
    [ 36.204126] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    [ 37.006348] ata2.00: configured for PIO4
    [ 37.807142] ata2: EH complete
    [ 37.890491] Adding 4653052k swap on /dev/sda4. Priority:-1 extents:1 across:4653052k SS
    [ 38.084040] device-mapper: uevent: version 1.0.3
    [ 38.084187] device-mapper: ioctl: 4.18.0-ioctl (2010-06-29) initialised: dm-devel@redhat.com
    [ 69.476870] kjournald starting. Commit interval 15 seconds
    [ 69.477257] EXT3-fs (sde1): using internal journal
    [ 69.477260] EXT3-fs (sde1): mounted filesystem with ordered data mode
    [ 69.482601] fuse init (API version 7.15)

    Thanks in advance

    Linux 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686 athlon i386 GNU/Linux

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Delay during boot process on 11.4

    On 2011-04-14 20:36, u20380 wrote:
    > Hi all,
    >
    > I have recently installed Suse 1.4_64 on my system. During the boot
    > process I experience two delays of about 30 seconds, every time I boot
    > up.
    >
    > Any suggestions?


    splash=verbose

    remove "quiet".

    Find out where it waits.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Delay during boot process on 11.4

    Or just press ESC key when the splash appear.

  4. #4

    Default Re: Re : Re: Delay during boot process on 11.4

    The first wait occurs at 5 seconds into the boot process, with an error message "ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen"
    The second wait at 38 seconds, with a message "device-mapper: ioctl: 4.18.0-ioctl (2010-06-29) initialised: dm-devel@redhat.com"

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Re : Re: Delay during boot process on 11.4

    You could install bootchart and use that to help you determine where any boot slow down may be.

    One of our other moderators showed me how to do it. I installed the application bootchart , obtaining it from a factory repository:
    Code:
    http://download.opensuse.org/repositories/Base:/System/openSUSE_Factory/
    Then I opened an xterm (konsole also works in KDE) and restarted from the LXDE menu with that separate terminal open.

    In the grub option line I entered:
    Code:
    init=/sbin/bootchartd
    Then after the reboot was finished I again opened a terminal (or konsole) and that stopped the bootchart data collection process. I then waited a bit for the bootchart.png file to be created.

    That produced the charts noted above. ... I stumbled a bit on this and had to get help from some of the SuSE-GmbH team (via a bug report which illustrated my ignorance). The first chart shows apparmor was consuming ~26% of CPU during boot, so given it is not essential, I was advised it was a possible candidate to disable. It can be disabled with YaST > System > System Services (run level) > expert mode > boot.apparmor .... etc ... [I'm no expert in this].

    Here is the bootchart.png of my sandbox PC, which is a truely ancient 32-bit athlon-1100 (running 11.4) with no optimisation (immediately after the install) and a rather slow and ancient nVidia FX5200 graphic card:


    boot chart identified some areas that could be tuned ...

    Here is the same ancient athlon-1100 with the same openSUSE-11.4 install but with apparmor removed and the number of VT (terminal) sessions reduced. Much faster to boot (from 120 seconds to 85 seconds):


    Probably more optimization could be done - but optimization of boot time is not a subject that interests me on such an old PC as my sandbox PC.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Delay during boot process on 11.4

    On 2011-04-15 14:06, u20380 wrote:
    >
    > The first wait occurs at 5 seconds into the boot process, with an error
    > message "ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
    > frozen"
    > The second wait at 38 seconds, with a message "device-mapper: ioctl:
    > 4.18.0-ioctl (2010-06-29) initialised: dm-devel@redhat.com"


    Either a hardware problem, or a bug. Try another opensuse version: if it
    doesn't pause, report in bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Delay during boot process on 11.4

    On 2011-04-15 03:06, DaaX wrote:
    >
    > Or just press ESC key when the splash appear.


    No, removing the "quiet" paramenter makes booting to be extra verbose and
    log it all.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Delay during boot process on 11.4

    Quote Originally Posted by robin_listas View Post
    On 2011-04-15 03:06, DaaX wrote:
    >
    > Or just press ESC key when the splash appear.


    No, removing the "quiet" paramenter makes booting to be extra verbose and
    log it all.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)
    Ah oki, so it is more verbose than just pressing the ESC key.... I'll remember this then.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Delay during boot process on 11.4

    On 2011-04-15 16:06, DaaX wrote:

    > Ah oki, so it is more verbose than just pressing the ESC key.... I'll
    > remember this then.


    I learned that recently, on a bugzilla :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: Delay during boot process on 11.4

    Carlos,

    I ran the 11.2 LiveCD and it ran like a breeze, no timeouts.
    It does seem to be a bug indeed.

    Thanks

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •