Results 1 to 10 of 10

Thread: Problems after ATI driver installation

  1. #1
    Join Date
    Apr 2011
    Location
    Tuscany
    Posts
    15

    Default Problems after ATI driver installation

    I Just installed OpenSuse 11.4-32 bit with KDE 4.6 on my PC.
    At first boot everything was working, then I added the community ATI/AMD repository to get the drivers for my ATI 5570, but after reboot i got a blank screen.
    So I ran the "failsafe mode" in the boot menu, it worked (3D accel. as well), but just for the root user. To make it work for the non-root user had to set the setuid bit for /usr/bin/Xorg. (is it ok to run xorg with superuser privileges?)
    Then I tryed to understand wich is the kernel option actually needed for X to start, and after a few attempts I realized the only option really needed is the "nomodeset".

    Can you tell me what is the nomodeset option for? and why I need it to run in the graphic mode?
    Thank you
    Alessandro

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Problems after ATI driver installation

    Hi,

    Wich driver did you installed ?

  3. #3
    Join Date
    Apr 2011
    Location
    Tuscany
    Posts
    15

    Default Re: Re : Problems after ATI driver installation

    Quote Originally Posted by DaaX View Post
    Hi,

    Wich driver did you installed ?
    On Yast for "fglrx" i get:

    ati-fglrxG02-kmp-desktop - ATI "fglrx" driver kernel module
    ATI "fglrx" driver kernel module for ATI Radeon HD 2000 and later.
    Vers. 8.812_k2.6.37.1_1.2-49.1

    And
    x11-video-fglrxG02 - X Window display driver for the ATI graphics accelerators
    Vers. 8.812-51.1

    fglrxinfo:
    display: :0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 5700 Series
    OpenGL version string: 4.1.10428 Compatibility Profile Context

  4. #4
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Re : Problems after ATI driver installation

    So the nomodeset option disable the KMS kernel module. As it seems to work for you that way.

    Some readings for you on this : openSUSE Graphic Card Practical Theory Guide for Users

    Perhaps oldcpu could help you more on this issue than me.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems after ATI driver installation

    Quote Originally Posted by _x_e_l_A_l_e_x_ View Post
    (is it ok to run xorg with superuser privileges?)
    No it is not.

    Quote Originally Posted by _x_e_l_A_l_e_x_ View Post
    Then I tryed to understand wich is the kernel option actually needed for X to start, and after a few attempts I realized the only option really needed is the "nomodeset".

    Can you tell me what is the nomodeset option for? and why I need it to run in the graphic mode?
    nomodest stops the modeset (KMS - kernel mode set) loading. Mode-setting if enabled supports setting up the screen resolution and depth mode for the graphics card. Doing mode-setting in kernel-space (with KMS) is purportedly more flexible and it moves a lot of graphics card control logic to kernel which makes it possible to write more advanced 3D and 2D drivers. With KMS the Linux kernel which will do most of the work of setting your screen resolution, depth, colors, etc. Earlier this configuration was done by the Xorg graphics drivers. Unfortunately in terms of the age of Linux, it is still relatively new and does not always work well.

    The openSUSE-11.3 and 11.4 release notes has words on this, but my guess you did not read those, or if you did read them what you saw did not help.

    In the case of openSUSE-11.4, if you boot the liveCD or install from DVD, openSUSE will initially attempt to boot with the radeon open source driver. That driver should support the AMD HD 5770, for if you type :
    Code:
    man radeon
    you will read that the 'radeon' graphic driver is supposed to support the Juniper HD 5770 graphics.

    If at this point in time, without the proprietary graphic driver installed, if you were to boot the pc and type 'nomodeset', openSUSE-11.4 in addition to booting with modeset disabled, would also load the 'radeonhd' driver which does NOT support the HD 5770. So without the proprietary graphic driver installed, 'nomodeset' on your hardware should fail.

    So I find it interesting that by typing 'nomodeset' you are able to boot.

    This suggests to me that in fact for you to get the 'fglrx' (proprietary graphic driver) to work, you need to disable modesetting with 'nomodeset'.

    IF you had read the openSUSE release notes, you would have read that another way to do that (which in fact is the way I adopt for my HD 3450 AMD graphics) is to go to YaST > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to "yes". This takes a minute or two to save once changed is submitted.

    In my case, I build my AMD drivers the hardway (and I do not use the repository approach you followed) and I always disable KMS BEFORE trying to build my proprietary graphic driver.

    I'm not familiar with the repository method of installing the graphic driver, so I can not tell if you have the latest Catalyst 11.3 proprietary graphic driver (which purportedly has early openSUSE-11.4 graphic card support).

    You can tell if you have the proprietary graphic driver loaded by looking at your loaded modules :
    Code:
    lsmod
    and check to see if 'fglrx' or 'radeon' is in that list. For the proprietary driver you should see 'fglrx' and not 'radeon'.

    You may also see what driver is loaded if you type:
    Code:
    /sbin/lspci -nnk
    and look for the line that starts with VGA and then read the next two lines. That may tell you the loaded driver.

    Your /etc/var/log/Xorg.0.log file will also tell you what the loaded driver is.

    Now you may KNOW exactly what your loaded driver is when you type 'nomodeset' but reading your post I can not tell what you are reporting (my knowledge is not strong enough to helpfully interpret fully what you posted).

  6. #6
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Problems after ATI driver installation

    Hi oldcpu,

    So I was not too oof track in my little explanation. I am glad because I learned your lessons well.

    Thanks for the added explanation, I'll try to remember it.

  7. #7
    Join Date
    Apr 2011
    Location
    Tuscany
    Posts
    15

    Default Re: Re : Re: Problems after ATI driver installation

    Hi oldcpu and thanks for your reply
    I reinstalled the same drivers using Yast and removed the setuid bit for xorg and now everything works.
    NO_KMS_IN_INITRD is set to "no" and I can boot with or without the 'nomodeset' option, and it looks like I get the same drivers loaded in both cases (proprietary):

    NOMODESET:
    Code:
    lsmod:
    ...
    fglrx                2399517  311
    Code:
    lspci:
    ...
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Juniper [Radeon HD 5700 Series] [1002:68b8]
            Subsystem: PC Partner Limited Device [174b:1482]
            Kernel driver in use: fglrx_pci
    WITHOUT NOMODESET:
    Code:
    lsmod:
    ...
    fglrx                2399517  361
    Code:
    lspci:
    ...
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Juniper [Radeon HD 5700 Series] [1002:68b8]                                                                                                     
            Subsystem: PC Partner Limited Device [174b:1482]                                                                                                                                                       
            Kernel driver in use: fglrx_pci
    ... but reading your post I can not tell what you are reporting (my knowledge is not strong enough to helpfully interpret fully what you posted).
    Sorry about that English is not my mother tongue (as you may guess).
    Thanks for your time.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Re : Re: Problems after ATI driver installation

    Quote Originally Posted by _x_e_l_A_l_e_x_ View Post
    I reinstalled the same drivers using Yast and removed the setuid bit for xorg and now everything works.
    NO_KMS_IN_INITRD is set to "no" and I can boot with or without the 'nomodeset' option, and it looks like I get the same drivers loaded in both cases:
    Thats interesting that it works set to "no". If I had to guess I would have guessed that you would need to set it to "yes".

  9. #9
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Re : Re: Problems after ATI driver installation

    Do you activated 3D desktop ? Does it work ? Like oldcpu said, it is suprising that it works now with nomodeset=no.

  10. #10
    Join Date
    Apr 2011
    Location
    Tuscany
    Posts
    15

    Default Re: Re : Re: Re : Re: Problems after ATI driver installation

    Quote Originally Posted by DaaX View Post
    Do you activated 3D desktop ? Does it work ? Like oldcpu said, it is suprising that it works now with nomodeset=no.
    Do you mean wobbly windows, rotating cube ecc...? yes

    By tuxefy at 2011-04-14

    Later I will run a live cd to see which driver is loaded

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •