Results 1 to 6 of 6

Thread: Systemd and ntp

  1. #1
    Join Date
    Nov 2009
    Location
    Hampshire, UK
    Posts
    42

    Default Systemd and ntp

    I'm using 11.4 in a multiboot setup with Windows 7 and 11.3 (I installed 11.4 in its own partition and then added it to GRUB in 11.3).

    I wanted to try systemd so added it to 11.4.

    If I boot with systemV init then ntp starts and sets time correctly.

    If I boot with systemd then it all starts fine but the clock is an hour slow but still claims to be in BST. If I go into settings and set locale without changing value it corrects the time.

    (Because of Windows the system clock is set to local time).

    11.3 and Windows all have the correct time.

    Any ideas?
    - Custom built core i7 720, 18GB RAM, nVidia GT1030 Asus Xonar D2X, OpenSuse 15.2 and Tumbleweed 64bit

    He is no fool who gives up that which he cannot keep to gain that he cannot loose - Jim Elliot

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Systemd and ntp

    On 2011-04-14 13:36, tweetiepooh wrote:

    > Any ideas?


    Bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: Systemd and ntp

    Is one set for daylight savings time the other is not? How about the HW clock?
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  4. #4
    Join Date
    Nov 2009
    Location
    Hampshire, UK
    Posts
    42

    Default Re: Systemd and ntp

    As far as I know the settings are the same in all.

    HW clock is set to local time (Windows forces this)

    Timezone is set to Europe/London which I'd guess automatically compensates for daylight saving on the appropriate dates.

    11.4$ date
    time one hour ago BST

    11.3$ date
    time now BST
    - Custom built core i7 720, 18GB RAM, nVidia GT1030 Asus Xonar D2X, OpenSuse 15.2 and Tumbleweed 64bit

    He is no fool who gives up that which he cannot keep to gain that he cannot loose - Jim Elliot

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Systemd and ntp

    On 2011-04-15 09:36, tweetiepooh wrote:

    To me it looks like a bug you should report in bugzilla. It can not be that
    using systemv or systemd makes different times.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6

    Default Re: Systemd and ntp

    Quote Originally Posted by tweetiepooh View Post
    As far as I know the settings are the same in all.

    HW clock is set to local time (Windows forces this)

    Timezone is set to Europe/London which I'd guess automatically compensates for daylight saving on the appropriate dates.

    11.4$ date
    time one hour ago BST

    11.3$ date
    time now BST
    There are timing errors between Win and Linux and there's a timezone fix from Win 7 that I don't have the link for at the moment. It updates the timezones.

    Starting out I'd set other system clocks (including the BIOS) to the same timezones, UTC and DST as OS 11.3. Use the same NTP Internet time providers as 11.3. Because you have 3 systems on the same machine I don't think its a BIOS clock issue (HW clock) even though systems update the HW clock when rebooting.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •