Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Disable Blueman on KDE

  1. #1

    Question Disable Blueman on KDE

    I have installed Blueman. But I want to disable it on KDE startup so that whenever I turn on my Bluetooth, blueman shouldn't take over the KDE's Bluedevil.

    Please tell me how I can do so.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,889
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    Remove the package (unless you really want to keep it):

    Code:
    zypper rm blueman
    Check ~/.kde4/Autostart for links to this app.

  3. #3

    Default Re: Disable Blueman on KDE

    I do not want to remove it as its very useful to connect to the Internet through the phone and many things that BlueDevil currently doesn't support. So I simply want to remove it from the startup.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,646
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    Does Blueman start as a Service?
    Then you can disable the "Start on Boot" configuration through YAST

    YAST > System > System Service(RunLevel) > Advanced

    HTH,
    Tony

  5. #5

    Default Re: Disable Blueman on KDE

    @tsu2 No, its not a service. It starts with KDE.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,889
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    If it is not in 'Autostart', also make sure that its not simply starting because you have 'Restore previous session' in System Settings>>Startup and Shutdown>>Session Management.

  7. #7

    Default Re: Disable Blueman on KDE

    I guess its associated with a KDE installation in /usr. I kill blueman before logout, but it still starts with every login.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,889
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    Ok, I think I may have found how it gets loaded. Blueman is a gnome app, and at installation it creates a .desktop file called /etc/xdg/autostart/blueman.desktop. Have a look at this file with an editor and make sure that this entry

    Code:
    OnlyShowIn=GNOME;XFCE;LXDE;
    doesn't contain KDE as well. Mine for reference:

    Code:
    [Desktop Entry]
    X-SuSE-translate=true
    GenericName=Bluetooth Manager applet
    Name=Bluetooth Manager
    Comment=Bluetooth Manager applet
    Icon=bluetooth
    Exec=bluetooth-applet
    Terminal=false
    Type=Application
    Categories=
    OnlyShowIn=GNOME;XFCE;LXDE;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=gnome-bluetooth
    X-GNOME-Bugzilla-Component=applet
    X-GNOME-Bugzilla-Version=2.30.0
    Last edited by deano_ferrari; 16-Apr-2011 at 00:08.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,889
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    FWIW, a similar approach can be used to autostart Gnome apps like nm-applet for those users running KDE4 (who don't like the KDE equivalents).

    Outlined here:

    Kubuntu: knetworkmanager and kdebluetooth sucks! let’s use better tools goshawk's digital nest

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,889
    Blog Entries
    1

    Default Re: Disable Blueman on KDE

    Just to expand on potential Autostart folders, for those looking to enable or disable 'auto-starting' of particular apps. KDE checks these locations for .desktop files:

    ~/.kde4/Autostart
    ~/.kde4/share/autostart
    ~/.config/autostart
    ~/.local/share/autostart
    /etc/xdg/autostart
    /usr/share/autostart

    (Adjusted for openSUSE which uses .kde4 directory naming)

    References:

    Autostart in KDE Linux | Sharpley.org.uk

    KDE / GNOME autostart | LinuxPC.info

    Hope this is helpful to others.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •