Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Internal Microphone not working- help

  1. #1

    Default Internal Microphone not working- help

    I have an Acer 4810T laptop with built-in mic and webcam. I have looked all over the internet and tried a variety of "solutions", but can't get me internal mic working in 11.4 with kde 4.6. It worked fine in 11.3 with kde 4.4 and 4.5 and then I did a dup upgrade and everything else works fine except the internal mic.

    Now, with Pulse Audio uninstalled, it won't work in Skype and Audacity will let me record, but adds a huge amount of white noise. No amount of playing around with the "capture", "mic boost" and "digital" settings will give satisfactory results (not even close).

    When Pulse audio is installed; I only have one volume slider in pavucontrol and in Audacity it says "no devices found" for the input device.

    Any help would be appreciated. Thanks.

    With Pulse uninstalled here is the information for this computer:

    http://www.alsa-project.org/db/?f=b2...72ec81f8d714f0

    rpm -qa '*alsa*'
    alsa-plugins-1.0.24-6.1.i586
    alsa-oss-1.0.17-32.1.i586
    alsa-firmware-1.0.24.1-3.1.noarch
    alsa-utils-1.0.24.2-3.1.i586
    alsa-1.0.24.1-4.5.1.i586
    rpm -qa '*pulse*'
    libpulse-mainloop-glib0-0.9.22-6.9.1.i586
    libpulse0-0.9.22-6.9.1.i586
    rpm -q libasound2
    libasound2-1.0.24.1-4.5.1.i586
    uname -a
    2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686 i686 i386 GNU/Linux

    With Pulse installed and activated the information is:
    rpm -qa '*pulse*'
    alsa-plugins-pulse-1.0.24-6.1.i586
    pulseaudio-module-gconf-0.9.22-6.9.1.i586
    libpulse-mainloop-glib0-0.9.22-6.9.1.i586
    libxine1-pulse-1.1.19-4.4.i586
    libpulse0-0.9.22-6.9.1.i586
    pulseaudio-0.9.22-6.9.1.i586
    pulseaudio-module-jack-0.9.22-6.9.1.i586
    pulseaudio-utils-0.9.22-6.9.1.i586
    pulseaudio-module-x11-0.9.22-6.9.1.i586
    pulseaudio-module-zeroconf-0.9.22-6.9.1.i586
    libpulse-browse0-0.9.22-6.9.1.i586
    pulseaudio-gdm-hooks-0.9.22-6.9.1.i586
    pulseaudio-lang-0.9.22-6.9.1.noarch
    pulseaudio-module-bluetooth-0.9.22-6.9.1.i586
    pulseaudio-module-lirc-0.9.22-6.9.1.i586

    http://www.alsa-project.org/db/?f=d9...19bcbd2cdd8919

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Internal Microphone not working- help

    When you give quote with pulse installed and not installed , that gives me a degree of trepidation. openSUSE-11.4 was mostly tested with pulse installed, so wrt pulse not being installed I don't feel comfortable in providing suggestions there.

    As you have discovered, openSUSE-11.4 KDE with pulse audio enabled is a different 'beast' from 11.3 KDE. My experience is one needs to also install the application 'pavucontrol' in order to get adequate control over one's audio for both playing sound and recording sound. Once installed, run 'pavucontrol' and try to tune the 'recording' section and also the 'input' section.

    Note your internal mic is likely a digital mic.

    I note this in your mixer:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    ie only one record device. I expected more than one (as I assume your PC has a jack for an external mic) so that in my mind raises the possibility of a misconfigured alsa driver load. But before we jump to that conclusion, I note this in your mixer:
    Code:
     !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [Intel]
    
    Card hw:0 'Intel'/'HDA Intel at 0xd4100000 irq 40'
      Mixer name    : 'Realtek ALC269'
      Components    : 'HDA:10ec0269,1025022a,00100004'
    Simple mixer control 'Mic Boost',1
      Front Left: 0 [0%]
      Front Right: 0 [0%]
    Simple mixer control 'Capture',0
      Front Left: Capture 39 [85%] [22.00dB] [on]
      Front Right: Capture 39 [85%] [22.00dB] [on]
    Simple mixer control 'Digital',0
      Front Left: Capture 49 [41%] [-5.50dB]
      Front Right: Capture 49 [41%] [-5.50dB]
    Having boost at 0% may mute the recording. 41% capture for a digital capture is low.

    Try adjusting those.

  3. #3

    Default Re: Internal Microphone not working- help

    Thanks for the quick reply.

    Uninstalling Pulse was a desperation move when nothing else worked. It is currently reinstalled. Whether the mic boost is on or not seems to make little difference. Using alsamixer from the command line, when I put the capture up to 83% and the digital up to 60% I can "hear" my recording, but there is a lot of white noise. It seems that the digital needs to go higher, but this also is increasing the noise. There isn't any combination that seems to work. Using pavucontrol only gives me one slider for input devices and if I open pavucontrol and then open audacity, then it gives me "device not found" for the recording device, if I open alsamixer, then I get the white noise problem.

    Yes, you are correct about your assumptions about there being an external jack and that the internal mic is a digital mic (as far as I know). What do I need to do to get the alsa drivers correctly configured.? That is my guess since I have tried just about every different configuration of the settings.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Internal Microphone not working- help

    Quote Originally Posted by bumble66 View Post
    Uninstalling Pulse was a desperation move when nothing else worked. It is currently reinstalled. Whether the mic boost is on or not seems to make little difference. Using alsamixer from the command line, when I put the capture up to 83% and the digital up to 60% I can "hear" my recording, but there is a lot of white noise. It seems that the digital needs to go higher, but this also is increasing the noise. There isn't any combination that seems to work. Using pavucontrol only gives me one slider for input devices and if I open pavucontrol and then open audacity, then it gives me "device not found" for the recording device, if I open alsamixer, then I get the white noise problem.

    Yes, you are correct about your assumptions about there being an external jack and that the internal mic is a digital mic (as far as I know).
    OK, ... please note that audacity is NOT a good application for testing basic audio recording ... I recommend use something simple. ie "arecord". For example, type in a terminal:
    Code:
    arecord -vv -f cd test.wav
    which will record to file test.wav. Tune your mixer. Then stop the recording by pressing in that terminal <ctl><c> . Then play back test.wav. Try different mixer settings.

    Quote Originally Posted by bumble66 View Post
    What do I need to do to get the alsa drivers correctly configured.? That is my guess since I have tried just about every different configuration of the settings.
    Well, your PC has an ALC269 hardware audio codec. If you look at the documentation on your PC, in the directory /usr/src/linux-(your-kernel-version)/Documentation/sound/alsa you will see the file HD-Audio-Models.txt (on my PC the directory is /usr/src/linux-2.6.34.7-0.7/Documentation/sound/alsa ). For the ALC269 that file has:

    Code:
    ALC269
    ======
      basic        Basic preset
      quanta    Quanta FL1
      laptop-amic    Laptops with analog-mic input
      laptop-dmic    Laptops with digital-mic input
      fujitsu    FSC Amilo
      lifebook    Fujitsu Lifebook S6420
      auto        auto-config reading BIOS (default)
    There are specific edits one can make to the /etc/modprobe.d/50-sound.conf file to force a specific alsa configuration upon boot. But to provide a recommendation, I need to see the content of your PC's /etc/modprobe.d/50-sound.conf file. ie what is the output of:
    Code:
    cat /etc/modprobe.d/50-sound.conf

  5. #5

    Default Re: Internal Microphone not working- help

    oldcpu thanks again. Here is the 50-sound.conf file:

    options snd slots=snd-hda-intel,snd-hda-intel
    # NXNs.WGJCmrf0_q6:R700 Audio Device [Radeon HD 4000 Series]
    alias snd-card-1 snd-hda-intel
    # u1Nb.KeU1GhG9Vq1:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    Anything else I need to pass on. Did a little testing with arecord, will do more later, but so far lots of static like before.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Internal Microphone not working- help

    Ok, again as per my above post,

    Your PC has an ALC269 hardware audio codec and if you look at the documentation on your PC, in the directory /usr/src/linux-(your-kernel-version)/Documentation/sound/alsa you will see the file HD-Audio-Models.txt (on my PC the directory is /usr/src/linux-2.6.34.7-0.7/Documentation/sound/alsa ). For the ALC269 that file has:

    Code:
    ALC269
    ======
      basic        Basic preset
      quanta    Quanta FL1
      laptop-amic    Laptops with analog-mic input
      laptop-dmic    Laptops with digital-mic input
      fujitsu    FSC Amilo
      lifebook    Fujitsu Lifebook S6420
      auto        auto-config reading BIOS (default)
    Now one can use one of those model options for force alsa not to autoconfigure, but to rather use a specific configuration upon boot.

    Quote Originally Posted by bumble66 View Post
    Code:
    options snd slots=snd-hda-intel,snd-hda-intel
    # NXNs.WGJCmrf0_q6:R700 Audio Device [Radeon HD 4000 Series]
    alias snd-card-1 snd-hda-intel
    # u1Nb.KeU1GhG9Vq1:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    You should try each model option in that list, ONE at a TIME ! and see if you can get your internal mic function with each one in turn. (ie spend some time on each one testing) ..

    Lets say you think your laptop has a digital mic, and you wish to try that model option (laptop-dmic) first. Then you should add the following line at the START of the /etc/modprobe.d/50-sound.conf file (you need to use root permissions to do that) , such that the file now looks like:

    Code:
    options snd-hda-intel model=laptop-dmic
    options snd slots=snd-hda-intel,snd-hda-intel
    # NXNs.WGJCmrf0_q6:R700 Audio Device [Radeon HD 4000 Series]
    alias snd-card-1 snd-hda-intel
    # u1Nb.KeU1GhG9Vq1:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    save the change, then restart your alsa sound driver by typing as a regular user:
    Code:
    su -c 'rcalsasound restart'
    and provide your root password when prompted for a password. As a regular user then restart your mixer (type 'kmix' if KDE) and then test your mic recording. Do NOT forget to start 'pavucontrol' and use that as well when testing. If you get some popup message from KDE asking if you can forget your old configurations, make the selection to get rid of them. Don't worry, you can put things back the way they were.

    Its possible laptop-dmic will make this worse and you may have no sound ... No worries. Simply edit the /etc/modprobe.d/50-sound.conf file, replacing laptop-dmic with another model option from the list. Save the change, restart the alsa sound driver, restart the mixer, and test. Do that for EACH model option in the list.

    Note that if you find a setting you like, from now on you need to avoid YaST > Hardware > Sound as it will re-write the /etc/modprobe.d/50-sound.conf file.

  7. #7
    Join Date
    Apr 2011
    Location
    Bulgaria
    Posts
    5

    Default Re: Internal Microphone not working- help

    Hello Dear Suse users and developers.
    I have the same problem with my Asus K50AB. Internal mic not work.
    When apply this line into beginning at 50-sound.conf:

    options snd-hda-intel model=asus

    and restarted alsa from the terminal, worked only external jack microphone input, but not built in - only white noise from him.
    Same effect with model options: auto, lifebook, 3stack, 3stack-dig ... etc. When remove this entire line -> not signal from any microphones - full silence.
    In opensuse 11.3 with KDE4.x all inputs worked fine. For this reason unfortunately last 1~2 months i use ubuntu or win7 for VoIP services.

    Card model: HDA ATI SB
    Chip: VIA VT1708S
    OS: openSUSE 11.4 x86_64
    GUI: KDE 4.6

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Internal Microphone not working- help

    Quote Originally Posted by welder_01 View Post
    For this reason unfortunately last 1~2 months i use ubuntu or win7 for VoIP services.
    What can you tell us about Ubuntu's setup ? alsa version ? output URL/address provided by running the diagnostic script with PC connected to Internet (selecting the SHARE/UPLOAD option):
    Code:
    /usr/sbin/alsa-info.sh
    and what can you tell us about openSUSE running the same diagnostic script (ie output URL/address) with PC connected to Internet (selecting the SHARE/UPLOAD option):
    Code:
    /usr/sbin/alsa-info.sh
    ..
    also the output on openSUSE of running:
    Code:
    rpm -qa '*alsa*'
    rpm -qa '*pulse*'
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/50-sound.conf

  9. #9
    Join Date
    Apr 2011
    Location
    Bulgaria
    Posts
    5

    Default Re: Internal Microphone not working- help

    Quote Originally Posted by oldcpu View Post
    What can you tell us about Ubuntu's setup ? alsa version ? output URL/address provided by running the diagnostic script with PC connected to Internet?...
    alsa-info.sh trough UIbuntu 10.10: here.


    Quote Originally Posted by oldcpu View Post
    ....and what can you tell us about openSUSE running the same diagnostic script (ie output URL/address) with PC connected to Internet?
    alsa-info.sh trough openSUSE 11.4: here.



    ..
    Quote Originally Posted by oldcpu View Post
    ...also the output on openSUSE
    Code:
    opensuse:~ # rpm -qa '*alsa*'
    alsa-plugins-32bit-1.0.24-6.1.x86_64
    alsa-1.0.24.1-4.7.1.x86_64
    alsa-utils-1.0.24.2-3.1.x86_64
    alsa-oss-1.0.17-32.1.x86_64
    alsa-plugins-1.0.24-6.1.x86_64
    alsa-oss-32bit-1.0.17-32.1.x86_64
    alsa-plugins-pulse-32bit-1.0.24-6.1.x86_64
    alsa-firmware-1.0.24.1-3.1.noarch
    alsa-plugins-pulse-1.0.24-6.1.x86_64
    opensuse:~ # rpm -qa '*pulse*'
    pulseaudio-module-zeroconf-0.9.22-6.11.1.x86_64
    libpulse-browse0-0.9.22-6.11.1.x86_64
    pulseaudio-module-bluetooth-0.9.22-6.11.1.x86_64
    libpulse0-0.9.22-6.11.1.x86_64
    pulseaudio-module-gconf-0.9.22-6.11.1.x86_64
    pulseaudio-0.9.22-6.11.1.x86_64
    pulseaudio-module-lirc-0.9.22-6.11.1.x86_64
    alsa-plugins-pulse-32bit-1.0.24-6.1.x86_64
    libpulse-mainloop-glib0-32bit-0.9.22-6.11.1.x86_64
    pulseaudio-utils-0.9.22-6.11.1.x86_64
    pulseaudio-module-x11-0.9.22-6.11.1.x86_64
    libxine1-pulse-1.1.19-4.4.x86_64
    libpulse0-32bit-0.9.22-6.11.1.x86_64
    alsa-plugins-pulse-1.0.24-6.1.x86_64
    libpulse-mainloop-glib0-0.9.22-6.11.1.x86_64
    pulseaudio-module-jack-0.9.22-6.11.1.x86_64
    pulseaudio-esound-compat-0.9.22-6.11.1.x86_64
    vlc-aout-pulse-1.1.9-1.pm.2.4.x86_64
    opensuse:~ # rpm -q libasound2
    libasound2-1.0.24.1-4.7.1.x86_64
    opensuse:~ # uname -a
    Linux opensuse.site 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 x86_64 x86_64 x86_64 GNU/Linux
    opensuse:~ # cat /etc/modprobe.d/50-sound.conf
    options snd-hda-intel model=asus
    options snd slots=snd-hda-intel
    # 5Dex.EE2h6RUqX_8:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel

    PS: Today, during many tests i have seen another abnormal situation: when insert headphone jack into output terminal at the computer, Kmix are automaticly muted! When unmute with pluged in headphone jack, sound become from loudspеакеr and headphone together.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Internal Microphone not working- help

    Quote Originally Posted by welder_01 View Post
    Hello Dear Suse users and developers.
    I have the same problem with my Asus K50AB. Internal mic not work.
    When apply this line into beginning at 50-sound.conf:

    options snd-hda-intel model=asus

    and restarted alsa from the terminal, worked only external jack microphone input, but not built in - only white noise from him.
    Same effect with model options: auto, lifebook, 3stack, 3stack-dig ... etc.
    What is your reference for using those options. NONE OF THEM are the correct option according to the HD-Audio-Models.txt file associated with version 1.0.24 of alsa. The ONLY model option for the VIA VT17xx series is "auto" . From the HD-Audio-Models.txt file
    Code:
    VIA VT17xx/VT18xx/VT20xx
    ========================
      auto        BIOS setup (default)
    Hence unless 'asus' is some undocumented option for the VT1708 then you should NOT apply that option. That is a MAJOR difference between the Ubuntu setup and the openSUSE setup, and it changes the functionality of your mixer in openSUSE, causing some functions to operate incorrectly IMHO.

    IF you can not get the model=auto to work (where auto IS a correct option, unlike 'asus' which is NOT a listed option) , then you probably should update alsa, per the guidance here: SDB:Alsa-update - openSUSE (ie update libasound2, alsa-plugins-32bit, alsa, alsa-utils, alsa-oss, alsa-plugins, alsa-oss-32bit, alsa-plugins-pulse-32bit, alsa-firmware, and alsa-plugins-pulse). Also install alsa-driver-kmp-desktop suitable for your kernel version.

    Note, after you 'think' you have updated libasound2, alsa-plugins-32bit, alsa, alsa-utils, alsa-oss, alsa-plugins, alsa-oss-32bit, alsa-plugins-pulse-32bit, alsa-firmware, and alsa-plugins-pulse then check the version numbers. If they have not changed then you FAILED to follow the update instructions correctly.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •