Results 1 to 9 of 9

Thread: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2ram s2disk)

  1. #1

    Default SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2ram s2disk)

    Hi - this is a final hopeful call for some help :-)

    pm-hibernate and pm-suspend only work the first time after booting into runlevel 5.

    This behavior is reproducable.

    pm-hibernate starts out correctly but then hangs the system bevore it gets to save the image from memory to disk. The computer locks up and does not power down.

    pm-suspend: on wake up there is no signal on the screen (pm-suspend called from X environment or text terminal shows same result).

    I spent some time reading information on s2ram s2disk and added the follwing options:

    S2RAM_OPTS="-f" in
    /etc/pm/config.d/00meine.config
    (display adapter is GForce4 nvidia with the closed source nvidia driver for accel)

    splash = n in
    /etc/suspend.conf - to get some more information during the suspend / hibernate.

    Any ideas to get pm-hibernate / pm-suspend to work more than one time after boot???

    Thank you for your contributions!!!

    Hibernate would be a great start for daily work and for energy saving.

    Greetings :-)

    horstausdemwald

    PS:
    In runlevel 3 pm-hibernate works various times from a text terminal.

    Under the same condition pm-suspend leads to a scrambled text terminal after resuming (some help on this: using vga=normal in Grub).

    The computer continues to work - though without visual aid - when the text terminal is scarambled. For example Runlevel 5 can be called blindly from the text terminal.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    On 2011-04-13 15:06, horstausdemwald wrote:
    > pm-hibernate starts out correctly but then hangs the system bevore it
    > gets to save the image from memory to disk. The computer locks up and
    > does not power down.


    Try in runlevel 3.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    On Wed, 13 Apr 2011 18:36:02 +0530, horstausdemwald
    <horstausdemwald@no-mx.forums.opensuse.org> wrote:

    >
    > Hi - this is a final hopeful call for some help :-)
    >
    > pm-hibernate and pm-suspend only work the first time after booting into
    > runlevel 5.
    >
    > This behavior is reproducable.
    >
    > pm-hibernate starts out correctly but then hangs the system bevore it
    > gets to save the image from memory to disk. The computer locks up and
    > does not power down.
    >
    > pm-suspend: on wake up there is no signal on the screen (pm-suspend
    > called from X environment or text terminal shows same result).
    >
    > I spent some time reading information on s2ram s2disk and added the
    > follwing options:
    >
    > S2RAM_OPTS="-f" in
    > /etc/pm/config.d/00meine.config
    > (display adapter is GForce4 nvidia with the closed source nvidia driver
    > for accel)
    >
    > splash = n in
    > /etc/suspend.conf - to get some more information during the suspend /
    > hibernate.
    >
    > Any ideas to get pm-hibernate / pm-suspend to work more than one time
    > after boot???
    >
    > Thank you for your contributions!!!
    >
    > Hibernate would be a great start for daily work and for energy saving.
    >
    > Greetings :-)
    >
    > horstausdemwald
    >
    > PS:
    > In runlevel 3 pm-hibernate works various times from a text terminal.
    >
    > Under the same condition pm-suspend leads to a scrambled text terminal
    > after resuming (some help on this: using vga=normal in Grub).
    >
    > The computer continues to work - though without visual aid - when the
    > text terminal is scarambled. For example Runlevel 5 can be called
    > blindly from the text terminal.
    >


    same thing happened to me while on openSUSE 11.3. i didn't do any research
    since the main board was flaky anyway, so i assumed that to be the reason.
    now, with a new MB & 11.4, suspend to RAM or disk works as expected,
    repeatedly. is upgrading an option for you?

    --
    phani.

  4. #4

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    Thank you for your suggestion. I tried this ... in runlevel 3 ... and it basically works unlimited times - though pm-suspend shows some side affects:

    In runlevel 3 pm-hibernate works various times from a text terminal.

    Under the same condition pm-suspend leads to a scrambled text terminal after resuming (some help on this: using vga=normal in Grub).

    The computer continues to work - though without visual aid - when the text terminal is scarambled. For example Runlevel 5 can be called blindly from the text terminal.
    Any idea what this could lead to ... to get the problem solved for runlevel 5?

    Thanks!

  5. #5

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    What could the benefit of openSUSE 11.4 be to fix this problem with respect to pm-utils (s2ram / s2disk)?

    (Everything else I have working fine with 11.3).

    Ideas?

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    On Thu, 14 Apr 2011 03:06:02 +0530, horstausdemwald
    <horstausdemwald@no-mx.forums.opensuse.org> wrote:

    >
    > What could the benefit of openSUSE 11.4 be to fix this problem with
    > respect to pm-utils (s2ram / s2disk)?
    >
    > (Everything else I have working fine with 11.3).
    >
    > Ideas?
    >


    sorry, no.

    if everything else works fine, and you're not planning to upgrade to 11.4
    any time soon -- why should you if (almost) everything works -- you'll
    have to figure out how to solve this on 11.3. i remember different threads
    in these forums, perhaps also mailing lists, dealing with this.

    for me it just started working at 11.4, but that might not be the case for
    you.

    --
    phani.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    On 2011-04-13 23:36, horstausdemwald wrote:

    > Any idea what this could lead to ... to get the problem solved for
    > runlevel 5?


    To learn if video graphics is the problem.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    OK ... video graphics seem to be the problem (articles on nvidia recommend using the "-f" option - which I am doing - and seeing to it that there is no AGP interfering - except the driver's => I took care of this and checked).

    Interesting enough there is a failure only the second time I use pm-suspend / pm-hibernate after a reboot .

    Any further ideas to find a possible fix ???

    Thanks,

    DH

    Any ideas what path to go down?

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SUSE 11.3 Only 1st time after boot OK: hibernate + suspend (s2rams2disk)

    On 2011-04-14 23:06, horstausdemwald wrote:
    > OK ... video graphics seem to be the problem (articles on nvidia

    ....
    > Any further ideas to find a possible fix ???


    In my case the opensource driver crashes the machine (11.2), and the closed
    source one works fine.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •