Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: 11.4 wont boot from SATA drive

  1. #1

    Default 11.4 wont boot from SATA drive

    Hi

    I have just installed opensuse 11.4 and the install fails to boot, grub hangs or gives an error.

    I have tried installing grub in MBR and root changed every setting I can find and even downloaded a fresh ISO. As a last resort I changed the machines BOIS settings from SATA to emulate ide, booted as expected but a bit slow.

    11.2 and 11.3 worked on this machine with no problems. Am i missing something? I also tried an Ubuntu install and this worked fine!

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.4 wont boot from SATA drive

    si1975 wrote:

    >
    > Hi
    >
    > I have just installed opensuse 11.4 and the install fails to boot, grub
    > hangs or gives an error.
    >

    Which error exactly, please post it.

    Please provide some more details about your harddisk, bios, manufacturer.
    Otherwise we can only guess.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
    ION | 3GB Ram

  3. #3

    Default Re: 11.4 wont boot from SATA drive

    Your initial ramdisk is missing something: the sata kernel module. If you switch to IDE mode, the hard disks are handled in PIO mode and the I/O is then extremely slow.
    Can you boot from live CD and issue this command:
    Code:
    lsmod | grep ata
    Then check /etc/sysconfig/kernel on your installed system:

    Code:
    grep "^INITRD_MODULES" /etc/sysconfig/kernel
    You should add the missing sata module here and run /sbin/mkinitrd.

    * And of course, forget about IDE mode !

  4. #4

    Default Re: 11.4 wont boot from SATA drive

    Thanks for the replies.

    machine is: 2.4Ghz Pentium 4 | GigabyteGA-81PE1000 motherboard | Intel 865PE AGPSet BIOS| seagate
    barracuda 7200.7 SATA hard drive | 3GB RAM | GeForce 6200 | ide cd/dvd writer.

    The GRUB error with SATA enabled is:

    "GRUB Loading stage1.5

    GRUB loading, please wait . . .
    Error 21
    _"

    The machine then hangs and has to be rebooted.


    Running a live cd (opensuse 11.3 is all i can get my hands on) "lsmod | grep ata" shows:

    ata_generic 2711 0
    ata_piix 19945 1
    libata 185684 3 ata_generic,ata_piix,ahci
    scsi_mod 189241 5 st,sg,sr_mod,sd_mod,libata

    then "grep "^INITRD_MODULES" /etc/sysconfig/kernel" on the installed system shows:

    INITRD_MODULES="thermal ata_piix ata_generic processor fan"

    I'm not 100% sure which bit to add.

  5. #5

    Default Re: 11.4 wont boot from SATA drive

    ata_pixx should be the module you need for your Intel board. It is there. So in IDE mode, Grub finds the hard disk an boots while in SATA mode in does not? I assume you didn't switch the mode just after installing the system, which could produce such an issue. What do you mean by SATA mode, AHCI? Can you boot with the live CD while in IDE mode and while in SATA/AHCI mode and run fdisk -l in both cases to check the differences. You will pretty much have to reinstall Grub. You said you installed Ubuntu in the meantime? Which version of Grub is in your MBR right now?

  6. #6

    Default Re: 11.4 wont boot from SATA drive

    So in IDE mode, Grub finds the hard disk an boots while in SATA mode in does not?

    Yes the machine hangs in SATA mode, the install failed half way through when the system restarted and ejected the DVD. This is when I changed the BIOS settings. The BOIS has a "integrated peripherals" page where the SATA port can be set in compatible mode to remap as IDE primary master. I can't find any mention of AHCI in my BIOS settings.

    My current GRUB version is: GNU GRUB version 0.97

    For some reason my machine will not boot the live CD while the SATA drive is emulating IDE.

    Do you have any pointers for reinstalling grub?

    Thanks for the advice.

  7. #7

    Default Re: 11.4 wont boot from SATA drive

    I just noticed that you ran openSUSE 11.3 live CD. That doesn't help since you already know that 11.3 worked on this machine. You should boot 11.4 and check if the ata_piix module has been loaded. I would also test the media from which you installed 11.4. Tell us what you did exactly. Fresh install or update? Are there other operating systems on this machine? How many hard disks do you have, etc? And what do you intend to do? Single boot, dualboot, etc.

  8. #8

    Default Re: 11.4 wont boot from SATA drive

    I wont get back to the desktop machine till tomorrow so cant check
    ata_piix module has been loaded till then.

    Here is the list of attempted installs:

    Started with a working version of 11.3 booting from the sata drive. I had not changed any BOIS settings for years.

    Installed 11.4 from a live dvd (magazine cover disk) as an upgrade. The machine booted and ran as expected. A few problems with KDE and my old user area so i decided to to a clean install.

    11.4 clean install from live dvd (magazine cover disk) default settings and partition table. Failed to boot with grub error: Error 21

    Another 11.4 clean install from live dvd (magazine cover disk). All settings checked manually, fdisk and format of harddisk. Failed to boot with grub error: Error 21. Tried again and installed grub into the MBR instead of root partition. Still failed to boot and grub hung with no error just blank screen.

    Tried mythbunto install from same DVD worked and booted as expected.

    Downloaded full 11.4 install iso from opensuse mirror. Checked md5 and install media checked. Clean install with default settings and partition table. Failed to boot.

    Yet another clean install all settings checked manually fdisk and format of harddisk. Grub installed into MBR. Failed to boot, changed BIOS setting for SATA to remap to ide. BOOTED!

    I am running a single boot system with one harddisk. I no longer have the 11.4 live dvd but will do another full clean install if i can get the system working with SATA.

  9. #9

    Default Re: 11.4 wont boot from SATA drive

    Have tried to rollback to 11.3 from live dvd (drive set as SATA). This also fails to boot half way though the install when the system resets. I get the GRUB prompt with no errors.

    Am I correct in thinking this is an MRB problem?

    Changed the BIOS setting for SATA to remap to ide and 11.3 booted and competed the install, now i'm confused.

  10. #10

    Default Re: 11.4 wont boot from SATA drive

    Found an old winXP DVD and ran FIXMBR and did another format. Did an 11.4 install from DVD with drive set to sata. I now get a GRUB prompt with no errors. I'm guesing this should boot with the correct grub command.

    Can anyone help?

    If i boot from the install DVD then select "boot installed system" it goes back to the GRUB prompt.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •