Results 1 to 7 of 7

Thread: Wireless option greyed out

  1. #1
    Join Date
    Apr 2011
    Location
    Birmingham, UK
    Posts
    3

    Default Wireless option greyed out

    When I go to connect my computer to my wireless internet the option for wireless is greyed out as well as Wired, Mobile Broadband and DSL. I was able to connect to my wireless internet with no problems when I tried it on the Live CD so is this happening now? I have only just installed it, I am running 32-bit OpenSUSE 11.4 KDE.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Wireless option greyed out

    On 04/12/2011 01:36 PM, chrispynegar wrote:
    >
    > When I go to connect my computer to my wireless internet the option for
    > wireless is greyed out as well as Wired, Mobile Broadband and DSL. I was
    > able to connect to my wireless internet with no problems when I tried it
    > on the Live CD so is this happening now? I have only just installed it,
    > I am running 32-bit OpenSUSE 11.4 KDE.


    Wireless is being blocked. The most-likely reason is that an rfkill switch is in
    the wrong state. What does the following report?

    Code:
    /usr/sbin/rfkill list
    If you get a "command not found" response, then install with

    Code:
    sudo zypper in rfkill
    If rfkill reports a hard block, that is a switch. How you fix that depends on
    your laptop model and how the radio on/off button/switch is configured.

  3. #3
    Join Date
    Apr 2011
    Location
    Birmingham, UK
    Posts
    3

    Default Re: Wireless option greyed out

    It reports back Soft blocked: no and Hard blocked: no.

    Here is an image of how it looks on my screen:


  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,681
    Blog Entries
    3

    Default Re: Wireless option greyed out

    Your problem is that NetworkManager (the system process) is not running.

    In Yast, go to "Network Devices" then select "Network Settings".

    Click on the "Global Options" tab. Select "User controlled with NetworkManager"

    Accept the changes.

    When that is completed, the red X in your system tray should turn into the icon for the KDE network manager applet (probably the plasmoid), and you should be able to configure wireless. It's possible that you might have to reboot once to make sure that all of the changes take properly.

    Oh, and the settings for your wired connection will also revert to using NetworkManager.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Wireless option greyed out

    On 04/13/2011 07:06 AM, chrispynegar wrote:
    >
    > It reports back Soft blocked: no and Hard blocked: no.
    >
    > Here is an image of how it looks on my screen:
    >
    > [image: http://chrispynegar.net/images/snapshot1.png]


    OK, now we know it is not rfkill that is blocking.

    On your screen shot, I don't see the wireless applet's icon. Are you running
    NetworkManager? If so, which applet?

  6. #6
    Join Date
    Apr 2011
    Location
    Birmingham, UK
    Posts
    3

    Default Re: Wireless option greyed out

    That sorted my problem, the NetworkManager wasn't running. Thank you both for the support

  7. #7

    Default Re: Wireless option greyed out

    Thanks. I was fixing to kick suse to the curb.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •