Results 1 to 5 of 5

Thread: turn off keyring

  1. #1

    Default turn off keyring

    At boot time I get asked to input my password to open the keyring. I don't need this level of security and want to either pass the password in a script or disable the keyring without disallowing my wireless connection. How do I do that and where do I find out about this keyring thing? TIA

  2. #2

    Default Re: turn off keyring

    bump bump bump

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: turn off keyring

    argon99 wrote:

    >
    > bump bump bump
    >

    try this
    Code:
    rm ~/.gnome2/keyrings/default.keyring
    Next time keyring asks your for new passwords enter two times empty
    passwords.

    If that does not help, try this
    http://ubuntu-tutorials.com/2010/01/...g-password-on-
    ubuntu/

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
    ION | 3GB Ram

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: turn off keyring

    Are you talking about the gnome keyring, or about kwallet in KDE?
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: turn off keyring

    Quote Originally Posted by argon99 View Post
    At boot time I get asked to input my password to open the keyring. I don't need this level of security and want to either pass the password in a script or disable the keyring without disallowing my wireless connection. How do I do that and where do I find out about this keyring thing? TIA
    keyring = credentials repository
    You can maintain certificates (and other security credentials) in different separate groups, ie. keyrings

    So, it sounds as though when your system boots up, something is running that needs security credentials and it sounds like it's your wireless connection. If your wireless connection is "open" (no credentials) then a connection can be made without accessing a keyring but yours appears to require <and> it appears that your network connection is invoked on bootup (likely using IFUP/IFDOWN) instead of on User Login (typically using Knetworkmanager or Gnome Network Manager).

    Solution 1
    If your machine is a laptop and you move between wireless AP, you should not be connecting on bootup. Configure your network settings to use "Network Manager" instead.

    Solution 2
    If you really want your system to connect to wireless on bootup <without> a User logged in, then you need to provide network credentials to networking services either without a keyring (eg WPA_SUPPLICANT.CONF hashed password) or in a keyring the system can access.

    HTH,
    Tony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •